Bug 108867 - [CI][DRMTIP] igt@kms_flip_tiling@flip-to-y-tiled / igt@kms_rotation_crc@* - fail - Exceeded timeout (\d+ms) while waiting for a pageflip
Summary: [CI][DRMTIP] igt@kms_flip_tiling@flip-to-y-tiled / igt@kms_rotation_crc@* - f...
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium major
Assignee: Juha-Pekka Heikkilä
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-26 15:39 UTC by Lakshmi
Modified: 2019-05-07 10:51 UTC (History)
3 users (show)

See Also:
i915 platform: CNL, ICL
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2018-11-26 15:39:43 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_144/fi-cnl-u/igt@kms_flip_tiling@flip-to-y-tiled.html

	
Starting subtest: flip-to-Y-tiled
(kms_flip_tiling:1083) igt_kms-CRITICAL: Test assertion failure function kmstest_wait_for_pageflip, file ../lib/igt_kms.c:1501:
(kms_flip_tiling:1083) igt_kms-CRITICAL: Failed assertion: ret == 1
(kms_flip_tiling:1083) igt_kms-CRITICAL: Last errno: 25, Inappropriate ioctl for device
(kms_flip_tiling:1083) igt_kms-CRITICAL: error: 0 != 1
Subtest flip-to-Y-tiled failed.
**** DEBUG ****
(kms_flip_tiling:1083) ioctl_wrappers-DEBUG: Test requirement passed: igt_has_fb_modifiers(fd)
(kms_flip_tiling:1083) DEBUG: Test requirement passed: data.gen >= 9
(kms_flip_tiling:1083) igt_debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(kms_flip_tiling:1083) igt_kms-DEBUG: display: eDP-1: set_pipe(A)
(kms_flip_tiling:1083) igt_kms-DEBUG: display: eDP-1: Selecting pipe A
(kms_flip_tiling:1083) igt_kms-DEBUG: Test requirement passed: plane_idx >= 0 && plane_idx < pipe->n_planes
(kms_flip_tiling:1083) igt_fb-DEBUG: igt_create_fb_with_bo_size(width=2048, height=1080, format=0x34325258, tiling=0x0, size=0)
(kms_flip_tiling:1083) igt_fb-DEBUG: igt_create_fb_with_bo_size(handle=1, pitch=8192)
(kms_flip_tiling:1083) ioctl_wrappers-DEBUG: Test requirement passed: igt_has_fb_modifiers(fd)
(kms_flip_tiling:1083) igt_fb-DEBUG: Test requirement passed: cairo_surface_status(fb->cairo_surface) == CAIRO_STATUS_SUCCESS
(kms_flip_tiling:1083) igt_fb-DEBUG: igt_create_fb_with_bo_size(width=2048, height=1080, format=0x34325258, tiling=0x100000000000002, size=0)
(kms_flip_tiling:1083) drmtest-DEBUG: Test requirement passed: is_i915_device(fd) && has_known_intel_chipset(fd)
(kms_flip_tiling:1083) drmtest-DEBUG: Test requirement passed: is_i915_device(fd) && has_known_intel_chipset(fd)
(kms_flip_tiling:1083) igt_fb-DEBUG: igt_create_fb_with_bo_size(handle=2, pitch=8192)
(kms_flip_tiling:1083) ioctl_wrappers-DEBUG: Test requirement passed: igt_has_fb_modifiers(fd)
(kms_flip_tiling:1083) igt_kms-DEBUG: display: A.0: plane_set_fb(159)
(kms_flip_tiling:1083) igt_kms-DEBUG: display: A.0: plane_set_size (2048x1080)
(kms_flip_tiling:1083) igt_kms-DEBUG: display: A.0: fb_set_position(0,0)
(kms_flip_tiling:1083) igt_kms-DEBUG: display: A.0: fb_set_size(2048x1080)
(kms_flip_tiling:1083) igt_kms-DEBUG: display: commit {
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     Fixing up initial rotation pipe A, plane 0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     eDP-1: SetCrtc pipe A, fb 159, src (0, 0), mode 1920x1080
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     Fixing up initial rotation pipe A, plane 1
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetPlane pipe A, plane 1, disabling
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane A.1 "rotation" to 0x1/1
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane A.1 "COLOR_ENCODING" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane A.1 "COLOR_RANGE" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     Fixing up initial rotation pipe A, plane 2
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetPlane pipe A, plane 2, disabling
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane A.2 "rotation" to 0x1/1
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane A.2 "COLOR_ENCODING" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane A.2 "COLOR_RANGE" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     Fixing up initial rotation pipe A, plane 3
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetPlane pipe A, plane 3, disabling
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane A.3 "rotation" to 0x1/1
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane A.3 "COLOR_ENCODING" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane A.3 "COLOR_RANGE" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     Fixing up initial rotation pipe A, plane 4
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetCursor pipe A, disabling
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     MoveCursor pipe A, (0, 0)
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     Fixing up initial rotation pipe B, plane 0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetCrtc pipe B, disabling
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     Fixing up initial rotation pipe B, plane 1
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetPlane pipe B, plane 1, disabling
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane B.1 "rotation" to 0x1/1
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane B.1 "COLOR_ENCODING" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane B.1 "COLOR_RANGE" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     Fixing up initial rotation pipe B, plane 2
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetPlane pipe B, plane 2, disabling
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane B.2 "rotation" to 0x1/1
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane B.2 "COLOR_ENCODING" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane B.2 "COLOR_RANGE" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     Fixing up initial rotation pipe B, plane 3
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetPlane pipe B, plane 3, disabling
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane B.3 "rotation" to 0x1/1
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane B.3 "COLOR_ENCODING" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane B.3 "COLOR_RANGE" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     Fixing up initial rotation pipe B, plane 4
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetCursor pipe B, disabling
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     MoveCursor pipe B, (0, 0)
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     Fixing up initial rotation pipe C, plane 0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetCrtc pipe C, disabling
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     Fixing up initial rotation pipe C, plane 1
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetPlane pipe C, plane 1, disabling
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane C.1 "rotation" to 0x1/1
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane C.1 "COLOR_ENCODING" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane C.1 "COLOR_RANGE" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     Fixing up initial rotation pipe C, plane 2
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetPlane pipe C, plane 2, disabling
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane C.2 "rotation" to 0x1/1
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane C.2 "COLOR_ENCODING" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane C.2 "COLOR_RANGE" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     Fixing up initial rotation pipe C, plane 3
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetPlane pipe C, plane 3, disabling
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane C.3 "rotation" to 0x1/1
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane C.3 "COLOR_ENCODING" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetProp plane C.3 "COLOR_RANGE" to 0x0/0
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     Fixing up initial rotation pipe C, plane 4
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     SetCursor pipe C, disabling
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     MoveCursor pipe C, (0, 0)
(kms_flip_tiling:1083) igt_kms-DEBUG: display: }
(kms_flip_tiling:1083) igt_debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(kms_flip_tiling:1083) igt_kms-DEBUG: display: A.0: plane_set_fb(157)
(kms_flip_tiling:1083) igt_kms-DEBUG: display: A.0: plane_set_size (2048x1080)
(kms_flip_tiling:1083) igt_kms-DEBUG: display: A.0: fb_set_position(0,0)
(kms_flip_tiling:1083) igt_kms-DEBUG: display: A.0: fb_set_size(2048x1080)
(kms_flip_tiling:1083) igt_kms-DEBUG: display: commit {
(kms_flip_tiling:1083) igt_kms-DEBUG: display:     eDP-1: SetCrtc pipe A, fb 157, src (0, 0), mode 1920x1080
(kms_flip_tiling:1083) igt_kms-DEBUG: display: }
(kms_flip_tiling:1083) DEBUG: Test requirement passed: ret == 0
(kms_flip_tiling:1083) igt_kms-CRITICAL: Test assertion failure function kmstest_wait_for_pageflip, file ../lib/igt_kms.c:1501:
(kms_flip_tiling:1083) igt_kms-CRITICAL: Failed assertion: ret == 1
(kms_flip_tiling:1083) igt_kms-CRITICAL: Last errno: 25, Inappropriate ioctl for device
(kms_flip_tiling:1083) igt_kms-CRITICAL: error: 0 != 1
(kms_flip_tiling:1083) igt_core-INFO: Stack trace:
(kms_flip_tiling:1083) igt_core-INFO:   #0 ../lib/igt_core.c:1467 __igt_fail_assert()
(kms_flip_tiling:1083) igt_core-INFO:   #1 ../lib/igt_kms.c:1502 kmstest_wait_for_pageflip()
(kms_flip_tiling:1083) igt_core-INFO:   #2 ../tests/kms_flip_tiling.c:127 test_flip_tiling()
(kms_flip_tiling:1083) igt_core-INFO:   #3 ../tests/kms_flip_tiling.c:264 __real_main143()
(kms_flip_tiling:1083) igt_core-INFO:   #4 ../tests/kms_flip_tiling.c:143 main()
(kms_flip_tiling:1083) igt_core-INFO:   #5 ../csu/libc-start.c:344 __libc_start_main()
(kms_flip_tiling:1083) igt_core-INFO:   #6 [_start+0x2a]
****  END  ****
Subtest flip-to-Y-tiled: FAIL (0.265s)
Comment 1 Lakshmi 2018-12-21 09:04:03 UTC
On ICL
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_176/fi-icl-u3/igt@kms_rotation_crc@primary-y-tiled-reflect-x-270.html

Starting subtest: primary-y-tiled-reflect-x-270
(kms_rotation_crc:1201) igt_kms-CRITICAL: Test assertion failure function kmstest_wait_for_pageflip, file ../lib/igt_kms.c:1501:
(kms_rotation_crc:1201) igt_kms-CRITICAL: Failed assertion: ret == 1
(kms_rotation_crc:1201) igt_kms-CRITICAL: Last errno: 25, Inappropriate ioctl for device
(kms_rotation_crc:1201) igt_kms-CRITICAL: error: 0 != 1
Subtest primary-y-tiled-reflect-x-270 failed.
Comment 2 Jani Saarinen 2019-01-18 11:49:14 UTC
This has been seen only 2 times and last time on drmtip_176.
Comment 3 CI Bug Log 2019-01-25 12:25:28 UTC
A CI Bug Log filter associated to this bug has been updated:

{- CNL ICL: igt@kms_flip_tiling@flip-to-y-tiled|igt@kms_rotation_crc@primary-y-tiled-reflect-x-270 - fail - Failed assertion: ret == 1\n[^\n]+Last errno: 25,  -}
{+ CNL ICL: igt@kms_flip_tiling@flip-to-y-tiled|igt@kms_rotation_crc@primary-y-tiled-reflect-x-270|90 - fail - Failed assertion: ret == 1\n[^\n]+Last errno: 25,  +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_183/fi-icl-u3/igt@kms_rotation_crc@primary-y-tiled-reflect-x-90.html
Comment 4 CI Bug Log 2019-01-25 12:28:36 UTC
A CI Bug Log filter associated to this bug has been updated:

{- CNL ICL: igt@kms_flip_tiling@flip-to-y-tiled|igt@kms_rotation_crc@primary-y-tiled-reflect-x-270|90 - fail - Failed assertion: ret == 1\n[^\n]+Last errno: 25,  -}
{+ CNL ICL: igt@kms_flip_tiling@flip-to-y-tiled|igt@kms_rotation_crc@primary-y-tiled-reflect-x-270|90|180 - fail - Failed assertion: ret == 1\n[^\n]+Last errno: 25 +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_190/fi-icl-u3/igt@kms_rotation_crc@primary-y-tiled-reflect-x-180.html
Comment 5 CI Bug Log 2019-02-28 12:15:18 UTC
A CI Bug Log filter associated to this bug has been updated:

{- CNL ICL: igt@kms_flip_tiling@flip-to-y-tiled|igt@kms_rotation_crc@primary-y-tiled-reflect-x-270|90|180 - fail - Failed assertion: ret == 1\n[^\n]+Last errno: 25 -}
{+ CNL ICL: igt@kms_flip_tiling@flip-to-y-tiled|igt@kms_rotation_crc@primary-* - fail - Failed assertion: ret == 1\n[^\n]+Last errno: 25 +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_232/fi-icl-y/igt@kms_rotation_crc@primary-x-tiled-reflect-x-180.html
Comment 6 CI Bug Log 2019-02-28 12:19:45 UTC
A CI Bug Log filter associated to this bug has been updated:

{- CNL ICL: igt@kms_flip_tiling@flip-to-y-tiled|igt@kms_rotation_crc@primary-* - fail - Failed assertion: ret == 1\n[^\n]+Last errno: 25 -}
{+ CNL ICL: igt@kms_flip_tiling@flip-to-y-tiled|igt@kms_rotation_crc@* - fail - Failed assertion: ret == 1\n[^\n]+Last errno: 25 +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_232/fi-icl-y/igt@kms_rotation_crc@sprite-rotation-90.html
Comment 7 Arek Hiler 2019-04-04 12:32:02 UTC
The issue is strange. Noways it is seen only on ICL-y. ICL-u seems fine.

The failure is us waiting for pageflip to happen (select()) with a timeout of 50ms, but we exceed that timeout.

The errno we see in the error is random noise and not relevant to the issue. I'll work on improved logging here.
Comment 8 Arek Hiler 2019-04-04 12:42:35 UTC
There were issues with IRQ storms, which seems to be solved now by a BIOS update. Let's see if we still can reproduce this with drmtip_248. 

If the issue is sill here then we may try to wait longer to see if a pageflip is comming at all, as it may take some time to reconfigure the HW. But 50ms should be plenty anyway...
Comment 9 Lakshmi 2019-04-04 12:44:58 UTC
Customer impact assessment will be added after looking at drmtip_248 results.
Comment 10 Arek Hiler 2019-04-05 04:58:11 UTC
This commit improves logging for this issue:
https://patchwork.freedesktop.org/patch/296260/
Comment 11 CI Bug Log 2019-04-05 07:21:41 UTC
A CI Bug Log filter associated to this bug has been updated:

{- CNL ICL: igt@kms_flip_tiling@flip-to-y-tiled|igt@kms_rotation_crc@* - fail - Failed assertion: ret == 1\n[^\n]+Last errno: 25 -}
{+ CNL ICL: igt@kms_flip_tiling@flip-to-y-tiled|igt@kms_rotation_crc@* - fail - Failed assertion: ret == 1\n[^\n]+Last errno: 25 / Exceeded timeout (\d+ms) while waiting for a pageflip +}

 No new failures caught with the new filter
Comment 12 Jani Saarinen 2019-04-05 11:09:43 UTC
JP did you saw this issue still?
Comment 13 Jani Saarinen 2019-04-05 11:11:13 UTC
Also same question to Stan?
Comment 14 Stanislav Lisovskiy 2019-04-05 11:39:20 UTC
(In reply to Jani Saarinen from comment #13)
> Also same question to Stan?

Yes, timeout while waiting for page flip is still visible. Even though it doesn't hang anymore.
Comment 15 CI Bug Log 2019-04-10 13:17:43 UTC
A CI Bug Log filter associated to this bug has been updated:

{- CNL ICL: igt@kms_flip_tiling@flip-to-y-tiled|igt@kms_rotation_crc@* - fail - Failed assertion: ret == 1\n[^\n]+Last errno: 25 / Exceeded timeout (\d+ms) while waiting for a pageflip -}
{+ CNL ICL: igt@kms_flip_tiling@flip-to-y-tiled / igt@kms_rotation_crc@* - fail -  Exceeded timeout (\d+ms) while waiting for a pageflip +}

 No new failures caught with the new filter
Comment 16 Jani Saarinen 2019-04-22 14:34:15 UTC
on u2/u3 and shards BIOS updates made, this only seen on ICL-Y
Comment 17 Jani Saarinen 2019-04-29 13:01:06 UTC
On ICL-y there were i2c changes made and why issue might not been seen also on ICL-Y anymore.
Comment 18 Jani Saarinen 2019-05-06 08:21:23 UTC
Now this was seen on every build before and after change nothing, I would consider this fixed by making i2c IRQ change. Lowering priority
Comment 19 Jani Saarinen 2019-05-07 10:51:33 UTC
Was happening on every builds and stopped on seeing after drmtip_252
Resolving.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.