Bug 108877 - OpenGL CTS gl43 test cases were interrupted due to segment fault
Summary: OpenGL CTS gl43 test cases were interrupted due to segment fault
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: 18.3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-27 08:05 UTC by Chen Xi
Modified: 2019-01-23 05:19 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
glxinfo and other logs (134.52 KB, application/zip)
2018-11-27 08:08 UTC, Chen Xi
Details
display 0 glxinfo and other logs (147.45 KB, application/zip)
2018-11-27 09:56 UTC, Chen Xi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chen Xi 2018-11-27 08:05:25 UTC
Test Environment
Platform: KBL-G (Intel NUC i7)
CPU: Intel (R) Core (TM) i7-8809G CPU @3.10GHz
GPU: AMD(Radeon RX Vega M GH Graphics)
Memory: 16G
OS: Ubutu16.04
Kernel: 4.18.0-rc3
amd driver version: amdgpu-pro-18.40-673869-ubuntu-16.04.tar.xz (Open Stack) 
VK-GL-CTS: https://github.com/KhronosGroup/VK-GL-CTS (commit id:54e546a1a0a6fa412ea4c3e3081bbc9518928a6e)

Run opengl cts gl43 test cases with below command
run command:
$ ./cts-runner --type=gl43

Segment fault were encountered when run into "KHR-GL43.stencil_texturing.functional"

More info:
Did not encounter segment fault if running just the single case:
/glcts -n KHR-GL43.stencil_texturing.functional
With AMD driver 18.10 (amdgpu-pro-18.10-516951.tar.gz (open stack)) the test passed
Comment 1 Chen Xi 2018-11-27 08:08:49 UTC
Created attachment 142625 [details]
glxinfo and other logs

Attached the logs captured following guidance from:
https://amdgpu-install.readthedocs.io/en/latest/install-bugrep.html
Comment 2 Chen Xi 2018-11-27 09:56:33 UTC
Created attachment 142630 [details]
display 0 glxinfo and other logs

Update the glxinfo and other logs captured from display 0
Comment 3 Chen Xi 2019-01-02 10:36:16 UTC
Hi, Is there any update for this issue?
Comment 4 Marek Olšák 2019-01-17 16:54:42 UTC
This issue should be fixed with these two patches:

https://patchwork.freedesktop.org/patch/276824/
https://patchwork.freedesktop.org/patch/276858/
Comment 5 Hai 2019-01-23 05:18:42 UTC
With these two patches, this issue can't reproduce.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.