Bug 108878 - OpenGL CTS KHR-GL31.transform_feedback.api_errors_test failed
Summary: OpenGL CTS KHR-GL31.transform_feedback.api_errors_test failed
Status: RESOLVED NOTOURBUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: 18.3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-27 08:13 UTC by Chen Xi
Modified: 2019-01-09 11:41 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
glxinfo and other logs (108.79 KB, application/zip)
2018-11-27 08:15 UTC, Chen Xi
Details
Update glxinfo log from DISPLAY 0 (121.72 KB, application/zip)
2018-11-27 10:02 UTC, Chen Xi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chen Xi 2018-11-27 08:13:07 UTC
Test Environment
Platform: KBL-G (Intel NUC i7)
CPU: Intel (R) Core (TM) i7-8809G CPU @3.10GHz
GPU: AMD(Radeon RX Vega M GH Graphics)
Memory: 16G
OS: Ubutu16.04
Kernel: 4.18.0-rc3
amd driver version: amdgpu-pro-18.40-673869-ubuntu-16.04.tar.xz (Open Stack) 
VK-GL-CTS: https://github.com/KhronosGroup/VK-GL-CTS (commit id:54e546a1a0a6fa412ea4c3e3081bbc9518928a6e)


When running the test case, got the test failed result from the test tool
./glcts -n KHR-GL31.transform_feedback.api_errors_test
Writing test log into TestResults.qpa
dEQP Core unknown (0xcafebabe) starting..
target implementation = 'Default'

Test case 'KHR-GL31.transform_feedback.api_errors_test'..
Fail (Fail)

DONE!

Test run totals:
Passed: 0/1 (0.0%)
Failed: 1/1 (100.0%)
Not supported: 0/1 (0.0%)
Warnings: 0/1 (0.0%)

More info:
With AMD driver 18.10 (amdgpu-pro-18.10-516951.tar.gz (open stack)) the test passed.
Comment 1 Chen Xi 2018-11-27 08:15:00 UTC
Created attachment 142626 [details]
glxinfo and other logs

Attached the logs captured following guidance from:
https://amdgpu-install.readthedocs.io/en/latest/install-bugrep.html
Comment 2 Chen Xi 2018-11-27 10:02:07 UTC
Created attachment 142632 [details]
Update glxinfo log from DISPLAY 0

Update glxinfo and other logs from DISPLAY 0
Comment 3 Hai 2019-01-02 06:39:25 UTC
This issue is caused by missing ARB_geometry_shader4 in AMD driver. Is it possible to enable ARB_geometry_shader4 for OpenGL 3.1 driver? Or this function needs OpenGL 3.2? Thanks.
Comment 4 Hai 2019-01-09 06:32:46 UTC
Since ARB_geometry_shader4 is from OpenGL 3.2, this issue is a test case bug rather than mesa bug. Will close it.
Comment 5 Ilia Mirkin 2019-01-09 11:41:36 UTC
(In reply to Hai from comment #4)
> Since ARB_geometry_shader4 is from OpenGL 3.2, this issue is a test case bug
> rather than mesa bug. Will close it.

Note that ARB_geometry_shader4 is actually a separate extension, with functionality that's slightly different than what's included in GL 3.2 core. Mesa has no current plans to implement that extension.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.