Bug 108901 - [CI][SHARDS] igt@debugfs_test@read_all_entries - incomplete
Summary: [CI][SHARDS] igt@debugfs_test@read_all_entries - incomplete
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-29 15:13 UTC by Martin Peres
Modified: 2019-08-03 11:32 UTC (History)
1 user (show)

See Also:
i915 platform: SKL
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-11-29 15:13:10 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5218/shard-skl5/igt@debugfs_test@read_all_entries.html

<6> [597.580674] Console: switching to colour dummy device 80x25
<6> [597.581709] [IGT] debugfs_test: executing
<6> [597.632196] [IGT] debugfs_test: starting subtest read_all_entries
Comment 1 Arek Hiler 2019-07-22 13:52:10 UTC
This test is opening every entry in /sys/kernel/debug/dri/* and reading it.

DebugFS are meant to be used by developers and does not constitute a stable ABI. The entries are radable only by the root.

Occasional (every few months) crashes by reading it across the whole farm of machines have no impact on users and very small impact on the CI. Lowering the priority to medium for now.

Most of the failures I've seen in the past are caused by broken structure traversal, usually because of insufficient locking. Those crashes are hard to fight as we can only hope that we will get pstore having a relevant backtrace to even know which entry to investigate.
Comment 2 Chris Wilson 2019-08-03 11:32:57 UTC
Stale link, we have no clue where the lockup occurred.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.