Bug 108932 - [CI][DRMTIP] igt@kms_atomic_transition@1x-modeset-transitions-fencing|nonblocking - fail - HDMI-A-2 and eDP-1 are both trying to use pipe C
Summary: [CI][DRMTIP] igt@kms_atomic_transition@1x-modeset-transitions-fencing|nonbloc...
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: low normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-03 17:25 UTC by Martin Peres
Modified: 2019-03-08 17:09 UTC (History)
1 user (show)

See Also:
i915 platform: ICL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-12-03 17:25:08 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_153/fi-icl-u3/igt@kms_atomic_transition@1x-modeset-transitions-fencing.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_152/fi-icl-u3/igt@kms_atomic_transition@1x-modeset-transitions-fencing.html

Starting subtest: 1x-modeset-transitions-fencing
(kms_atomic_transition:1959) igt_kms-CRITICAL: Test assertion failure function igt_display_refresh, file ../lib/igt_kms.c:2202:
(kms_atomic_transition:1959) igt_kms-CRITICAL: Failed assertion: output->pending_pipe != b->pending_pipe
(kms_atomic_transition:1959) igt_kms-CRITICAL: Last errno: 25, Inappropriate ioctl for device
(kms_atomic_transition:1959) igt_kms-CRITICAL: HDMI-A-2 and eDP-1 are both trying to use pipe C
Subtest 1x-modeset-transitions-fencing failed.
Comment 3 CI Bug Log 2019-01-24 16:33:17 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@kms_atomic_transition@1x-modeset-transitions-fencing|nonblocking - fail - HDMI-A-2 and eDP-1 are both trying to use pipe C -}
{+ ICL: igt@kms_atomic_transition@1x-modeset-transitions-fencing|nonblocking - fail - HDMI-A-2 and eDP-1 are both trying to use pipe C +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_177/fi-icl-u3/igt@kms_atomic_transition@1x-modeset-transitions.html
Comment 4 Nidhi Gupta 2019-01-31 13:25:27 UTC
When I was trying to reproduce the issue with latest DRM-TIP(5.0.0-rc1+) , IGT and all three displays edp ,DP and HDMI connected , the subtest  igt@kms_atomic_transition@1x-modeset-transitions-fencing which was failing because both- HDMI-A-2 and eDP-1 are both trying to use pipe is not there anymore. All my subtests are successful.
Comment 5 Martin Peres 2019-03-07 12:42:54 UTC
Dropping the priority because the reproduction rate is quite low and it has good chances of having been fixed already.

Final verdict is set for drmtip_427.
Comment 6 Martin Peres 2019-03-08 17:01:59 UTC
(In reply to Martin Peres from comment #5)
> Dropping the priority because the reproduction rate is quite low and it has
> good chances of having been fixed already.
> 
> Final verdict is set for drmtip_427.

Not sure how I counted that, but I now found I needed to wait until drmtip_227 (50 runs). We are now at drmtip_238. Closing!
Comment 7 CI Bug Log 2019-03-08 17:09:19 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.