Bug 108993 - [CI][DRMTIP] igt@kms_plane@pixel-format-pipe-[bc]-planes* - incomplete - Suspicious CRC: it looks like the CRC read back was from a register in a powered down well
Summary: [CI][DRMTIP] igt@kms_plane@pixel-format-pipe-[bc]-planes* - incomplete - Susp...
Status: RESOLVED DUPLICATE of bug 108336
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-09 19:16 UTC by Lakshmi
Modified: 2019-03-08 14:23 UTC (History)
2 users (show)

See Also:
i915 platform: ICL
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2018-12-09 19:16:41 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_155/fi-icl-u3/igt@kms_plane@pixel-format-pipe-b-planes-source-clamping.html

Err:

Starting subtest: pixel-format-pipe-B-planes-source-clamping
(kms_plane:1026) igt_debugfs-WARNING: Warning on condition crc->crc[i] == 0xffffffff in function crc_sanity_checks, file ../lib/igt_debugfs.c:896
(kms_plane:1026) igt_debugfs-WARNING: Suspicious CRC: it looks like the CRC read back was from a register in a powered down well
(kms_plane:1026) igt_debugfs-WARNING: Warning on condition crc->crc[i] == 0xffffffff in function crc_sanity_checks, file ../lib/igt_debugfs.c:896
(kms_plane:1026) igt_debugfs-WARNING: Suspicious CRC: it looks like the CRC read back was from a register in a powered down well
(kms_plane:1026) igt_debugfs-WARNING: Warning on condition crc->crc[i] == 0xffffffff in function crc_sanity_checks, file ../lib/igt_debugfs.c:896
(kms_plane:1026) igt_debugfs-WARNING: Suspicious CRC: it looks like the CRC read back was from a register in a powered down well
(kms_plane:1026) igt_debugfs-WARNING: Warning on condition crc->crc[i] == 0xffffffff in function crc_sanity_checks, file ../lib/igt_debugfs.c:896
(kms_plane:1026) igt_debugfs-WARNING: Suspicious CRC: it looks like the CRC read back was from a register in a powered down well
(kms_plane:1026) igt_debugfs-WARNING: Warning on condition crc->crc[i] == 0xffffffff in function crc_sanity_checks, file ../lib/igt_debugfs.c:896
(kms_plane:1026) igt_debugfs-WARNING: Suspicious CRC: it looks like the CRC read back was from a register in a powered down well
(kms_plane:1026) igt_debugfs-WARNING: Warning on condition crc->crc[i] == 0xffffffff in function crc_sanity_checks, file ../lib/igt_debugfs.c:896

Dmeg-warnings:
<3> [50.168556] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun
<3> [50.169200] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun
<3> [707.833240] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun
<3> [708.766762] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun
<3> [713.849752] [drm:drm_crtc_add_crc_entry] *ERROR* Overflow of CRC buffer, userspace reads too slow.
<3> [808.355118] [drm:drm_crtc_add_crc_entry] *ERROR* Overflow of CRC buffer, userspace reads too slow.
<3> [902.960505] [drm:drm_crtc_add_crc_entry] *ERROR* Overflow of CRC buffer, userspace reads too slow.
<3> [997.499221] [drm:drm_crtc_add_crc_entry] *ERROR* Overflow of CRC buffer, userspace reads too slow.
<3> [1092.087930] [drm:drm_crtc_add_crc_entry] *ERROR* Overflow of CRC buffer, userspace reads too slow.
<3> [1186.676644] [drm:drm_crtc_add_crc_entry] *ERROR* Overflow of CRC buffer, userspace reads too slow.
Comment 4 Jani Saarinen 2019-01-11 11:26:20 UTC
Stan, is this duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=108336?
Comment 5 Stanislav Lisovskiy 2019-01-11 12:03:43 UTC
(In reply to Jani Saarinen from comment #4)
> Stan, is this duplicate of
> https://bugs.freedesktop.org/show_bug.cgi?id=108336?

I think yes. Current clue is that setting atomic property for plane size breaks it at some point. If I change the test case so that plane size is smaller, the problem goes away. Still don't understand how plane size affects this though.
Comment 6 CI Bug Log 2019-01-18 20:18:01 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@kms_plane@pixel-format-pipe-[bc]-planes*- incomplete - Suspicious CRC: it looks like the CRC read back was from a register in a power -}
{+ ICL: igt@kms_plane@pixel-format-pipe-[abc]-planes*- incomplete - Suspicious CRC: it looks like the CRC read back was from a register in a power +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_196/fi-icl-u2/igt@kms_plane@pixel-format-pipe-a-planes-source-clamping.html
* https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5448/shard-iclb3/igt@kms_plane@pixel-format-pipe-a-planes-source-clamping.html
* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_193/fi-icl-u3/igt@kms_plane@pixel-format-pipe-a-planes-source-clamping.html
* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_194/fi-icl-u3/igt@kms_plane@pixel-format-pipe-a-planes-source-clamping.html
Comment 7 Lakshmi 2019-01-30 11:12:03 UTC

*** This bug has been marked as a duplicate of bug 108336 ***
Comment 8 CI Bug Log 2019-02-19 09:26:58 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@kms_plane@pixel-format-pipe-[abc]-planes*- incomplete - Suspicious CRC: it looks like the CRC read back was from a register in a power -}
{+ ICL: igt@kms_plane@pixel-format-pipe-[abc]-planes*|kms_rotation_crc@primary-*- incomplete - Suspicious CRC: it looks like the CRC read back was from a register  +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_221/fi-icl-u3/igt@kms_rotation_crc@primary-y-tiled-reflect-x-0.html
Comment 9 Martin Peres 2019-03-08 14:23:35 UTC
Moved to https://bugs.freedesktop.org/show_bug.cgi?id=108336.
Comment 10 CI Bug Log 2019-03-08 14:23:46 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.