Bug 109014 - [CI][DRMTIP] igt@gem_eio@in-flight-* - fail - Failed assertion: __gem_execbuf_wr(fd, execbuf) == 0, error: -5 != 0
Summary: [CI][DRMTIP] igt@gem_eio@in-flight-* - fail - Failed assertion: __gem_execbuf...
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-11 16:14 UTC by Martin Peres
Modified: 2019-03-08 14:17 UTC (History)
1 user (show)

See Also:
i915 platform: BSW/CHT
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Martin Peres 2018-12-11 16:15:16 UTC
Seems to be a regression, as it has been 100% reproducible since drmtip_157.
Comment 2 Chris Wilson 2019-01-30 15:02:45 UTC
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Wed Jan 30 13:09:59 2019 +0000

    i915/gem_eio: 64 batches may be too many for some devices!
    
    Actually measure how many batches we can fit into a ring before
    blocking, or else we may end up hanging the device earlier than
    expected!
    
    v2: Mostly conservative.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=109014
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Cc: Mika Kuoppala <mika.kuoppala@intel.com>
    Reviewed-by: Mika Kuoppala <mika.kuoppala@intel.com>
Comment 3 Martin Peres 2019-03-08 14:17:48 UTC
(In reply to Chris Wilson from comment #2)
> Author: Chris Wilson <chris@chris-wilson.co.uk>
> Date:   Wed Jan 30 13:09:59 2019 +0000
> 
>     i915/gem_eio: 64 batches may be too many for some devices!
>     
>     Actually measure how many batches we can fit into a ring before
>     blocking, or else we may end up hanging the device earlier than
>     expected!
>     
>     v2: Mostly conservative.
>     
>     Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=109014
>     Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
>     Cc: Mika Kuoppala <mika.kuoppala@intel.com>
>     Reviewed-by: Mika Kuoppala <mika.kuoppala@intel.com>

No failures since the patch, when it used to be seen every run (except for ~10 runs for some reason). Anyway, not seen for over 30 runs now. Closing!
Comment 4 CI Bug Log 2019-03-08 14:17:56 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.