Bug 109042 - [CI][DRMTIP] igt@kms_ccs@pipe-a-ccs-on-another-bo - skip - list_del corruption. prev->next should be ffff97430fffe000, but was ffff974300000000
Summary: [CI][DRMTIP] igt@kms_ccs@pipe-a-ccs-on-another-bo - skip - list_del corruptio...
Status: CLOSED DUPLICATE of bug 109040
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-12 16:06 UTC by Martin Peres
Modified: 2019-03-08 10:58 UTC (History)
1 user (show)

See Also:
i915 platform: I945G
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-12-12 16:06:20 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_159/fi-gdg-551/igt%40kms_ccs%40pipe-a-ccs-on-another-bo.html

<4> [226.571282] ------------[ cut here ]------------
<4> [226.571324] list_del corruption. prev->next should be ffff97430fffe000, but was ffff974300000000
<4> [226.571371] WARNING: CPU: 0 PID: 5 at lib/list_debug.c:53 __list_del_entry_valid+0x79/0x90
<4> [226.571374] Modules linked in: vgem i915 i2c_i801 lpc_ich tg3 prime_numbers
<4> [226.571389] CPU: 0 PID: 5 Comm: kworker/0:0 Tainted: G     U            4.20.0-rc5-gec6b8cacbc87-drmtip_159+ #1
<4> [226.571393] Hardware name: Dell Inc.                 OptiPlex GX280               /0G8310, BIOS A04 02/09/2005
<4> [226.571400] Workqueue: events delayed_fput
<4> [226.571406] RIP: 0010:__list_del_entry_valid+0x79/0x90
<4> [226.571411] Code: 0b 31 c0 c3 48 89 fe 48 c7 c7 48 b2 0a a6 e8 5e 3a be ff 0f 0b 31 c0 c3 48 89 f2 48 89 fe 48 c7 c7 80 b2 0a a6 e8 47 3a be ff <0f> 0b 31 c0 c3 48 c7 c7 c0 b2 0a a6 e8 36 3a be ff 0f 0b 31 c0 c3
<4> [226.571415] RSP: 0018:ffffa15a8002fd50 EFLAGS: 00010286
<4> [226.571420] RAX: 0000000000000000 RBX: ffff97430fffe000 RCX: 0000000000000000
<4> [226.571423] RDX: 0000000000000007 RSI: ffffffffa608808b RDI: 00000000ffffffff
<4> [226.571427] RBP: ffff9743355d3858 R08: 0000000039580a01 R09: 0000000000000000
<4> [226.571430] R10: ffffa15a8002fcd8 R11: 0000000000000000 R12: ffff97430fffdfa8
<4> [226.571434] R13: ffff97430fffe068 R14: ffff9743355d3918 R15: ffff97430fffe068
<4> [226.571438] FS:  0000000000000000(0000) GS:ffff97433e000000(0000) knlGS:0000000000000000
<4> [226.571442] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4> [226.571446] CR2: 00007f6238c75888 CR3: 000000003549c000 CR4: 00000000000006f0
<4> [226.571450] Call Trace:
<4> [226.571457]  shmem_evict_inode+0xe6/0x1a0
<4> [226.571467]  ? dput+0x20/0x2c0
<4> [226.571473]  evict+0xcb/0x190
<4> [226.571480]  __dentry_kill+0xca/0x190
<4> [226.571487]  dentry_kill+0x4b/0x1b0
<4> [226.571494]  ? dput+0x20/0x2c0
<4> [226.571498]  dput+0x262/0x2c0
<4> [226.571505]  __fput+0xf7/0x1f0
<4> [226.571515]  delayed_fput+0x17/0x30
<4> [226.571521]  process_one_work+0x262/0x630
<4> [226.571535]  worker_thread+0x37/0x380
<4> [226.571543]  ? process_one_work+0x630/0x630
<4> [226.571548]  kthread+0x119/0x130
<4> [226.571553]  ? kthread_park+0x80/0x80
<4> [226.571562]  ret_from_fork+0x3a/0x50
<4> [226.571581] irq event stamp: 2228550
<4> [226.571587] hardirqs last  enabled at (2228549): [<ffffffffa50ffaa9>] console_unlock+0x3f9/0x5f0
<4> [226.571593] hardirqs last disabled at (2228550): [<ffffffffa50019b0>] trace_hardirqs_off_thunk+0x1a/0x1c
<4> [226.571598] softirqs last  enabled at (2228258): [<ffffffffa5c0033a>] __do_softirq+0x33a/0x4b9
<4> [226.571603] softirqs last disabled at (2228115): [<ffffffffa5093009>] irq_exit+0xa9/0xc0
<4> [226.571609] WARNING: CPU: 0 PID: 5 at lib/list_debug.c:53 __list_del_entry_valid+0x79/0x90
<4> [226.571613] ---[ end trace 2a4aea9ab96ebe39 ]---
<6> [227.394322] [IGT] kms_ccs: exiting, ret=77
Comment 1 Jani Saarinen 2018-12-12 16:29:49 UTC
Anything could explain from patches tested on this:
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_159/git-log-oneline.log ?
Comment 2 Chris Wilson 2018-12-13 07:42:32 UTC

*** This bug has been marked as a duplicate of bug 109040 ***
Comment 3 CI Bug Log 2019-03-08 10:58:11 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.