Bug 109044 - [CI][BAT] igt@kms_flip@basic-flip-vs-dpms - dmesg-warn - WARNING: CPU: 2 PID: 3075 at drivers/gpu/drm/i915/intel_ddi.c:3104 icl_program_mg_dp_mode+0xe6/0x180 [i915]
Summary: [CI][BAT] igt@kms_flip@basic-flip-vs-dpms - dmesg-warn - WARNING: CPU: 2 PID:...
Status: CLOSED DUPLICATE of bug 108924
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: highest normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-12 16:33 UTC by Martin Peres
Modified: 2019-03-08 14:15 UTC (History)
3 users (show)

See Also:
i915 platform: ICL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-12-12 16:33:08 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5306/fi-icl-u3/igt@kms_flip@basic-flip-vs-dpms.html

The trace appears to be a little incomplete, but here it is:

<4> [223.659921] CPU: 2 PID: 3075 Comm: kms_flip Tainted: G     U  W         4.20.0-rc5-CI-CI_DRM_5306+ #1
<4> [223.659967] RDX: 0000000000000007 RSI: ffffffff820c7388 RDI: 00000000ffffffff
<4> [223.659970] RBP: 00000000001687a0 R08: 00000000330c76eb R09: 0000000000000000
<4> [223.659973] R10: 0000000000000000 R11: 0000000000000000 R12: ffff888495552158
<4> [223.659976] R13: 000000000a0038fe R14: 00000000001683a0 R15: 0000000000000000
<4> [223.659979] FS:  00007f234f3ab980(0000) GS:ffff8884aff00000(0000) knlGS:0000000000000000
<4> [223.659982] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4> [223.659985] CR2: 00007fd95c85d5a0 CR3: 000000043b9dc006 CR4: 0000000000760ee0
<4> [223.659988] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
<4> [223.659990] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
<4> [223.659993] PKRU: 55555554
<4> [223.659995] Call Trace:
<4> [223.660030]  intel_ddi_pre_enable+0x727/0xac0 [i915]
<4> [223.660062]  intel_encoders_pre_enable.isra.13+0x61/0x80 [i915]
<4> [223.660096]  haswell_crtc_enable+0x82/0x7d0 [i915]
<4> [223.660127]  ? icl_pll_get_hw_state+0x5f/0x280 [i915]
<4> [223.660157]  intel_update_crtc+0x54/0x2b0 [i915]
<4> [223.660186]  skl_update_crtcs+0x266/0x2b0 [i915]
<4> [223.660218]  intel_atomic_commit_tail+0x1ea/0xd70 [i915]
<4> [223.660250]  intel_atomic_commit+0x244/0x330 [i915]
<4> [223.660257]  drm_atomic_connector_commit_dpms+0xe0/0xf0
<4> [223.660262]  set_property_atomic+0xb5/0x140
<4> [223.660272]  drm_mode_obj_set_property_ioctl+0x10f/0x1d0
<4> [223.660276]  ? drm_connector_set_obj_prop+0x70/0x70
<4> [223.660279]  drm_connector_property_set_ioctl+0x39/0x60
<4> [223.660284]  drm_ioctl_kernel+0x81/0xf0
<4> [223.660289]  drm_ioctl+0x2de/0x390
<4> [223.660294]  ? drm_connector_set_obj_prop+0x70/0x70
<4> [223.660301]  ? __might_fault+0x39/0x90
<4> [223.660308]  do_vfs_ioctl+0xa0/0x6e0
<4> [223.660312]  ? lock_acquire+0xa6/0x1c0
<4> [223.660316]  ? __task_pid_nr_ns+0xb9/0x1f0
<4> [223.660321]  ksys_ioctl+0x35/0x60
<4> [223.660326]  __x64_sys_ioctl+0x11/0x20
<4> [223.660329]  do_syscall_64+0x55/0x190
<4> [223.660333]  entry_SYSCALL_64_after_hwframe+0x49/0xbe
<4> [223.660336] RIP: 0033:0x7f234e0f55d7
<4> [223.660338] Code: b3 66 90 48 8b 05 b1 48 2d 00 64 c7 00 26 00 00 00 48 c7 c0 ff ff ff ff c3 66 2e 0f 1f 84 00 00 00 00 00 b8 10 00 00 00 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 81 48 2d 00 f7 d8 64 89 01 48
<4> [223.660340] RSP: 002b:00007fffb0c3b388 EFLAGS: 00000246 ORIG_RAX: 0000000000000010
<4> [223.660343] RAX: ffffffffffffffda RBX: 0000000000000000 RCX: 00007f234e0f55d7
<4> [223.660345] RDX: 00007fffb0c3b3c0 RSI: 00000000c01064ab RDI: 0000000000000005
<4> [223.660346] RBP: 00007fffb0c3b3c0 R08: 00007fffb0c3b721 R09: 00007fffb0dcd080
<4> [223.660348] R10: 000000000005d0d8 R11: 0000000000000246 R12: 00000000c01064ab
<4> [223.660350] R13: 0000000000000005 R14: 0000000000000000 R15: 0000000000000000
<4> [223.660359] irq event stamp: 1832504
<4> [223.660363] hardirqs last  enabled at (1832503): [<ffffffff810fb0a9>] console_unlock+0x3f9/0x5f0
<4> [223.660365] hardirqs last disabled at (1832504): [<ffffffff810019b0>] trace_hardirqs_off_thunk+0x1a/0x1c
<4> [223.660368] softirqs last  enabled at (1832230): [<ffffffff81c0033a>] __do_softirq+0x33a/0x4b9
<4> [223.660371] softirqs last disabled at (1832223): [<ffffffff8108e6a9>] irq_exit+0xa9/0xc0
<4> [223.660401] WARNING: CPU: 2 PID: 3075 at drivers/gpu/drm/i915/intel_ddi.c:3104 icl_program_mg_dp_mode+0xe6/0x180 [i915]
<4> [223.660403] ---[ end trace 46f076d00dcee405 ]---
Comment 1 Jani Saarinen 2018-12-17 20:01:55 UTC
This should be fixed by: https://patchwork.freedesktop.org/series/54017/
Comment 2 Jani Saarinen 2018-12-17 20:05:42 UTC
Isn't this dup of https://bugs.freedesktop.org/show_bug.cgi?id=108924?
Comment 3 Imre Deak 2018-12-17 20:55:06 UTC
(In reply to Jani Saarinen from comment #2)
> Isn't this dup of https://bugs.freedesktop.org/show_bug.cgi?id=108924?

Yes looks like it. I guess cibug didn't recognized it as such as the dmesg log is oddly missing lines and so it's missing the

intel_dig_port->tc_type == 0

marker. Petri I think is looking into the root cause of the dmesg mangling.

*** This bug has been marked as a duplicate of bug 108924 ***
Comment 4 CI Bug Log 2019-03-08 14:15:51 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.