Bug 109052 - [CI][SHARDS] igt@kms_* - fail - Failed assertion: ret == 0
Summary: [CI][SHARDS] igt@kms_* - fail - Failed assertion: ret == 0
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-13 11:57 UTC by Martin Peres
Modified: 2019-06-11 11:19 UTC (History)
3 users (show)

See Also:
i915 platform: CFL, ICL, KBL, SKL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-12-13 11:57:09 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5306/shard-iclb5/igt@kms_rmfb@close-fd.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5306/shard-iclb3/igt@kms_atomic_transition@plane-all-transition-fencing.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5306/shard-iclb3/igt@kms_plane_multiple@atomic-pipe-b-tiling-x.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5306/shard-iclb3/igt@kms_plane@pixel-format-pipe-a-planes.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_168/fi-kbl-r/igt@kms_plane_alpha_blend@pipe-c-coverage-vs-premult-vs-constant.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_168/fi-kbl-r/igt@kms_frontbuffer_tracking@psr-1p-primscrn-spr-indfb-fullscreen.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_168/fi-kbl-r/igt@kms_cursor_legacy@cursor-vs-flip-atomic-transitions.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_168/fi-kbl-r/igt@kms_plane@pixel-format-pipe-b-planes.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_168/fi-skl-6770hq/igt@kms_available_modes_crc@available_mode_test_crc.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_168/fi-skl-6770hq/igt@kms_plane_alpha_blend@pipe-c-constant-alpha-mid.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_168/fi-skl-6770hq/igt@kms_cursor_legacy@cursor-vs-flip-atomic-transitions-varying-size.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_168/fi-whl-u/igt@kms_plane@pixel-format-pipe-c-planes-source-clamping.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_168/fi-whl-u/igt@kms_frontbuffer_tracking@fbc-1p-primscrn-spr-indfb-fullscreen.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_168/fi-whl-u/igt@kms_plane@pixel-format-pipe-c-planes.html

Starting subtest: pixel-format-pipe-C-planes
(kms_plane:1020) igt_kms-CRITICAL: Test assertion failure function do_display_commit, file ../lib/igt_kms.c:3320:
(kms_plane:1020) igt_kms-CRITICAL: Failed assertion: ret == 0
(kms_plane:1020) igt_kms-CRITICAL: Last errno: 22, Invalid argument
(kms_plane:1020) igt_kms-CRITICAL: error: -22 != 0
Subtest pixel-format-pipe-C-planes failed.
Comment 1 Martin Peres 2018-12-13 12:07:10 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5307/shard-iclb3/igt@kms_frontbuffer_tracking@psr-1p-primscrn-spr-indfb-fullscreen.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5306/shard-iclb3/igt@kms_atomic_transition@plane-all-transition-fencing.html

[...] even for the other platforms [...]

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5307/shard-iclb3/igt@kms_frontbuffer_tracking@fbcpsr-1p-primscrn-spr-indfb-fullscreen.html

Starting subtest: fbcpsr-1p-primscrn-spr-indfb-fullscreen
(kms_frontbuffer_tracking:6693) igt_kms-CRITICAL: Test assertion failure function igt_drm_plane_commit, file ../lib/igt_kms.c:2529:
(kms_frontbuffer_tracking:6693) igt_kms-CRITICAL: Failed assertion: ret == 0
(kms_frontbuffer_tracking:6693) igt_kms-CRITICAL: Last errno: 22, Invalid argument
(kms_frontbuffer_tracking:6693) igt_kms-CRITICAL: error: -22 != 0
Subtest fbcpsr-1p-primscrn-spr-indfb-fullscreen failed.
Comment 3 James Ausmus 2018-12-18 18:05:03 UTC
Looks like it might be a test issue:

[280.408479] [drm:skl_compute_wm [i915]] [PLANE:30:plane 1A] ddb (0 - 992) -> (0 - 0)
[280.408505] [drm:skl_compute_wm [i915]] [PLANE:72:plane 7A] ddb (0 - 0) -> (0 - 992)
[280.425389] [drm:skl_allocate_pipe_ddb [i915]] Requested display configuration exceeds system DDB limitations
[280.425418] [drm:skl_allocate_pipe_ddb [i915]] minimum required 4522/992
Comment 4 Jani Saarinen 2019-01-18 08:33:17 UTC
e-production rate (0.9%) not seen other than ICL systems lately. Martin not seen on shards lately.
Comment 5 Jani Saarinen 2019-01-18 08:33:49 UTC
Re-production rate (0.9%) not seen other than ICL systems lately. Martin not
seen on shards lately.
Comment 6 Martin Peres 2019-01-18 08:46:05 UTC
(In reply to Jani Saarinen from comment #5)
> Re-production rate (0.9%) not seen other than ICL systems lately. Martin not
> seen on shards lately.

No idea how you checked, but this has been seen on drmtip_194/195. Don't use the statistics from CI Bug Log, they need more work and they would not be sufficient to tell you if you should close the bug or not anyway.
Comment 7 CI Bug Log 2019-02-08 11:41:43 UTC
A CI Bug Log filter associated to this bug has been updated:

{- SKL KBL WHL ICL: random kms tests - fail - Test assertion failure function *_commit, Failed assertion: ret == 0, Last errno: 22, Invalid argument -}
{+ SKL KBL CFL WHL ICL: random kms tests - fail - Test assertion failure function *_commit, Failed assertion: ret == 0, Last errno: 22, Invalid argument +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_208/fi-cfl-8109u/igt@kms_plane_scaling@pipe-a-scaler-with-pixel-format.html
Comment 8 Martin Peres 2019-04-04 06:46:34 UTC
ICL is failing constantly on igt@kms_plane_scaling@pipe-[abc]-scaler-with-rotation, which indicates that the test is trying to do something that the kernel refuses. This is either a test issue that needs to be fixed, or the kernel not providing what it should. As for the customer impact, the worst thing that can be is that the feature is broken because it is not tested, but since the feature is not exactly the most common use case, then a priority is already high-enough.

As for the random failures we see on the other platforms, these are likely due to previous tests leaving pipes and planes enabled, and the failing test having failed to reset the state of the machine to an expected one. The fix for this is likely to reset the state of the machine in the lib igt for every KMS test, in order to provide consistency between tests. The customer impact is that we could let some regressions in that lead to more consistent failing, as noone is looking at the changes in reproduction rate and CI BUg log will not warn us about it ... yet. So, high priority it is again!
Comment 9 CI Bug Log 2019-04-10 13:25:19 UTC
A CI Bug Log filter associated to this bug has been updated:

{- SKL KBL WHL ICL: igt@kms_cursor_legacy@cursor-vs-flip-atomic-transitions(-varying-size) - fail - Failed assertion: !ret, Last errno: 22, Invalid argument -}
{+ SKL KBL WHL ICL: igt@kms_cursor_legacy@cursor-vs-flip-atomic-transitions(-varying-size) - fail - Failed assertion: !ret +}

 No new failures caught with the new filter
Comment 10 CI Bug Log 2019-04-10 13:25:38 UTC
A CI Bug Log filter associated to this bug has been updated:

{- SKL KBL CFL WHL ICL: random kms tests - fail - Test assertion failure function *_commit, Failed assertion: ret == 0, Last errno: 22, Invalid argument -}
{+ SKL KBL CFL WHL ICL: random kms tests - fail - Test assertion failure function *_commit, Failed assertion: ret == 0 +}

 No new failures caught with the new filter
Comment 11 Lakshmi 2019-04-15 11:14:29 UTC
@Mika: Any update on kms_plane_scaling/kms_plane_multiple test failures?

@Maarten, any fix for chamelium? 

Updates to kms_concurrent=> https://patchwork.freedesktop.org/series/58872/ reviewed and accepted.
Comment 12 Mika Kahola 2019-04-15 11:19:20 UTC
On kms_plane_scaling, I proposed a patch

https://patchwork.freedesktop.org/series/59391/

This is under review at the moment.
Comment 13 Mika Kahola 2019-04-18 05:49:34 UTC
The problem with the test is that the test tries to do scaling with the pixel format that is not supported by the kernel. Kernel refuses this request with -EINVAL which causes a failure in a test. Even if we pass the test some pixel format it is enough for the test to fail if we try scaling with one that is not supported.
Comment 14 Mika Kahola 2019-04-18 05:50:58 UTC
With kms_plane_scaling test the problem with the test is that the test tries to do scaling with the pixel format that is not supported by the kernel. Kernel refuses this request with -EINVAL which causes a failure in a test. Even if we pass the test some pixel format it is enough for the test to fail if we try scaling with one that is not supported.
Comment 15 Mika Kahola 2019-04-24 11:37:55 UTC
For kms_plane_scaling test I merged this patch https://patchwork.freedesktop.org/series/59826/ that will unify the list of supported pixel formats for rotation between kernel and IGT.
Comment 16 Jani Saarinen 2019-05-25 07:34:33 UTC
This now seen on ICL 2 weeks and 2 days ago.
Comment 17 Maarten Lankhorst 2019-05-27 09:15:27 UTC
This filter is way too broad. Commit fails but it could be for any reason, it doesn't make sense to just put everything in a single bug. I would open a bug per test, or if one platform has the same issue on a lot of separate tests, per platform..
Comment 18 Jani Saarinen 2019-06-11 11:19:36 UTC
Not seen after change merged on IGT_5034


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.