Bug 109106 - [CI][DRMTIP]igt@gem_exec_reuse@single - dmesg-earn - BUG kmalloc-64
Summary: [CI][DRMTIP]igt@gem_exec_reuse@single - dmesg-earn - BUG kmalloc-64
Status: CLOSED DUPLICATE of bug 109040
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-19 18:32 UTC by Lakshmi
Modified: 2019-03-08 14:13 UTC (History)
1 user (show)

See Also:
i915 platform: I945G
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2018-12-19 18:32:57 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_170/fi-gdg-551/igt@gem_exec_reuse@single.html

<6> [232.712072] Console: switching to colour dummy device 80x25
<6> [232.713749] [IGT] gem_exec_reuse: executing
<5> [232.729549] Setting dangerous option reset - tainting kernel
<7> [233.410407] [drm:intel_sdvo_detect [i915]] [CONNECTOR:43:DVI-D-1]
<7> [233.410522] [drm:intel_sdvo_debug_write [i915]] SDVOB: W: 0B                         (SDVO_CMD_GET_ATTACHED_DISPLAYS)
<7> [233.415554] [drm:intel_sdvo_read_response [i915]] SDVOB: R: (Success) 00 00
<7> [233.415639] [drm:intel_sdvo_detect [i915]] SDVO response 0 0 [1]
<7> [236.232658] [drm:i915_gem_do_execbuffer [i915]] EINVAL at i915_gem_do_execbuffer:2240
<7> [236.232763] [drm:i915_gem_do_execbuffer [i915]] EINVAL at i915_gem_do_execbuffer:2240
<7> [236.232854] [drm:i915_gem_do_execbuffer [i915]] EINVAL at i915_gem_do_execbuffer:2240
<6> [236.238877] [IGT] gem_exec_reuse: starting subtest single
<6> [241.610313] [IGT] gem_exec_reuse: exiting, ret=0
<6> [241.644878] Console: switching to colour frame buffer device 128x48
<3> [242.871398] =============================================================================
<3> [242.871864] BUG kmalloc-64 (Tainted: G     U           ): Redzone overwritten
<3> [242.871945] -----------------------------------------------------------------------------\x0a
<4> [242.872047] Disabling lock debugging due to kernel taint
<3> [242.872052] INFO: 0x0000000084981d92-0x000000009afa474c. First byte 0x0 instead of 0xcc
<3> [242.872118] INFO: Allocated in drm_vma_node_allow+0x20/0xc0 age=6916 cpu=0 pid=1052
<3> [242.872175] \x09kmem_cache_alloc_trace+0x228/0x290
<3> [242.872211] \x09drm_vma_node_allow+0x20/0xc0
<3> [242.872245] \x09drm_gem_handle_create_tail+0xc3/0x170
<3> [242.872455] \x09i915_gem_create+0x7f/0xc0 [i915]
<3> [242.872492] \x09drm_ioctl_kernel+0x81/0xf0
<3> [242.872523] \x09drm_ioctl+0x2de/0x390
<3> [242.872552] \x09do_vfs_ioctl+0xa0/0x6e0
<3> [242.872580] \x09ksys_ioctl+0x35/0x60
<3> [242.872607] \x09__x64_sys_ioctl+0x11/0x20
<3> [242.872639] \x09do_syscall_64+0x55/0x190
<3> [242.872669] \x09entry_SYSCALL_64_after_hwframe+0x49/0xbe
<3> [242.872708] INFO: Slab 0x00000000f080e0d1 objects=20 used=20 fp=0x          (null) flags=0x4000000000010201
<3> [242.872775] INFO: Object 0x00000000e4af1f76 @offset=8 fp=0x          (null)\x0a
<3> [242.872835] Redzone 0000000084981d92: 00 00 00 00 cc cc cc cc                          ........
<3> [242.872895] Object 00000000e4af1f76: 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  ................
<3> [242.872959] Object 000000003d8c4307: 00 00 00 00 00 00 00 00 98 ef f6 eb 97 9e ff ff  ................
<3> [242.873022] Object 00000000fcfe0a3d: 00 00 00 00 00 00 00 00 6b 6b 6b 6b 6b 6b 6b 6b  ........kkkkkkkk
<3> [242.873086] Object 0000000071fe61fb: 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b a5  kkkkkkkkkkkkkkk.
<3> [242.873149] Redzone 0000000057695cad: cc cc cc cc cc cc cc cc                          ........
<3> [242.873209] Padding 000000004a07592f: 5a 5a 5a 5a 5a 5a 5a 5a                          ZZZZZZZZ
<4> [242.873271] CPU: 0 PID: 1052 Comm: gem_exec_reuse Tainted: G    BU            4.20.0-rc6-gcaa765e4d392-drmtip_170+ #1
<4> [242.873274] Hardware name: Dell Inc.                 OptiPlex GX280               /0G8310, BIOS A04 02/09/2005
<4> [242.873275] Call Trace:
<4> [242.873285]  dump_stack+0x67/0x9b
<4> [242.873289]  check_bytes_and_report+0xbd/0x100
<4> [242.873295]  check_object+0x177/0x270
<4> [242.873300]  free_debug_processing+0x137/0x370
<4> [242.873303]  ? drm_vma_node_revoke+0x64/0x70
<4> [242.873309]  __slab_free+0x337/0x510
<4> [242.873312]  ? _raw_spin_unlock_irqrestore+0x39/0x60
<4> [242.873317]  ? debug_check_no_obj_freed+0x132/0x210
<4> [242.873323]  ? drm_vma_node_revoke+0x64/0x70
<4> [242.873327]  ? drm_vma_node_revoke+0x64/0x70
<4> [242.873330]  drm_vma_node_revoke+0x64/0x70
<4> [242.873334]  drm_gem_object_release_handle+0x51/0xb0
<4> [242.873338]  ? drm_gem_object_handle_put_unlocked+0xb0/0xb0
<4> [242.873341]  idr_for_each+0x49/0xd0
<4> [242.873347]  drm_gem_release+0x17/0x20
<4> [242.873351]  drm_file_free.part.0+0x2d0/0x330
<4> [242.873356]  drm_release+0xa9/0x120
<4> [242.873362]  __fput+0xb9/0x1f0
<4> [242.873368]  task_work_run+0x82/0xb0
<4> [242.873375]  do_exit+0x34e/0xd10
<4> [242.873381]  do_group_exit+0x34/0xb0
<4> [242.873385]  __x64_sys_exit_group+0xf/0x10
<4> [242.873388]  do_syscall_64+0x55/0x190
<4> [242.873392]  entry_SYSCALL_64_after_hwframe+0x49/0xbe
<4> [242.873397] RIP: 0033:0x7f759b8aee06
<4> [242.873408] Code: Bad RIP value.
<4> [242.873411] RSP: 002b:00007ffee3702dc8 EFLAGS: 00000246 ORIG_RAX: 00000000000000e7
<4> [242.873414] RAX: ffffffffffffffda RBX: 00007f759bbb1740 RCX: 00007f759b8aee06
<4> [242.873416] RDX: 0000000000000000 RSI: 000000000000003c RDI: 0000000000000000
<4> [242.873418] RBP: 0000000000000000 R08: 00000000000000e7 R09: ffffffffffffff80
<4> [242.873421] R10: 00007f758fd1d0c0 R11: 0000000000000246 R12: 00007f759bbb1740
<4> [242.873423] R13: 0000000000000003 R14: 00007f759bbba628 R15: 0000000000000000
<3> [242.873432] FIX kmalloc-64: Restoring 0x0000000084981d92-0x000000009afa474c=0xcc\x0a
<3> [242.873558] FIX kmalloc-64: Object at 0x00000000e4af1f76 not freed
Comment 2 Chris Wilson 2018-12-19 19:21:03 UTC

*** This bug has been marked as a duplicate of bug 109040 ***
Comment 3 CI Bug Log 2019-03-08 14:13:21 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.