Bug 109121 - [dock] display hotplug doesn't work properly
Summary: [dock] display hotplug doesn't work properly
Status: CLOSED NOTOURBUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged, ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-20 12:13 UTC by Timo Aaltonen
Modified: 2019-07-16 06:17 UTC (History)
3 users (show)

See Also:
i915 platform: CFL
i915 features: display/DP MST


Attachments
dmesg dump (30.03 KB, text/plain)
2018-12-20 12:13 UTC, Timo Aaltonen
no flags Details
gzipped kernel.log (49.66 KB, application/x-gzip)
2018-12-21 08:18 UTC, Che Cheng
no flags Details
kernel log after applying patch in comment 6 (231.89 KB, text/plain)
2019-01-09 08:51 UTC, Che Cheng
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timo Aaltonen 2018-12-20 12:13:28 UTC
Created attachment 142864 [details]
dmesg dump

There are issues with a new dock (model undisclosed for now) when hotplugging a monitor to it; it isn't detected properly until the display configurator or xrandr is run.

This happens with current drm-next as well, dmesg dump attached (I'm not sure from which kernel it is though). The display is attached at ~102s, xrandr is run at ~109s.
Comment 1 Timo Aaltonen 2018-12-20 14:43:25 UTC
the log is from 4.20-rc7, timestamps ~47s, ~60s and 102s are all about plugging in the monitor
Comment 2 Lakshmi 2018-12-20 20:38:06 UTC
Reporter can you attach full dmesg from boot? Which platform is this?

@Stan, any help here?

[   11.970683] [drm:drm_dp_dual_mode_detect [drm_kms_helper]] DP dual mode HDMI ID:  (err -6)
[   11.970687] [drm:drm_helper_probe_single_connector_modes [drm_kms_helper]] [CONNECTOR:79:HDMI-A-1] disconnected
[   11.970715] [drm:drm_helper_probe_single_connector_modes [drm_kms_helper]] [CONNECTOR:85:DP-1]
[   11.970728] [drm:intel_dp_detect [i915]] [CONNECTOR:85:DP-1]
[   11.970738] [drm:intel_power_well_enable [i915]] enabling power well 2
[   11.970801] [drm:intel_power_well_disable [i915]] disabling power well 2
[   11.970808] [drm:drm_helper_probe_single_connector_modes [drm_kms_helper]] [CONNECTOR:85:DP-1] disconnected
[   11.970815] [drm:drm_helper_probe_single_connector_modes [drm_kms_helper]] [CONNECTOR:90:HDMI-A-2]
[   11.970841] [drm:intel_hdmi_detect [i915]] [CONNECTOR:90:HDMI-A-2]
[   11.975520] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus dpc] NAK for addr: 0050 w(1)
[   11.975539] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus dpc] NAK on first message, retry
[   11.981039] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus dpc] NAK for addr: 0050 w(1)
[   11.981095] [drm:drm_do_probe_ddc_edid [drm]] drm: skipping non-existent adapter i915 gmbus dpc
[   11.981108] [drm:intel_hdmi_set_edid [i915]] HDMI GMBUS EDID read failed, retry using GPIO bit-banging
[   11.981121] [drm:intel_gmbus_force_bit [i915]] enabling bit-banging on i915 gmbus dpc. force bit now 1
[   11.992821] [drm:drm_do_probe_ddc_edid [drm]] drm: skipping non-existent adapter i915 gmbus dpc
[   11.992836] [drm:intel_gmbus_force_bit [i915]] disabling bit-banging on i915 gmbus dpc. force bit now 0
[   11.998116] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus dpc] NAK for addr: 0040 w(1)
[   11.998134] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus dpc] NAK on first message, retry
[   12.003359] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus dpc] NAK for addr: 0040 w(1)
[   12.003401] [drm:drm_dp_dual_mode_detect [drm_kms_helper]] DP dual mode HDMI ID:  (err -6)
[   12.003405] [drm:drm_helper_probe_single_connector_modes [drm_kms_helper]] [CONNECTOR:90:HDMI-A-2] disconnected
[   12.003424] [drm:drm_helper_probe_single_connector_modes [drm_kms_helper]] [CONNECTOR:93:DP-2]
[   12.003440] [drm:intel_dp_detect [i915]] [CONNECTOR:93:DP-2]
[   12.003450] [drm:intel_power_well_enable [i915]] enabling power well 2
[   12.003483] [drm:intel_power_well_disable [i915]] disabling power well 2
[   12.003489] [drm:drm_helper_probe_single_connector_modes [drm_kms_helper]] [CONNECTOR:93:DP-2] disconnected
[   12.003496] [drm:drm_helper_probe_single_connector_modes [drm_kms_helper]] [CONNECTOR:98:HDMI-A-3]
[   12.003509] [drm:intel_hdmi_detect [i915]] [CONNECTOR:98:HDMI-A-3]
[   12.003853] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus dpd] NAK for addr: 0050 w(1)
[   12.003865] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus dpd] NAK on first message, retry
[   12.004178] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus dpd] NAK for addr: 0050 w(1)
[   12.004217] [drm:drm_do_probe_ddc_edid [drm]] drm: skipping non-existent adapter i915 gmbus dpd
[   12.004229] [drm:intel_hdmi_set_edid [i915]] HDMI GMBUS EDID read failed, retry using GPIO bit-banging
[   12.004241] [drm:intel_gmbus_force_bit [i915]] enabling bit-banging on i915 gmbus dpd. force bit now 1
[   12.008955] [drm:drm_do_probe_ddc_edid [drm]] drm: skipping non-existent adapter i915 gmbus dpd
[   12.008972] [drm:intel_gmbus_force_bit [i915]] disabling bit-banging on i915 gmbus dpd. force bit now 0
[   12.009310] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus dpd] NAK for addr: 0040 w(1)
[   12.009322] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus dpd] NAK on first message, retry
[   12.009631] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus dpd] NAK for addr: 0040 w(1)
[   12.009666] [drm:drm_dp_dual_mode_detect [drm_kms_helper]] DP dual mode HDMI ID:  (err -6)
[   12.009669] [drm:drm_helper_probe_single_connector_modes [drm_kms_helper]] [CONNECTOR:98:HDMI-A-3] disconnected
[   13.659482] [drm:intel_power_well_enable [i915]] enabling power well 2
[   13.665561] [drm:i915_audio_component_get_eld [i915]] Not valid for port B
[   13.665594] [drm:i915_audio_component_get_eld [i915]] Not valid for port B
[   13.665623] [drm:i915_audio_component_get_eld [i915]] Not valid for port B
[   13.665652] [drm:i915_audio_component_get_eld [i915]] Not valid for port C
[   13.665676] [drm:i915_audio_component_get_eld [i915]] Not valid for port C
[   13.665699] [drm:i915_audio_component_get_eld [i915]] Not valid for port C
[   13.665722] [drm:i915_audio_component_get_eld [i915]] Not valid for port D
[   13.665745] [drm:i915_audio_component_get_eld [i915]] Not valid for port D
[   13.665768] [drm:i915_audio_component_get_eld [i915]] Not valid for port D
[   13.907323] Bluetooth: RFCOMM TTY layer initialized
[   13.907375] Bluetooth: RFCOMM socket layer initialized
[   13.907394] Bluetooth: RFCOMM ver 1.11
[   14.565151] rfkill: input handler disabled
[   15.187418] [drm:edp_panel_vdd_off_sync [i915]] Turning eDP port A VDD off
[   15.187500] [drm:edp_panel_vdd_off_sync [i915]] PP_STATUS: 0x80000008 PP_CONTROL: 0x00000067
Comment 3 Timo Aaltonen 2018-12-21 07:27:45 UTC
It's CFL, I've asked for full dmesg..
Comment 4 Che Cheng 2018-12-21 08:18:34 UTC
Created attachment 142871 [details]
gzipped kernel.log

It's a new kernel log from 4.20-rc7.

The first time the monitor was attached is at 32.129279.

I ran xrandr command at 38.344303.
Comment 5 Timo Aaltonen 2018-12-21 09:09:05 UTC
one bit of information is that the host doesn't have TB but the dock does, and it's connected with USB+DP or such.. with a TB host there are no hotplug issues

Che, correct me if I'm wrong :)
Comment 6 Stanislav Lisovskiy 2018-12-27 14:13:09 UTC
"it isn't detected properly until the display configurator or xrandr is run." tells me that this is most likely yet again another dup of that one: 
https://bugs.freedesktop.org/show_bug.cgi?id=106250

I had one proposed fix attached there on kernel side, which wasn't yet accepted in the kernel. Please try the "kernel fix" attached to make sure that the issue is similar one.
Comment 7 Che Cheng 2019-01-09 08:51:43 UTC
Created attachment 143030 [details]
kernel log after applying patch in comment 6

After applying the kernel patch mentioned in comment 6, the situation becomes worse. Even running xrandr cannot detect the monitor plugged in.

The HDMI plug-in event is at timestamp 33.717977, and I ran xrandr at 41.087680.
Comment 8 Stanislav Lisovskiy 2019-01-09 09:23:32 UTC
(In reply to Che Cheng from comment #7)
> Created attachment 143030 [details]
> kernel log after applying patch in comment 6
> 
> After applying the kernel patch mentioned in comment 6, the situation
> becomes worse. Even running xrandr cannot detect the monitor plugged in.
> 
> The HDMI plug-in event is at timestamp 33.717977, and I ran xrandr at
> 41.087680.

Does xrandr show the connector as connected? From the log I see 4.15 kernel version, could you please also try some recent kernel with this patch?
Comment 9 Che Cheng 2019-01-11 03:46:20 UTC
(In reply to Stanislav Lisovskiy from comment #8)
> 
> Does xrandr show the connector as connected? From the log I see 4.15 kernel
> version, could you please also try some recent kernel with this patch?

I also had tested 4.18 and 4.20 kernel, did not work, too.
Running xrandr shows the connector as disconnected.
Comment 10 Stanislav Lisovskiy 2019-01-11 08:06:23 UTC
(In reply to Che Cheng from comment #9)
> (In reply to Stanislav Lisovskiy from comment #8)
> > 
> > Does xrandr show the connector as connected? From the log I see 4.15 kernel
> > version, could you please also try some recent kernel with this patch?
> 
> I also had tested 4.18 and 4.20 kernel, did not work, too.
> Running xrandr shows the connector as disconnected.

If xrandr shows it as disconnected then it's most probably a different bug, as for the bug I was referring to it shows that it is connected despite the screen is blank. So I guess this requires additional investigation.

Can you please also specify here, which xrandr command you were running to make it work again.
Comment 11 Che Cheng 2019-01-11 08:56:25 UTC
(In reply to Stanislav Lisovskiy from comment #10)

> If xrandr shows it as disconnected then it's most probably a different bug,
> as for the bug I was referring to it shows that it is connected despite the
> screen is blank. So I guess this requires additional investigation.
> 
> Can you please also specify here, which xrandr command you were running to
> make it work again.

I just simply ran xrandr, no additional parameter.
Comment 12 Lakshmi 2019-07-15 10:47:55 UTC
@Che, If you don't mind, can you please verify the issue with current drmtip?(https://cgit.freedesktop.org/drm-tip)

Can you please attach dmesg from boot from drmtip?
Comment 13 Che Cheng 2019-07-15 14:33:32 UTC
@Lakshmi,

Thanks for your kindly response.

The issue ends up with the dock manufacturer updated its firmware and fixed it.

Anyway, thanks much.
Comment 14 Lakshmi 2019-07-16 06:17:27 UTC
(In reply to Che Cheng from comment #13)
> @Lakshmi,
> 
> Thanks for your kindly response.
> 
> The issue ends up with the dock manufacturer updated its firmware and fixed
> it.
> 
> Anyway, thanks much.

OK. Thanks for the feedback, closing this issue as NOTOURBUG.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.