Bug 109153 - [KBL-G][VK] Vulkan CTS spirv_assembly cases failed Segmentation fault (core dumped)
Summary: [KBL-G][VK] Vulkan CTS spirv_assembly cases failed Segmentation fault (core d...
Status: RESOLVED NOTOURBUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: 18.3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
: 109146 109157 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-12-26 08:57 UTC by Hai
Modified: 2019-01-08 15:21 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
TestResults.qpa (6.39 KB, text/plain)
2018-12-26 09:01 UTC, Hai
Details
attachment-21903-0.html (1.72 KB, text/html)
2018-12-26 16:25 UTC, Cheng
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hai 2018-12-26 08:57:39 UTC
When Use Kaby Lake-g(AMD Vega M GPU) to do the Vulkan CTS test, the case "
dEQP-VK.spirv_assembly.instruction.compute.pointer_parameter.workgroup_memory_variable_pointers" will fail

Following is the environtment

Platform	KabyLake-G
CPU	Intel (R) Core (TM) i7-8809G CPU @3.10GHz
GPU	AMD(Radeon RX Vega M GH Graphics);
Memory	16G
OS	Ubutu18.04.1
Kernel	4.19.0
Mesa: 	mesa 18.3.1 (https://mesa.freedesktop.org/archive/mesa-18.3.1.tar.gz) 

VK-GL-CTS version	https://github.com/KhronosGroup/VK-GL-CTS
commit 54e546a1a0a6fa412ea4c3e3081bbc9518928a6e

How to reproduce
$ ./deqp-vk -n dEQP-VK.spirv_assembly.instruction.compute.pointer_parameter.workgroup_memory_variable_pointers
Writing test log into TestResults.qpa
dEQP Core git-8e3741675ba9ebfdea5bc98ac2df4e5e6f182e57 (0x8e374167) starting..
  target implementation = 'Default'

Test case 'dEQP-VK.spirv_assembly.instruction.compute.pointer_parameter.workgroup_memory_variable_pointers'..
SPIR-V parsing FAILED:
    In file spirv/vtn_variables.c:1646
    ptr_type->type
    1324 bytes into the SPIR-V binary
Segmentation fault (core dumped)
Comment 1 Hai 2018-12-26 09:01:12 UTC
*** Bug 109146 has been marked as a duplicate of this bug. ***
Comment 2 Hai 2018-12-26 09:01:59 UTC
Created attachment 142897 [details]
TestResults.qpa
Comment 3 Cheng 2018-12-26 16:25:59 UTC
Created attachment 142900 [details]
attachment-21903-0.html

Thanks for your email. Iā€™m OOO. Please expect slow email response.
Comment 4 Hai 2018-12-27 05:47:02 UTC
*** Bug 109157 has been marked as a duplicate of this bug. ***
Comment 5 Bas Nieuwenhuizen 2019-01-02 17:31:30 UTC
Can be reproduced with 18.3.1 but has been fixed in master. Still confirming what fixed it, but if my suspicion is right there are some extensive changes and that fix may *not* be backported to 18.3 .
Comment 6 Samuel Pitoiset 2019-01-08 09:01:15 UTC
The following commit fixes the crash for me

commit 2f4f5a5055c74a35916645ed6eb2f8bd8ca7d221
Author: Dave Airlie <airlied@redhat.com>
Date:   Wed Jul 4 16:21:49 2018 +1000

    spirv/vtn: handle variable pointers without offset lowering
    
    Reviewed-by: Jason Ekstrand <jason@jlekstrand.net>
Comment 7 Samuel Pitoiset 2019-01-08 15:21:31 UTC
This is actually a test bug. It doesn't check that variablePointers is enabled. I reported the problem to Khronos, should be fixed and upstreamed soon.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.