Bug 109156 - Meson doesn't always strip when --strip is used
Summary: Meson doesn't always strip when --strip is used
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-27 00:30 UTC by Shmerl
Modified: 2019-09-18 20:19 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shmerl 2018-12-27 00:30:01 UTC
I was experimenting with building Mesa using Meson, and noticed a strange thing.

When adding --strip to Meson invocation, most resulting .so files are indeed stripped, but some are not for some reason.

I noticed it for these at least (there can be more, but I tried with a limited set of libraries just for radv and radeonsi):

radeonsi_dri.so
radeonsi_drv_video.so
Comment 1 GitLab Migration User 2019-09-18 20:19:06 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/932.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.