Bug 109182 - [AMD][TAHITI XT] CSGO rendering artifact on dashboard human body
Summary: [AMD][TAHITI XT] CSGO rendering artifact on dashboard human body
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-30 15:37 UTC by Sylvain BERTRAND
Modified: 2019-01-13 14:56 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg (54.67 KB, text/plain; charset=ISO-8859-1)
2019-01-03 17:51 UTC, Sylvain BERTRAND
Details
xorg log (48.99 KB, text/plain; charset=ISO-8859-1)
2019-01-03 17:52 UTC, Sylvain BERTRAND
Details
glxinfo (versions and git hash, but already gave the info) (144.76 KB, text/plain; charset=ISO-8859-1)
2019-01-03 20:49 UTC, Sylvain BERTRAND
Details
capture.mkv (86.50 MB, text/plain; charset=ISO-8859-1)
2019-01-04 21:07 UTC, Sylvain BERTRAND
Details
capture.mkv (86.50 MB, video/x-matroska)
2019-01-05 03:51 UTC, Sylvain BERTRAND
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvain BERTRAND 2018-12-30 15:37:04 UTC
Everything git, less than a week (llvm/mesa/drm/xserver/xf86-video-amdgpu) linux amd-staging-drm-next).
Whatever the csgo 3D engine settings, in the dashboard, the human body shown there demonstrates rendering artifacts.
Comment 1 Michel Dänzer 2019-01-03 12:11:48 UTC
You know this isn't nearly enough information to find out what the problem is. Needed at the very least: A screenshot of the artifacts, the Xorg log file and the output of dmesg and glxinfo.
Comment 2 Sylvain BERTRAND 2019-01-03 17:51:43 UTC
Created attachment 142963 [details]
dmesg
Comment 3 Sylvain BERTRAND 2019-01-03 17:52:21 UTC
Created attachment 142964 [details]
xorg log
Comment 4 Sylvain BERTRAND 2019-01-03 17:59:29 UTC
I could not screenshots the artifacts because they seem too fast (the screenshots done with the steam overlay show nothing), so I'll describe them to you: its like some polygons of the human 3D model are "blinking"/glitching very fast from dark colors to normal colors.
Comment 5 Sylvain BERTRAND 2019-01-03 20:49:07 UTC
Created attachment 142967 [details]
glxinfo (versions and git hash, but already gave the info)
Comment 6 fin4478 2019-01-04 09:45:00 UTC
Comment on attachment 142963 [details]
dmesg

No rendering problems with my system. If you are compiling Mesa by your self, it is waste of time and good source of bugs. Oibaf ppa uses llvm 7.

You can record a video of the problem with OBS and edit it with Kdenlive.
https://youtu.be/CyMw-6O0aKI
Comment 7 Sylvain BERTRAND 2019-01-04 17:30:54 UTC
I added xcb capture to my ffmpeg build: I made a video of the glitches available for download there:
http://dl.free.fr/r1ENiiJ3C
(it's a french hosting service for big files, let me know if you are unable to download it)
Comment 8 Michel Dänzer 2019-01-04 17:37:35 UTC
Please attach the file here directly, should work AFAICT.
Comment 9 Sylvain BERTRAND 2019-01-04 21:07:52 UTC
Created attachment 142976 [details]
capture.mkv
Comment 10 Sylvain BERTRAND 2019-01-05 03:51:34 UTC
Created attachment 142981 [details]
capture.mkv
Comment 11 Sylvain BERTRAND 2019-01-13 14:56:31 UTC
updated to latest git. rendering bug is fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.