Bug 109183 - GPU Hangs randomly with GTA V
Summary: GPU Hangs randomly with GTA V
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: 19.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-30 19:05 UTC by Alexander Vereeken
Modified: 2019-09-18 19:51 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg (68.22 KB, text/x-log)
2019-04-17 17:01 UTC, Alexander Vereeken
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Vereeken 2018-12-30 19:05:47 UTC
My whole pc freezes randoly and I have to restart the computer and I think that's a GPU hang.
Comment 1 Alexander Vereeken 2018-12-30 19:09:52 UTC
My stats : GPU: RX 570
           CPU: AMD FX 8350
           Ram: 16GB
           Distro: Arch-Linux
           
This runs with DXVK 0.94
Comment 2 Samuel Pitoiset 2019-01-25 07:56:22 UTC
Can you explain why it's actually invalid?
Comment 3 Alexander Vereeken 2019-01-25 11:25:08 UTC
I can't confirm that it's mesa who is doing this and can only provide spongy info about it, but this only happens in online mode and just anyway proton has a hard time with the online mode.
Comment 4 Alexander Vereeken 2019-04-08 17:16:22 UTC
Changing this reopened okay this could be really related to mesa because i cant press ctl+alt+F2 while the game is frozen and this happends only in online mode.
Comment 5 Samuel Pitoiset 2019-04-08 19:01:25 UTC
Do you have something in dmesg when it freezes?
Comment 6 Alexander Vereeken 2019-04-17 17:01:47 UTC
Created attachment 144012 [details]
dmesg

Here I have something interesting maybe
Comment 7 Samuel Pitoiset 2019-04-18 07:26:54 UTC
Yeah, it's quite interesting. I guess it's hard to find a good way for reproducing that hang?
Comment 8 Alexander Vereeken 2019-04-18 07:49:27 UTC
Not really,

mostly happens at "The Fleeca job", during the preparations.

Video Settings: 

Screen type: Full screen view
Resolution: 1920x1080
Refreshrate: 60hz but i guess 144hz gets forced by the DE.

DirectX 11:

FXAA: On
MSAA: x2
Vsync: Off
Population density: Full
Population diversity: Full
Renderdistance: Full
Texturs: High
Shaders: High
Shadows: High
Reflexion: High
ReflexionMSAA: Off
Water: High
Particles: High
Grass: High
Soft Shadows: Softer
Post processing: High
Ambient occlusion: Off
Tessellation: High

Proton 4.2-2
Comment 9 Samuel Pitoiset 2019-04-18 07:54:34 UTC
I will investigate at some point.
Could be related to https://bugs.freedesktop.org/show_bug.cgi?id=110345
Comment 10 Alexander Vereeken 2019-05-17 18:57:49 UTC
ehm... could this releated to the old gnome version 3.24?

Since my distro upgraded gnome to 3.3.0, i never got this freeze again.
Comment 11 GitLab Migration User 2019-09-18 19:51:24 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/853.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.