Bug 109213 - GPU driver crashes randomly after waking up from hibernation
Summary: GPU driver crashes randomly after waking up from hibernation
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
: 109214 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-03 09:01 UTC by lishuai918
Modified: 2019-07-03 08:16 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lishuai918 2019-01-03 09:01:39 UTC
Hi, I am experiencing gpu crash after resuming from hibernation. After the crash, the screen goes black, and I have to press the power button to hard power off the machine, then restart. I found some bug reports on old kernels, and this one seems to be new.

The kernel I am using is: Linux Noah 4.19.12-arch1-1-ARCH #1 SMP PREEMPT Fri Dec 21 13:56:54 UTC 2018 x86_64 GNU/Linux

Xorg version:

X.Org X Server 1.20.3
X Protocol Version 11, Revision 0
Build Operating System: Linux Arch Linux
Current Operating System: Linux Noah 4.19.12-arch1-1-ARCH #1 SMP PREEMPT Fri Dec 21 13:56:54 UTC 2018 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=96171ef4-cef8-4f06-9617-50d956d76ac8 rw quiet resume=UUID=4ad44aea-31e8-4b0b-97ff-a785e2dde73c
Build Date: 25 October 2018  04:42:32PM
 
Current version of pixman: 0.36.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.


The output from booting message from journalctl is attached. Nothing is in `/sys/class/drm/card0/error`. I think it has been cleaned away after a restart. Let me know if further information is needed. I have experienced this problem for quite some months, after several arch linux update, meaning kernel update and graphics related library update. Would appreciate to know how to fix it.

Jan 03 15:31:25 Noah kernel: [drm] GPU HANG: ecode 9:0:0x37d6a2c8, in chrome [12021], reason: hang on rcs0, action: reset                        
Jan 03 15:31:25 Noah kernel: [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.                           
Jan 03 15:31:25 Noah kernel: [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel                               
Jan 03 15:31:25 Noah kernel: [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.                      
Jan 03 15:31:25 Noah kernel: [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.                              
Jan 03 15:31:25 Noah kernel: [drm] GPU crash dump saved to /sys/class/drm/card0/error                                                            
Jan 03 15:31:25 Noah kernel: i915 0000:00:02.0: Resetting rcs0 for hang on rcs0                                                                  
Jan 03 15:31:25 Noah kernel: [drm:gen8_reset_engines [i915]] *ERROR* rcs0: reset request timeout                                                 
Jan 03 15:31:25 Noah kernel: i915 0000:00:02.0: Resetting chip for hang on rcs0                                                                  
Jan 03 15:31:25 Noah kernel: [drm:gen8_reset_engines [i915]] *ERROR* rcs0: reset request timeout                                                 
Jan 03 15:31:25 Noah kernel: [drm:gen8_reset_engines [i915]] *ERROR* rcs0: reset request timeout                                                 
Jan 03 15:31:26 Noah kernel: [drm:gen8_reset_engines [i915]] *ERROR* rcs0: reset request timeout                                                 
Jan 03 15:31:26 Noah kernel: i915 0000:00:02.0: Failed to reset chip
Jan 03 15:31:26 Noah kernel: [drm:gen8_reset_engines [i915]] *ERROR* rcs0: reset request timeout                                                 
Jan 03 15:31:26 Noah google-chrome.desktop[5785]: i965: Failed to submit batchbuffer: Input/output error                                         
Jan 03 15:31:26 Noah kernel: snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x2, last cmd=0x201f0500
Comment 1 Chris Wilson 2019-01-15 17:25:50 UTC
*** Bug 109214 has been marked as a duplicate of this bug. ***
Comment 2 Chris Wilson 2019-01-15 17:26:28 UTC
Jan 03 15:31:25 Noah kernel: [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.                              
Jan 03 15:31:25 Noah kernel: [drm] GPU crash dump saved to /sys/class/drm/card0/error
Comment 3 lishuai918 2019-01-16 05:15:12 UTC
> The output from booting message from journalctl is attached. Nothing is in `/sys/class/drm/card0/error`. I think it has been cleaned away after a restart.

If it is required, would you please point me to places where I can learn how to save the dump next time?
Comment 4 Chris Wilson 2019-02-01 12:41:13 UTC
sudo cat /sys/class/drm/card0/error > bug109213.error
Comment 5 Lakshmi 2019-07-03 08:16:23 UTC
No feedback from many months, closing as resolved works for me.

Please re-open if issue persists with latest drm-tip https://cgit.freedesktop.org/drm-tip and send dmesg from boot with kernel parameters drm.debug=0x1e log_buf_len=4M?

Remember to attach the GPU crash dump file.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.