Bug 109224 - OpenCL in darktable with AMD Turks doesn't works
Summary: OpenCL in darktable with AMD Turks doesn't works
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: 18.3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on: 87738
Blocks: 99553
  Show dependency treegraph
 
Reported: 2019-01-04 11:01 UTC by Andy Costanza
Modified: 2019-09-18 19:26 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Costanza 2019-01-04 11:01:43 UTC
Hi all and happy new year.
I'm on archlinux and when i run darktable i can't enable OpenCL feature.
I'm on HP laptop with a ATI/AMD Turks Radeon HD 7550M/7570M/7650M with:

- xorg-server 1.20.3-1 : https://www.archlinux.org/packages/extra/x86_64/xorg-server/
- xf86-video-ati 1:18.1.0-1 : https://www.archlinux.org/packages/extra/x86_64/xf86-video-ati/
- opencl-mesa 18.3.1-1 : https://www.archlinux.org/packages/extra/x86_64/opencl-mesa/

When i look on https://dri.freedesktop.org/wiki/GalliumCompute/ my Northern Islands chip is still in WIP for OpenCL 1.x since may 2018.

Is it the cause?
Comment 1 Jan Vesely 2019-01-04 13:56:09 UTC
afaik darktable needs OCL image support which is not implemented, which is probably what keeps the option disabled (there might also be a driver blacklist).

turks also has problems with sub32bit types (short, char), and doesn't support register spilling, so large kernels will fail to compile.
Comment 2 Andy Costanza 2019-01-04 14:06:42 UTC
do you need extra info of my laptop to solve this issue? lspci, clinfo,...?
Comment 3 Jan Vesely 2019-01-04 15:51:46 UTC
(In reply to Andy Costanza from comment #2)
> do you need extra info of my laptop to solve this issue? lspci, clinfo,...?

no,
it's just a ton of work and there's too little time/too few people working on clover.
Comment 4 GitLab Migration User 2019-09-18 19:26:53 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/650.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.