Bug 109226 - [CI][BAT] igt@i915_selftest@live_contexts - incomplete - GEM_BUG_ON(!i915_request_completed(rq))
Summary: [CI][BAT] igt@i915_selftest@live_contexts - incomplete - GEM_BUG_ON(!i915_req...
Status: CLOSED DUPLICATE of bug 108569
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: highest normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-04 15:06 UTC by Martin Peres
Modified: 2019-01-08 12:14 UTC (History)
1 user (show)

See Also:
i915 platform: ICL
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-01-04 15:06:12 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5349/shard-iclb5/igt@i915_selftest@live_contexts.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5350/shard-iclb6/igt@i915_selftest@live_contexts.html

https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4755/shard-iclb5/igt@i915_selftest@live_contexts.html

[...]

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5352/fi-icl-u3/igt@i915_selftest@live_contexts.html

<3> [582.159904] process_csb:994 GEM_BUG_ON(!i915_request_completed(rq))
<4> [582.160028] ------------[ cut here ]------------
<2> [582.160031] kernel BUG at drivers/gpu/drm/i915/intel_lrc.c:994!
<4> [582.160041] invalid opcode: 0000 [#1] PREEMPT SMP PTI
<4> [582.160046] CPU: 0 PID: 4871 Comm: i915_selftest Tainted: G     U            4.20.0-CI-CI_DRM_5352+ #1
<4> [582.160049] Hardware name: Intel Corporation Ice Lake Client Platform/IceLake U DDR4 SODIMM PD RVP TLC, BIOS ICLSFWR1.R00.2402.AD3.1810170014 10/17/2018
<4> [582.160122] RIP: 0010:process_csb+0x248/0x7a0 [i915]
<4> [582.160126] Code: c7 f6 9d e0 48 8b 35 b7 b8 1a 00 49 c7 c0 6f e0 80 a0 b9 e2 03 00 00 48 c7 c2 80 3a 7f a0 48 c7 c7 03 d4 71 a0 e8 58 7a a4 e0 <0f> 0b 49 8b 96 a8 00 00 00 48 8b 92 a0 02 00 00 8b 92 c0 00 00 00
<4> [582.160129] RSP: 0018:ffffc9000030f760 EFLAGS: 00010086
<4> [582.160133] RAX: 000000000000000b RBX: ffff8884a9d28008 RCX: 0000000000000000
<4> [582.160136] RDX: 0000000000000001 RSI: 0000000000000008 RDI: ffff8884ae02fa38
<4> [582.160139] RBP: ffffc9000030f7c8 R08: 0000000000576aad R09: ffff8884ae033000
<4> [582.160142] R10: 0000000000000000 R11: ffff8884ae02fa38 R12: ffff88836fb42064
<4> [582.160145] R13: 0000000000000004 R14: ffff88838a0a31c0 R15: ffff88836fb42040
<4> [582.160148] FS:  00007fe8b135b980(0000) GS:ffff8884afe00000(0000) knlGS:0000000000000000
<4> [582.160151] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4> [582.160154] CR2: 000055722399d3b0 CR3: 000000043d042002 CR4: 0000000000760ef0
<4> [582.160157] PKRU: 55555554
<4> [582.160159] Call Trace:
<4> [582.160227]  execlists_reset_prepare+0x54/0x150 [i915]
<4> [582.160288]  i915_gem_reset_prepare_engine+0x20/0x40 [i915]
<4> [582.160344]  i915_gem_reset_prepare+0x2c/0x70 [i915]
<4> [582.160403]  ? i915_request_wait+0x16d/0x840 [i915]
<4> [582.160452]  i915_reset+0x108/0x2e0 [i915]
<4> [582.160511]  __i915_wait_request_check_and_reset.isra.7+0x44/0x50 [i915]
<4> [582.160563]  i915_request_wait+0x4fd/0x840 [i915]
<4> [582.160570]  ? lock_acquire+0xa6/0x1c0
<4> [582.160575]  ? wake_up_q+0x70/0x70
<4> [582.160579]  ? wake_up_q+0x70/0x70
<4> [582.160639]  i915_gem_object_wait_fence+0x8a/0x110 [i915]
<4> [582.160689]  i915_gem_object_wait+0x2dc/0x510 [i915]
<4> [582.160744]  i915_gem_object_set_to_cpu_domain+0x35/0x130 [i915]
<4> [582.160795]  igt_vm_isolation+0xb1f/0xfe0 [i915]
<4> [582.160874]  __i915_subtests+0x5e/0xf0 [i915]
<4> [582.160940]  __run_selftests+0x10b/0x190 [i915]
<4> [582.160999]  i915_live_selftests+0x2c/0x60 [i915]
<4> [582.161053]  i915_pci_probe+0x50/0xa0 [i915]
<4> [582.161058]  pci_device_probe+0xa1/0x130
<4> [582.161064]  really_probe+0xf3/0x3e0
<4> [582.161069]  driver_probe_device+0x10a/0x120
<4> [582.161073]  __driver_attach+0xdb/0x100
<4> [582.161077]  ? driver_probe_device+0x120/0x120
<4> [582.161082]  bus_for_each_dev+0x74/0xc0
<4> [582.161087]  bus_add_driver+0x15f/0x250
<4> [582.161091]  ? 0xffffffffa0be2000
<4> [582.161095]  driver_register+0x56/0xe0
<4> [582.161099]  ? 0xffffffffa0be2000
<4> [582.161103]  do_one_initcall+0x58/0x2e0
<4> [582.161107]  ? do_init_module+0x1d/0x1ea
<4> [582.161112]  ? rcu_read_lock_sched_held+0x6f/0x80
<4> [582.161117]  ? kmem_cache_alloc_trace+0x264/0x290
<4> [582.161122]  do_init_module+0x56/0x1ea
<4> [582.161127]  load_module+0x227a/0x29c0
<4> [582.161140]  ? __se_sys_finit_module+0xd3/0xf0
<4> [582.161144]  __se_sys_finit_module+0xd3/0xf0
<4> [582.161152]  do_syscall_64+0x55/0x190
<4> [582.161158]  entry_SYSCALL_64_after_hwframe+0x49/0xbe
<4> [582.161161] RIP: 0033:0x7fe8b0c21839
<4> [582.161165] Code: 00 f3 c3 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 40 00 48 89 f8 48 89 f7 48 89 d6 48 89 ca 4d 89 c2 4d 89 c8 4c 8b 4c 24 08 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 1f f6 2c 00 f7 d8 64 89 01 48
<4> [582.161168] RSP: 002b:00007ffe0c5d1fe8 EFLAGS: 00000246 ORIG_RAX: 0000000000000139
<4> [582.161172] RAX: ffffffffffffffda RBX: 0000557325dc20b0 RCX: 00007fe8b0c21839
<4> [582.161175] RDX: 0000000000000000 RSI: 0000557325dc2e50 RDI: 0000000000000006
<4> [582.161178] RBP: 0000557325dc2e50 R08: 0000000000000004 R09: 0000000000000000
<4> [582.161181] R10: 00007ffe0c5d2160 R11: 0000000000000246 R12: 0000000000000000
<4> [582.161184] R13: 0000557325dbc970 R14: 0000000000000020 R15: 000000000000003c
<4> [582.161195] Modules linked in: i915(+) amdgpu chash gpu_sched ttm vgem snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic x86_pkg_temp_thermal coretemp crct10dif_pclmul crc32_pclmul ghash_clmulni_intel snd_hda_codec btusb snd_hwdep btrtl btbcm cdc_ether btintel snd_hda_core usbnet mii bluetooth snd_pcm e1000e i2c_i801 ecdh_generic prime_numbers [last unloaded: i915]
Comment 1 CI Bug Log 2019-01-04 15:07:25 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* ICL: igt@i915_selftest@live_contexts - incomplete - GEM_BUG_ON(!i915_request_completed(rq)) (No new failures associated)
Comment 2 Chris Wilson 2019-01-04 16:35:56 UTC
Since the gpu should not have hanged there anyway (it's falling over the readonly faults), its state is indeterminate and that it tripped over itself may just be more undefined behaviour.

First fix the known issue and see what remains.

*** This bug has been marked as a duplicate of bug 108569 ***
Comment 3 CI Bug Log 2019-01-08 12:14:09 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@i915_selftest@live_contexts - incomplete - GEM_BUG_ON(!i915_request_completed(rq)) -}
{+ ICL: igt@i915_selftest@live_(contexts|hangcheck) - incomplete - GEM_BUG_ON(!i915_request_completed(rq)) +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5376/fi-icl-u2/igt@i915_selftest@live_hangcheck.html


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.