Bug 109288 - [CI][SHARDS] igt@pm_sseu@full-enable - skip - Test requirement: igt_get_media_spinfunc() for icl
Summary: [CI][SHARDS] igt@pm_sseu@full-enable - skip - Test requirement: igt_get_media...
Status: RESOLVED NOTABUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Tvrtko Ursulin
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-10 14:34 UTC by Martin Peres
Modified: 2019-09-27 05:41 UTC (History)
1 user (show)

See Also:
i915 platform: ICL, TGL
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-01-10 14:34:54 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5388/shard-iclb2/igt@pm_sseu@full-enable.html

Test requirement: gem.spinfunc
Last errno: 2, No such file or directory
Comment 1 CI Bug Log 2019-01-10 14:35:21 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* ICL: igt@pm_sseu@full-enable - skip - Test requirement: gem.spinfunc, Last errno: 2, No such file or directory
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5388/shard-iclb2/igt@pm_sseu@full-enable.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_3578/shard-iclb5/igt@pm_sseu@full-enable.html
Comment 2 Francesco Balestrieri 2019-01-16 07:20:47 UTC
Matt, could you take a look?
Comment 3 mwa 2019-01-16 17:28:30 UTC
According to Tony Ye, the gen9 media kernel + batch setup should also work with gen11, without modification. I guess we just need to send something as RFT to confirm that...
Comment 4 Francesco Balestrieri 2019-02-06 07:24:52 UTC
I wonder if we should enable this now that dynamic SSEU is merged. Tvrtko?
Comment 5 Tvrtko Ursulin 2019-02-25 11:51:08 UTC
It is not exactly related to Dynamic SSEU but I have sent a patch which enables gen9 media spin func usage on gen11 for testing.
Comment 6 Tvrtko Ursulin 2019-02-25 11:56:52 UTC
Btw, are skips automatically logged as bugs? Makes sense on a PASS -> SKIP transition, but this test was always skipping on gen11 AFAICS.
Comment 7 Francesco Balestrieri 2019-03-01 08:26:52 UTC
> It is not exactly related to Dynamic SSEU but I have sent a patch which 
> enables gen9 media spin func usage on gen11 for testing.

Did it help? I see the RFT on the mailing list but I don't now how to check the outcome.
Comment 8 Tvrtko Ursulin 2019-03-01 09:06:44 UTC
Unfortunately no Icelake results from the shards, they are excluded.

But there is another source of information which says gen9 media spin kernel is not completely right for gen11. So I kind of parked the patch it being stuck between the two sets of conflicting empirical evidence.
Comment 9 Francesco Balestrieri 2019-03-01 09:10:01 UTC
Should we remove the test for gen11?
Comment 10 Chris Wilson 2019-03-01 09:23:58 UTC
The test is already not being run on icl; you mean mark the bug as wontfix until further notice.
Comment 11 Francesco Balestrieri 2019-03-12 12:49:06 UTC
As per Chris' comment
Comment 12 Martin Peres 2019-03-12 13:13:42 UTC
(In reply to Tvrtko Ursulin from comment #6)
> Btw, are skips automatically logged as bugs? Makes sense on a PASS -> SKIP
> transition, but this test was always skipping on gen11 AFAICS.

All skips are considered as bugs, and acceptable skips are closed as NOTABUG. This is the only way to draw attention and assess if something is missing or not. For example, we could have forgotten to add mocs settings for ICL if we had not had such process.

(In reply to Tvrtko Ursulin from comment #8)
> Unfortunately no Icelake results from the shards, they are excluded.

Just for clarification: we have no icl sharded runs for pre-merge testing, but post-merge runs are still done and this bug still has 100% reproduction rate.
Comment 13 Martin Peres 2019-09-11 07:10:29 UTC
I am reopening the bug, as the loss of coverage has not been explained and it also affects TGL.
Comment 14 CI Bug Log 2019-09-11 07:11:14 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@pm_sseu@full-enable - skip - Test requirement: gem.spinfunc, Last errno: 2, No such file or directory -}
{+ ICL TGL: igt@pm_sseu@full-enable - skip - Test requirement: gem.spinfunc, Last errno: 2, No such file or directory, SKIP +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_362/fi-tgl-u/igt@i915_pm_sseu@full-enable.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_365/fi-tgl-u/igt@i915_pm_sseu@full-enable.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@i915_pm_sseu@full-enable.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@i915_pm_sseu@full-enable.html
Comment 15 Tvrtko Ursulin 2019-09-23 08:05:26 UTC
There is no *loss* of coverage to explain. There was _lack_ of coverage ever since the start of Gen11.

The task is about finding someone who can write/adapt a spinning media kernel for gen11+.
Comment 16 Francesco Balestrieri 2019-09-27 05:41:16 UTC
This test is not expected to work from gen11 onwards.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.