Bug 109358 - [CI][SHARDS] igt@kms_dp_dsc@basic-dsc-enable-edp - fail - Failed assertion: is_dp_dsc_enabled(data), Last errno: 25, Inappropriate ioctl for device, Default DSC enable failed on Connector: eDP-1 Pipe: A
Summary: [CI][SHARDS] igt@kms_dp_dsc@basic-dsc-enable-edp - fail - Failed assertion: i...
Status: RESOLVED DUPLICATE of bug 110270
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Manasi
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-14 17:14 UTC by Martin Peres
Modified: 2019-04-10 13:14 UTC (History)
1 user (show)

See Also:
i915 platform: ICL
i915 features: display/eDP


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-01-14 17:14:45 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5414/shard-iclb7/igt@kms_dp_dsc@basic-dsc-enable-edp.html

Starting subtest: basic-dsc-enable-eDP
(kms_dp_dsc:1339) CRITICAL: Test assertion failure function update_display, file ../tests/kms_dp_dsc.c:182:
(kms_dp_dsc:1339) CRITICAL: Failed assertion: is_dp_dsc_enabled(data)
(kms_dp_dsc:1339) CRITICAL: Last errno: 25, Inappropriate ioctl for device
(kms_dp_dsc:1339) CRITICAL: Default DSC enable failed on Connector: eDP-1 Pipe: ASubtest basic-dsc-enable-eDP failed.

And while we are at it, let's fix the missing \n at the end of the error message ;)
Comment 1 CI Bug Log 2019-01-14 17:18:43 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* ICL: igt@kms_dp_dsc@basic-dsc-enable-edp - fail - Failed assertion: is_dp_dsc_enabled(data), Last errno: 25, Default DSC enable failed on Connector: eDP-1
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5408/shard-iclb7/igt@kms_dp_dsc@basic-dsc-enable-edp.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5414/shard-iclb7/igt@kms_dp_dsc@basic-dsc-enable-edp.html
Comment 2 James Ausmus 2019-03-08 21:00:39 UTC
Is this still an issue after the BIOS updates?
Comment 3 Martin Peres 2019-04-08 11:42:27 UTC
This is the same failure as 110270, except with additional errno pollution (Arek is filing a bug for that).

*** This bug has been marked as a duplicate of bug 110270 ***
Comment 4 CI Bug Log 2019-04-10 13:14:40 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.