Bug 109399 - dpms off gives black screen [drm:intel_dp_start_link_train] [CONNECTOR:67:eDP-1] Link Training failed at link rate = 162000, lane count = 2
Summary: dpms off gives black screen [drm:intel_dp_start_link_train] [CONNECTOR:67:eDP...
Status: RESOLVED DUPLICATE of bug 109398
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged, ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-20 11:11 UTC by Seppe
Modified: 2019-01-26 08:56 UTC (History)
1 user (show)

See Also:
i915 platform: BDW
i915 features: display/eDP


Attachments
logs before and after the bug and machine information (73.79 KB, application/gzip)
2019-01-20 11:11 UTC, Seppe
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Seppe 2019-01-20 11:11:48 UTC
Created attachment 143170 [details]
logs before and after the bug and machine information

dpms off gives black screen 

I am using the 5.0.0-rc2 kernel from:
> git clone git://anongit.freedesktop.org/drm-tip
I have incuded a WiFi driver and btrfs to the .config made with "make
defconfig".

I have used the "i915.fastboot=1" kernel parameter to boot. The other usual
parameters "splash=silent quiet showopts drm.debug=0xe log_buf_len=4M". are
also used. Without this "i915.fastboot=1", the kernel boots into a flashing
screen and the computer can not be used. (see https://bugs.freedesktop.org/show_bug.cgi?id=109398)


When i run the command:
> xset dpms force off
the screen goes off. This is correct. When in touch something, the screen
should come back, but starts to flicker with small flashes of white at the
bottom of the screen.. No image is visible. Text terminals
(ctrl-alt-F1) are also not visible. The flickering is mostly at the bottom of
the screen, once every two seconds (or something like that time).

Recovery is sometimes happening by opening and closing the lid of the
laptop. One out of seven attempts brings back the screen. Most of the time a
reboot is the only solution.

This also happens with:
> xset dpms force standby
> xset dpms force suspend


This behavior is not present when running the opensuse leap 15.0 kernel :
kernel-default-4.12.14-lp150.11.4.x86_64.rpm
http://download.opensuse.org/distribution/leap/15.0/repo/oss/x86_64/kernel-default-4.12.14-lp150.11.4.x86_64.rpm.mirrorlist

I also made a commend about this bug at
https://bugzilla.suse.com/show_bug.cgi?id=1119621#c15


Note that the hardware i am using is a chromebook (Dell). The firmware is
having bugs, which i can not solve. This can also interfere here. 


In the logs attached there are tree sets of files:
- *_before
command "xset dpms force off" is executed
- *_after (here the screen is black) 
- *_flicker (here i have touched something and the screen is flickering.)

In the last dmesg logs (dmesg_flicker) i keep seeing at the end:
[drm:intel_dp_start_link_train] [CONNECTOR:67:eDP-1] Link Training failed at link rate = 162000, lane count = 2
This with a whole lot of other lines. There is no clear error or warning in
the log.

There is no error reported by the GPU. 

The script's which i made to create all log files are also included. These are
the .sh files. The commands given after the screen goes black are given with
the use of a ssh shell from a other computer. 


> inxi -bxx
System:    Host: linux-6axq Kernel: 5.0.0-rc2test-g1fb7b31e074e x86_64 bits: 64 compiler: gcc v: 8.2.1 Console: N/A 
           dm: LightDM Distro: openSUSE Tumbleweed 20190115 
Machine:   Type: Desktop System: GOOGLE product: Lulu v: Pilot serial: 123456789 Chassis: type: 3 serial: N/A 
           Mobo: N/A model: N/A serial: N/A BIOS: coreboot v: N/A date: 03/28/2016 
Battery:   ID-1: BAT0 charge: 41.2 Wh condition: 70.1/67.0 Wh (105%) volts: 11.6/11.4 model: SMP-LIS DELL MJ serial: 0340 
           status: Discharging 
CPU:       Dual Core: Intel Core i3-5005U type: MT MCP arch: Broadwell speed: 1743 MHz min/max: 500/2000 MHz 
Graphics:  Device-1: Intel HD Graphics 5500 driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:1616 
           Display: server: X.org 1.20.3 driver: intel tty: 180x31 
           Message: Advanced graphics data unavailable in console for root. 
Network:   Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel port: 1840 bus ID: 01:00.0 chip ID: 8086:08b1 
Drives:    Local Storage: total: 111.79 GiB used: 71.60 GiB (64.0%) 
Info:      Processes: 189 Uptime: N/A Memory: 3.78 GiB used: 410.2 MiB (10.6%) Init: systemd v: 239 runlevel: 5 
           target: graphical.target Compilers: gcc: 8.2.1 alt: 8 Shell: dump-info-befor inxi: 3.0.29 


possible duplicate:
https://bugs.freedesktop.org/show_bug.cgi?id=108266
https://bugs.freedesktop.org/show_bug.cgi?id=109398
Comment 1 Seppe 2019-01-26 08:55:16 UTC
solution (on the mainline kernel):
git revert 49218c83e25b6f0708f246b07d570b2c43a98223

The problem is caused by the commit 49218c83e25b6f0708f246b07d570b2c43a98223
"drm/i915/dp: Link train Fallback on eDP only if fallback link BW can fit panel's native mode".

I have not dig into this code, but only tried is reverting helps. It does. The problem is gone without this commit.
Comment 2 Seppe 2019-01-26 08:56:43 UTC

*** This bug has been marked as a duplicate of bug 109398 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.