Bug 109515 - Running BaseMark Web 3.0 (WebGL) cause unresponsive desktop (gen5)
Summary: Running BaseMark Web 3.0 (WebGL) cause unresponsive desktop (gen5)
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 18.2
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-31 09:51 UTC by Clemens Eisserer
Modified: 2019-09-25 20:29 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Clemens Eisserer 2019-01-31 09:51:23 UTC
When running the BaseMark 3.0 Web tests https://web.basemark.com/ (WebGL), my whole desktop becomes unresponsive - regardless whether I run the tests with Google Chrome or Firefox.

System: Arrandale laptop (i5-540M)

Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel(R) Ironlake Mobile  (0x46)
    Version: 18.2.8
    Accelerated: yes
    Video memory: 1536MB
    Unified memory: yes
    Preferred profile: compat (0x2)
    Max core profile version: 0.0
    Max compat profile version: 2.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 2.0


Linux localhost.localdomain 4.20.4-200.fc29.x86_64 #1 SMP Wed Jan 23 16:11:28 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Glamor acceleration

KWin + OpenGL Compositor
Comment 1 Chris Wilson 2019-01-31 11:25:13 UTC
GPU hangs or just overloaded? For the latter it is technically fixable so long as the benchmark rendering is off the critical path for interactivity (e.g. if the benchmark was offscreen). 90% of the work is done for a priority scheduler for gen5, just the last 10% will take 90% of the time...
Comment 2 Denis 2019-01-31 11:58:41 UTC
hi, I ran these tests on 2 different SNB's, found out that during running 4,5 and 7 tests PC freezes, but dmesg doesn't report about any hangs or segfaults during running tests
(btw, on KBL it freezes too)
Comment 3 Tapani Pälli 2019-02-04 07:19:29 UTC
I run this on my HSW, it 'freezes' for some time (gnome-shell becomes unusable for some time) but then is able to eventually continue. It looks like it is simply 'very heavy'?
Comment 4 GitLab Migration User 2019-09-25 20:29:28 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1785.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.