Bug 109516 - [CI][BAT] boot - aborted - *ERROR* mismatch in pipe_bpp (expected 24, found 0)
Summary: [CI][BAT] boot - aborted - *ERROR* mismatch in pipe_bpp (expected 24, found 0)
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: highest normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords: regression
Depends on:
Blocks:
 
Reported: 2019-01-31 11:23 UTC by Martin Peres
Modified: 2019-04-17 14:41 UTC (History)
4 users (show)

See Also:
i915 platform: BXT
i915 features: display/DSI


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-01-31 11:23:09 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4802/fi-bxt-dsi/igt@runner@aborted.html

<3>[    9.606033] [drm:pipe_config_err [i915]] *ERROR* mismatch in pipe_bpp (expected 24, found 0)
<4>[    9.606037] ------------[ cut here ]------------
<4>[    9.606040] pipe state doesn't match!
<4>[    9.606179] WARNING: CPU: 3 PID: 7 at drivers/gpu/drm/i915/intel_display.c:12311 intel_atomic_commit_tail+0xd7b/0xdf0 [i915]
<4>[    9.606181] Modules linked in: x86_pkg_temp_thermal coretemp crct10dif_pclmul crc32_pclmul i915 ghash_clmulni_intel btusb btrtl btbcm btintel i2c_i801 lpc_ich snd_hda_intel bluetooth snd_hda_codec snd_hwdep snd_hda_core ecdh_generic igb snd_pcm mei_me mei prime_numbers i2c_hid pinctrl_broxton pinctrl_intel
<4>[    9.606216] CPU: 3 PID: 7 Comm: kworker/u8:0 Not tainted 5.0.0-rc4-CI-CI_DRM_5518+ #1
<4>[    9.606219] Hardware name: Intel Corp. Broxton P/Apollolake RVP1A, BIOS APLKRVPA.X64.0150.B11.1608081044 08/08/2016
<4>[    9.606226] Workqueue: events_unbound async_run_entry_fn
<4>[    9.606316] RIP: 0010:intel_atomic_commit_tail+0xd7b/0xdf0 [i915]
<4>[    9.606319] Code: cc 29 e1 e9 c1 f8 ff ff e8 c2 72 d0 e0 0f 0b 0f b6 44 24 18 e9 87 f7 ff ff e8 b1 72 d0 e0 0f 0b e9 a9 f7 ff ff e8 a5 72 d0 e0 <0f> 0b e9 21 f8 ff ff e8 99 72 d0 e0 0f 0b 0f b6 0c 24 e9 aa fc ff
<4>[    9.606322] RSP: 0018:ffffc900000839e0 EFLAGS: 00010286
<4>[    9.606326] RAX: 0000000000000000 RBX: ffff88816903c138 RCX: 0000000000000000
<4>[    9.606328] RDX: 0000000000000000 RSI: ffffffff8212f9f2 RDI: 00000000ffffffff
<4>[    9.606331] RBP: ffff8881636fc138 R08: 00000000244a95a8 R09: 0000000000000000
<4>[    9.606334] R10: ffff88816903c430 R11: 0000000000000000 R12: ffff888163a89bf8
<4>[    9.606336] R13: ffff8881636fa548 R14: ffff888163a90758 R15: ffff888163a90000
<4>[    9.606339] FS:  0000000000000000(0000) GS:ffff88817bb80000(0000) knlGS:0000000000000000
<4>[    9.606342] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4>[    9.606345] CR2: 00007ffd60c5ee38 CR3: 0000000174680000 CR4: 00000000003406e0
<4>[    9.606348] Call Trace:
<4>[    9.606452]  intel_atomic_commit+0x244/0x330 [i915]
<4>[    9.606463]  restore_fbdev_mode_atomic+0x1da/0x1f0
<4>[    9.606486]  drm_fb_helper_restore_fbdev_mode_unlocked+0x42/0x90
<4>[    9.606492]  drm_fb_helper_set_par+0x24/0x50
<4>[    9.606576]  intel_fbdev_set_par+0x11/0x40 [i915]
<4>[    9.606584]  fbcon_init+0x439/0x610
<4>[    9.606597]  visual_init+0xc9/0x120
<4>[    9.606603]  do_bind_con_driver+0x1f2/0x410
<4>[    9.606616]  do_take_over_console+0x71/0x190
<4>[    9.606624]  do_fbcon_takeover+0x53/0xb0
<4>[    9.606628]  notifier_call_chain+0x34/0x90
<4>[    9.606637]  blocking_notifier_call_chain+0x3f/0x60
<4>[    9.606645]  register_framebuffer+0x2a5/0x360
<4>[    9.606662]  __drm_fb_helper_initial_config_and_unlock+0x2cf/0x570
<4>[    9.606753]  intel_fbdev_initial_config+0xf/0x20 [i915]
<4>[    9.606758]  async_run_entry_fn+0x34/0x160
<4>[    9.606765]  process_one_work+0x245/0x610
<4>[    9.606779]  worker_thread+0x37/0x380
<4>[    9.606787]  ? process_one_work+0x610/0x610
<4>[    9.606791]  kthread+0x119/0x130
<4>[    9.606796]  ? kthread_park+0x80/0x80
<4>[    9.606804]  ret_from_fork+0x3a/0x50
<4>[    9.606825] irq event stamp: 25148
<4>[    9.606829] hardirqs last  enabled at (25147): [<ffffffff81123e52>] vprintk_emit+0x302/0x320
<4>[    9.606834] hardirqs last disabled at (25148): [<ffffffff810019b0>] trace_hardirqs_off_thunk+0x1a/0x1c
<4>[    9.606838] softirqs last  enabled at (24876): [<ffffffff81c0033a>] __do_softirq+0x33a/0x4b9
<4>[    9.606843] softirqs last disabled at (24869): [<ffffffff810b50b1>] irq_exit+0xd1/0xe0
<4>[    9.606926] WARNING: CPU: 3 PID: 7 at drivers/gpu/drm/i915/intel_display.c:12311 intel_atomic_commit_tail+0xd7b/0xdf0 [i915]
<4>[    9.606929] ---[ end trace 22a8678858f3d215 ]---
Comment 2 Lakshmi 2019-04-05 06:22:18 UTC
Due to regression, priority is set as Highest.
Comment 3 Jani Nikula 2019-04-05 06:28:39 UTC
commit ca0b04db14a51893322a2a4638a41dc79c2cf98a
Author: Hans de Goede <hdegoede@redhat.com>
Date:   Sat Dec 1 12:31:45 2018 +0100

    drm/i915/dsi: Fix pipe_bpp for handling for 6 bpc pixel-formats

stops reading the pipe_bpp from hardware in DSI encoder->get_config hook. This is required for BXT/GLK DSI.
Comment 4 Hans de Goede 2019-04-05 09:06:15 UTC
(In reply to Jani Nikula from comment #3)
> commit ca0b04db14a51893322a2a4638a41dc79c2cf98a
> Author: Hans de Goede <hdegoede@redhat.com>
> Date:   Sat Dec 1 12:31:45 2018 +0100
> 
>     drm/i915/dsi: Fix pipe_bpp for handling for 6 bpc pixel-formats
> 
> stops reading the pipe_bpp from hardware in DSI encoder->get_config hook.
> This is required for BXT/GLK DSI.

Weird, I would expect pipe_config->pipe_bpp to get set from get_pipe_config in intel_display.c and for 6bpp color formats this should not be overriden with mipi_dsi_pixel_format_to_bpp(fmt) because there the pipe_bpp may be different from dsi bpp (when dsi is using sparse 6bpp, so 6bpp packed in 24 bits per pixel).

But I only tested on BYT and CHT hardware, so if this chunk:

--- a/drivers/gpu/drm/i915/vlv_dsi.c
+++ b/drivers/gpu/drm/i915/vlv_dsi.c
@@ -1059,10 +1064,8 @@ static void bxt_dsi_get_pipe_config(struct intel_encoder *encoder,
 	}
 
 	fmt = I915_READ(MIPI_DSI_FUNC_PRG(port)) & VID_MODE_FORMAT_MASK;
-	pipe_config->pipe_bpp =
-			mipi_dsi_pixel_format_to_bpp(
-				pixel_format_from_register_bits(fmt));
-	bpp = pipe_config->pipe_bpp;
+	bpp = mipi_dsi_pixel_format_to_bpp(
+			pixel_format_from_register_bits(fmt));
 
 	/* Enable Frame time stamo based scanline reporting */
 	adjusted_mode->private_flags |=

Needs to be reverted that is fine with me.

I'm afraid I'm totally swamped with other stuff. Jani can you do a patch reverting that chunk and then see of it makes the test-case in question happy again?
Comment 5 Ville Syrjala 2019-04-11 14:38:39 UTC
Fixed with

commit 499653501baf27d26e73cb5ce744869df3400509
Author: Ville Syrjälä <ville.syrjala@linux.intel.com>
Date:   Fri Apr 5 17:13:49 2019 +0300

    drm/i915: Fix pipe_bpp readout for BXT/GLK DSI
Comment 6 Martin Peres 2019-04-17 14:40:55 UTC
(In reply to Ville Syrjala from comment #5)
> Fixed with
> 
> commit 499653501baf27d26e73cb5ce744869df3400509
> Author: Ville Syrjälä <ville.syrjala@linux.intel.com>
> Date:   Fri Apr 5 17:13:49 2019 +0300
> 
>     drm/i915: Fix pipe_bpp readout for BXT/GLK DSI

Thanks, fixed in drmtip_252!
Comment 7 CI Bug Log 2019-04-17 14:41:01 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.