Bug 109530 - [CI][BAT] igt@gem_exec_suspend@basic-s3 - dmesg-warn - *ERROR* failed to enable link training
Summary: [CI][BAT] igt@gem_exec_suspend@basic-s3 - dmesg-warn - *ERROR* failed to enab...
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: highest normal
Assignee: Imre Deak
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged, ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-01 12:14 UTC by Lakshmi
Modified: 2019-03-06 17:28 UTC (History)
1 user (show)

See Also:
i915 platform: ICL
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-02-01 12:14:37 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5519/fi-icl-y/igt@gem_exec_suspend@basic-s3.html

Dmesg-Warnings	
<3> [82.574927] [drm:intel_dp_start_link_train [i915]] *ERROR* failed to enable link training
Comment 1 CI Bug Log 2019-02-01 12:18:03 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* ICL:  igt@gem_exec_suspend@basic-s3 - dmesg-warn - *ERROR* failed to enable link training
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_3703/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12040/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12058/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5519/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_3773/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5520/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12111/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5521/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12112/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12113/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5522/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12114/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12115/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12116/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5523/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5524/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4803/fi-icl-y/igt@gem_exec_suspend@basic-s3.html
Comment 2 Imre Deak 2019-02-06 17:07:01 UTC
The problem is that the eDP panel is used as a DP output (due to the lack of a correct VBT). That in turn means we'll not enable VDD (which is an eDP specific thing). That is most probably the reason for the link training failure for which we normally keep VDD enabled. The problem only triggers after an S3 suspend/resume cycle because before that we happen to have VDD enabled, left as such by BIOS.

I think we shouldn't add more hacks for systems without VBT to fix this, rather wait for the VBT fix itself.
Comment 3 Jani Saarinen 2019-02-27 16:48:28 UTC
Quick update to VBT corruption as new CI results (BAT) came. Now ICL-Y was updated

<6>[    0.000000] DMI: Intel Corporation Ice Lake Client Platform/IceLake Y LPDDR4x T4 RVP TLC, BIOS ICLSFWR1.R00.3087.A00.1902250334 02/25/2019

And now system works as expected: https://intel-gfx-ci.01.org/tree/drm-tip/fi-icl-y.html

Resolving.
Comment 4 Martin Peres 2019-03-06 17:28:37 UTC
(In reply to Jani Saarinen from comment #3)
> Quick update to VBT corruption as new CI results (BAT) came. Now ICL-Y was
> updated
> 
> <6>[    0.000000] DMI: Intel Corporation Ice Lake Client Platform/IceLake Y
> LPDDR4x T4 RVP TLC, BIOS ICLSFWR1.R00.3087.A00.1902250334 02/25/2019
> 
> And now system works as expected:
> https://intel-gfx-ci.01.org/tree/drm-tip/fi-icl-y.html
> 
> Resolving.

It indeed fixed it, thanks!
Comment 5 CI Bug Log 2019-03-06 17:28:47 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.