Bug 109558 - Plasma locks up after splash screen
Summary: Plasma locks up after splash screen
Status: RESOLVED DUPLICATE of bug 109556
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/nouveau (show other bugs)
Version: 18.3
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Nouveau Project
QA Contact: Nouveau Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-05 14:30 UTC by qjztreez
Modified: 2019-02-06 14:30 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Output of dmesg (98.19 KB, text/plain)
2019-02-05 14:30 UTC, qjztreez
Details
Part of pacman.log (5.05 KB, text/plain)
2019-02-06 00:12 UTC, qjztreez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description qjztreez 2019-02-05 14:30:38 UTC
Created attachment 143306 [details]
Output of dmesg

Operating System: Arch Linux 
KDE Plasma Version: 5.14.5
Qt Version: 5.12.1
KDE Frameworks Version: 5.54.0
Kernel Version: 4.20.6-arch1-1-ARCH
Graphics Card: NVIDIA GeForce GT 650M

Plasma locks up after splash screen, and it is sometimes (but not always) possible to switch to tty2 and kill the session using loginctl. The magic SysRq keys Alt+SysRq+REISUB and Alt+SysRq+REISUO always work though.

This seems to be a problem related to acceleration because adding the 'nouveau.noaccel=1' kernel parameter solves the problem, but disables some desktop effects as well.
Comment 1 qjztreez 2019-02-06 00:12:23 UTC
Created attachment 143309 [details]
Part of pacman.log

The problem occurred after upgrading mesa from 18.3.2 to 18.3.3 and qt from 5.12.0 to 5.12.1, but downgrading mesa to 18.3.2 didn't help.
Comment 2 qjztreez 2019-02-06 14:30:56 UTC

*** This bug has been marked as a duplicate of bug 109556 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.