Bug 109574 - Blender 2.8
Summary: Blender 2.8
Status: NEW
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/X11 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-06 18:45 UTC by veli
Modified: 2019-02-10 12:10 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
blender log when i launch it from terminal (1.75 KB, text/plain)
2019-02-06 18:45 UTC, veli
Details
glxinfo HD 4850 (103.42 KB, text/plain)
2019-02-08 16:44 UTC, veli
Details
r600dumpsshaders_HD4850_output (499.36 KB, text/plain)
2019-02-08 16:44 UTC, veli
Details
Xorg Logs of HD4850 (40.98 KB, text/plain)
2019-02-08 16:45 UTC, veli
Details
glxinfo HD2600pro (140.35 KB, text/plain)
2019-02-08 16:47 UTC, veli
Details
R600_DUMP_SHADERS_hd2600pro (957.72 KB, text/plain)
2019-02-08 16:49 UTC, veli
Details
xorg log files hd2600pro (44.55 KB, text/plain)
2019-02-08 16:52 UTC, veli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description veli 2019-02-06 18:45:56 UTC
Created attachment 143320 [details]
blender log when i launch it from terminal

Firstly, I want to apologize for writing this poorly written bug report. My knowledge is limited about drivers and such. I don't even know if I selected the right Component.

Secondly, here is some of my system info:


System Info:

Operating system: Ubuntu 18.04.1 LTS x86_64
Graphics card: AMD RV770

And Blender version:

2.80 (sub 43), branch: blender2.7, commit date: 2019-02-04 23:43, hash: 445433a6913f


Description:

Problem is Blender 2.80 isn't working at all. Interface is broken, lines are missing it is literally broken. I reported this bug to Blender first. They said it's about the drivers. 

see. https://developer.blender.org/T61206

When I launch blender via terminal it says sth about X11 and OpenGl. It also says that "Couldn't find a matching GPU name." Check the attachment.

I know that I have a very old GPU. But I have a second computer. It has HD 2600 Pro which is older than HD 4850 but it just runs Blender 2.80 fine. This baffles me as an older GPU could run Blender 2.8 while my HD 4850 can't.


Additional Builds and Platforms:

I have a second computer. It has HD 2600 Pro which is, as you know, older than HD 4850 but it just runs Blender 2.80 fine. Same drivers and OS's intalled on both computers.
Comment 1 Gert Wollny 2019-02-07 14:47:51 UTC
The HD 2600 Pro and  HD 4850 are slightly different hardware, so that the shader code generated by the drivers might be somewhat different. 

In any case, you can try to run blender with

  R600_DEBUG=nosb blender 

and see whether this helps. If this doesn't help then you please add the logging output by running 

  R600_DUMP_SHADERS=1 blender 

from both computers. This will print the shaders and one might be able to spot a difference that gives an idea where to look.
Comment 2 Michel Dänzer 2019-02-07 15:23:57 UTC
These messages:

Received X11 Error:
	error code:   182
	request code: 156
	minor code:   34
	error text:   GLXBadFBConfig
[...]
Received X11 Error:
	error code:   8
	request code: 156
	minor code:   34
	error text:   BadMatch (invalid parameter attributes)

indicate that blender fails to create a GLX context multiple times. Do you get these messages on the other system with an HD 2600 Pro as well? If not, it might be helpful if you attach the Xorg log files and the outputs of glxinfo from both systems.
Comment 3 veli 2019-02-08 16:44:17 UTC
Created attachment 143338 [details]
glxinfo HD 4850
Comment 4 veli 2019-02-08 16:44:57 UTC
Created attachment 143339 [details]
r600dumpsshaders_HD4850_output
Comment 5 veli 2019-02-08 16:45:27 UTC
Created attachment 143340 [details]
Xorg Logs of HD4850
Comment 6 veli 2019-02-08 16:47:20 UTC
Created attachment 143341 [details]
glxinfo HD2600pro
Comment 7 veli 2019-02-08 16:49:50 UTC
Created attachment 143342 [details]
R600_DUMP_SHADERS_hd2600pro
Comment 8 veli 2019-02-08 16:52:52 UTC
Created attachment 143343 [details]
xorg log files hd2600pro
Comment 9 veli 2019-02-08 16:58:55 UTC
Blender version: 2.80 (sub 44), commit date: 2019-02-07 23:15, hash: 3d16a268ee68

Mr. Wollny,

I tried R600_DEBUG=nosb blender but nothing's changed. I added the log files you asked.


Mr. Michel,

I also get these messages on my other system. I discovered that both system's aren't able to run blender without a problem. Even though the interface is good, I experienced crashes on my HD2600 system. 

I added log files you asked also.
Comment 10 Michel Dänzer 2019-02-08 17:39:19 UTC
One difference between the glxinfo outputs is that there are no 10 bit per component FBConfigs with the HD 2600 Pro. Does running blender like this:

 allow_rgb10_configs=false blender

avoid the problem?
Comment 11 veli 2019-02-08 17:49:16 UTC
Unfortunately no. Nothing's changed.
Comment 12 Gert Wollny 2019-02-09 15:26:18 UTC
for one thing you are actually running different versions of mesa: 
This is the 2600:
-    Device: AMD RV630 (DRM 2.50.0 / 4.15.0-45-generic, LLVM 7.0.0) (0x9589)
-    Version: 18.3.3

and this is the 4850: 
+    Device: AMD RV770 (DRM 2.50.0 / 4.15.0-45-generic, LLVM 7.0.0) (0x9442)
+    Version: 18.2.2
Comment 13 veli 2019-02-09 17:37:15 UTC
Now I have Padoka PPA installed in both systems. Problem still occurs. I tried again "R600_DEBUG=nosb blender" and "R600_DUMP_SHADERS=1 blender" but nothing's changed.
Comment 14 Gert Wollny 2019-02-10 12:10:25 UTC
I've seen a few differences in the shaders created on HD2600 vs. HD4850 (one has a R6xx class chip, the other a R7xx chip), i.e. at some points in the shader creatied for HD2600  contain workarounds for hardware bugs in R6xx. It might be that some of those also would apply to R7xx chips, but I can't test this, because I don't have the hardware. As cards using the r600 drivers go I now only have a HD 5450 which uses the "Evergreen" code path, and there everything looks okay (with R600_DEBUG=nosb).

FWIW; I see the same GLX errors on this card that don't show up when I run the radeonsi card (Since both cards are in the same system there is no difference in the software).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.