Bug 109575 - Mesa-19.0.0-rc1 : Computer Crashes trying to run anything Vulkan
Summary: Mesa-19.0.0-rc1 : Computer Crashes trying to run anything Vulkan
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-06 21:45 UTC by LunarG
Modified: 2019-02-12 16:39 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description LunarG 2019-02-06 21:45:03 UTC
[Hardware Info]
--Graphics Card--
[AMD/ATI] Ellesmere [Radeon RX 470/480] (rev c7)

--CPU Info--
Intel(R) Core(TM) i7-6700K CPU @ 4.00GH

[Sofware Info]
--Mesa Version tag--
mesa-19.0.0-rc1 and mesa-19.0.0-rc2

--llvm version--
7.0.1

--Kernel Version--
4.10.0-38-generic

[Problem Description]
Trying to run any of the Sascha Willems samples (https://github.com/SaschaWillems/Vulkan) or LunarG's Cube examples from the SDK (vulkan.lunarg.com) will freeze the system.

I've tried both building with both Meson and Autotools, with the same result. Am I missing a requirement or could something be out of date?
Comment 1 LunarG 2019-02-06 21:52:26 UTC
Possibly related to bug https://bugs.freedesktop.org/show_bug.cgi?id=109543
Comment 2 Bas Nieuwenhuizen 2019-02-06 22:57:32 UTC
Say I have a computer with similar GPU sitting around just for testing.

What would be the way to get to a similar software setup? What distro do you use, what is your compiler, where did your kernel come from and how did you compile mesa?
Comment 3 LunarG 2019-02-06 23:03:53 UTC
--Distro--
Ubuntu 16.04

--Kernel from Ubuntu's PPA--
https://kernel.ubuntu.com/~kernel-ppa/mainline/v4.10/

--GCC version--
gcc (Ubuntu 5.4.0-6ubuntu1~16.04.4) 5.4.0 20160609

Compiled Mesa using autotools with the following command:
./autogen.sh PKG_CONFIG_PATH=/opt/Mesa/lib/pkgconfig:/opt/Mesa/share/pkgconfig --prefix=/opt/Mesa --with-dri-drivers="radeon" --with-gallium-drivers="radeonsi" --with-platforms="x11,drm" --with-vulkan-drivers=radeon --enable-autotools --enable-dri3
Comment 4 LunarG 2019-02-07 17:10:15 UTC
I'm also seeing this same system crash on Ubuntu 18.04.1 using Radeon R9 380 card.

Happens when trying to run Sascha Willems Bloom sample.
Comment 5 Samuel Pitoiset 2019-02-11 08:28:47 UTC
What kernel version do you have on 18.04.1 btw?
Comment 6 Samuel Pitoiset 2019-02-11 15:05:21 UTC
Does it work with mesa 18.3.3?
Comment 7 LunarG 2019-02-11 16:56:29 UTC
> What kernel version do you have on 18.04.1 btw?
It's 4.15.0-45 generic

> Does it work with mesa 18.3.3?
Yes, I'm not seeing any problems running any Vulkan apps
Comment 8 Samuel Pitoiset 2019-02-11 17:18:36 UTC
Can you bisect?
Comment 9 LunarG 2019-02-12 00:17:05 UTC
After bisecting, it looks like commit f425d9ee74 is the first bad one.

I only used llvm-7 when trying to bisect.
Comment 10 Samuel Pitoiset 2019-02-12 07:30:23 UTC
Interesting, thanks for bisecting. I will investigate.
Comment 11 Samuel Pitoiset 2019-02-12 07:53:21 UTC
Can you try this patch https://patchwork.freedesktop.org/series/56522/ ?
Comment 12 Samuel Pitoiset 2019-02-12 07:59:35 UTC
Please, try v2.
Comment 13 LunarG 2019-02-12 16:31:35 UTC
Yes! this patch worked for me on my Ubuntu 18.04 - AMD R9 380 system! I will check with my other AMD systems today.
Comment 14 Samuel Pitoiset 2019-02-12 16:39:36 UTC
Fixed.

https://cgit.freedesktop.org/mesa/mesa/commit/?id=1b8983c25be19073c02fe9630e949be55f8280fa

Thanks for confirming. I guess it should also work on Ubuntu 16.04.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.