Bug 109581 - [BISECTED] Nothing is Rendered on Sascha Willem's "subpasses" demo
Summary: [BISECTED] Nothing is Rendered on Sascha Willem's "subpasses" demo
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/intel (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Matt Turner
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mesa-19.0
  Show dependency treegraph
 
Reported: 2019-02-07 20:40 UTC by LunarG
Modified: 2019-02-17 07:39 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description LunarG 2019-02-07 20:40:26 UTC
--Mesa Version--
mesa-19.0.0-rc1 or mesa-19.0.0rc2

--Hardware--
Intel Skylake Processor

--Description--
Nothing gets rendered to the window when the "subpasses" demo is run. Window is black.

Steps to reproduce:
-Build Mesa 19.0.0-rc1
-Clone and Sascha Willem's demos (https://github.com/SaschaWillems/Vulkan)
-Try to run "subpasses" demo
Comment 1 Jason Ekstrand 2019-02-07 21:04:58 UTC
I've bisected this bug to the following commit:

commit 613ac3aaa295ad2a6271ee8315e16ee31456fa9d (HEAD, refs/bisect/bad)
Author: Matt Turner <mattst88@gmail.com>
Date:   Mon Dec 10 11:06:16 2018 -0800

    i965: Compile fp64 software routines and lower double-ops
    
    Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>
Comment 2 Jason Ekstrand 2019-02-07 21:05:45 UTC
Looks like the "Window is black" is because it's compiling shaders forever.  Haven't dug into why yet.
Comment 3 Matt Turner 2019-02-07 22:20:35 UTC
So, there was a follow-on fix to this:

commit 32e266a9a5897bb2bb1560f142ac820e69fdae35
Author: Matt Turner <mattst88@gmail.com>
Date:   Thu Jan 10 15:14:35 2019 -0800

    i965: Compile fp64 funcs only if we do not have 64-bit hardware support
    
    Brown bag fix...

but we only call compile_fp64_funcs() in src/mesa/drivers/dri/i965/brw_program.c, so I don't think this can affect Vulkan.
Comment 4 Jason Ekstrand 2019-02-07 22:25:39 UTC
It's definitely infinite-looping in the 64-bit lowering loop even on master.
Comment 5 Kenneth Graunke 2019-02-07 23:20:52 UTC
Bisection is correct, I figured out what's going on here.  We should have patches shortly.
Comment 6 Kenneth Graunke 2019-02-17 07:39:12 UTC
Fixed:

commit 535251487ba56c4fd98465c4682881c2b9734242
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Fri Feb 15 14:52:20 2019 -0800

    nir: Don't reassociate add/mul chains containing only constants


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.