Bug 109638 - [CI][DRMTIP] igt@gem_exec_suspend@basic-s4-devices - dmesg-warn - irq \d+: nobody cared (try booting with the "irqpoll" option)
Summary: [CI][DRMTIP] igt@gem_exec_suspend@basic-s4-devices - dmesg-warn - irq \d+: no...
Status: RESOLVED NOTOURBUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Tomi Sarvela
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 109965 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-02-15 09:28 UTC by Lakshmi
Modified: 2019-07-27 16:18 UTC (History)
3 users (show)

See Also:
i915 platform: ICL
i915 features: CI Infra


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-02-15 09:28:10 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_218/fi-icl-u2/igt@gem_exec_suspend@basic-s4-devices.html

<3> [291.460222] irq 32: nobody cared (try booting with the "irqpoll" option)
<4> [291.460225] CPU: 4 PID: 0 Comm: swapper/4 Tainted: G     U            5.0.0-rc6-gc853cc6da521-drmtip_218+ #1
<4> [291.460226] Hardware name: Intel Corporation Ice Lake Client Platform/IceLake U DDR4 SODIMM PD RVP TLC, BIOS ICLSFWR1.R00.3071.A00.1902120336 02/12/2019
<4> [291.460227] Call Trace:
<4> [291.460229]  <IRQ>
<4> [291.460232]  dump_stack+0x67/0x9b
<4> [291.460236]  __report_bad_irq+0x2b/0xb0
<4> [291.460238]  note_interrupt+0x22e/0x280
<4> [291.460241]  handle_irq_event_percpu+0x4c/0x70
<4> [291.460243]  handle_irq_event+0x2f/0x50
<4> [291.460245]  handle_fasteoi_irq+0x87/0x140
<4> [291.460248]  handle_irq+0x67/0x160
<4> [291.460250]  do_IRQ+0x5e/0x130
<4> [291.460254]  common_interrupt+0xf/0xf
<4> [291.460255]  </IRQ>
<4> [291.460258] RIP: 0010:cpuidle_enter_state+0xae/0x450
<4> [291.460259] Code: 44 00 00 31 ff e8 42 d6 92 ff 45 84 f6 74 12 9c 58 f6 c4 02 0f 85 78 03 00 00 31 ff e8 2b 80 99 ff e8 06 61 9d ff fb 45 85 ed <0f> 88 c9 02 00 00 4c 2b 24 24 48 ba cf f7 53 e3 a5 9b c4 20 49 63
<4> [291.460260] RSP: 0018:ffff9c344012bea0 EFLAGS: 00000202 ORIG_RAX: ffffffffffffffdd
<4> [291.460262] RAX: ffff987ddd244040 RBX: ffffffff9f2a07c0 RCX: 0000000000000000
<4> [291.460263] RDX: 0000000000000046 RSI: ffffffff9f0ffb7a RDI: ffffffff9f0aad8f
<4> [291.460264] RBP: ffff987dd9ce9fe8 R08: 0000000000000000 R09: 0000000000000000
<4> [291.460265] R10: 0000000000000000 R11: 0000000000000000 R12: 00000043dc61f932
<4> [291.460266] R13: 0000000000000001 R14: 0000000000000000 R15: 0000000000000001
<4> [291.460272]  ? rcu_preempt_deferred_qs+0x19/0x80
<4> [291.460275]  do_idle+0x1f3/0x260
<4> [291.460278]  cpu_startup_entry+0x14/0x20
<4> [291.460281]  start_secondary+0x19d/0x1f0
<4> [291.460284]  secondary_startup_64+0xa4/0xb0
<3> [291.460288] handlers:
<3> [291.460305] [<00000000456b355a>] i2c_dw_isr
<0> [291.460317] Disabling IRQ #32
<7> [291.507604] [drm:edp_panel_vdd_off_sync [i915]] Turning eDP port A VDD off
<7> [291.507742] [drm:edp_panel_vdd_off_sync [i915]] PP_STATUS: 0x80000008 PP_CONTROL: 0x00000067
<6> [291.622708] sdhci-pci 0000:00:14.5: SDHCI controller found [8086:34f8] (rev 30)
<6> [291.626479] acpi LNXPOWER:0a: Turning OFF
<6> [291.633063] acpi LNXPOWER:09: Turning OFF
<6> [291.642179] sdhci-pci 0000:00:14.5: SDHCI controller found [8086:34f8] (rev 30)
<6> [291.643540] Bluetooth: hci0: Bootloader revision 0.4 build 0 week 11 2017
<6> [291.644605] Bluetooth: hci0: Device revision is 2
<6> [291.644607] Bluetooth: hci0: Secure boot is enabled
<6> [291.644608] Bluetooth: hci0: OTP lock is disabled
<6> [291.644609] Bluetooth: hci0: API lock is enabled
<6> [291.644610] Bluetooth: hci0: Debug lock is disabled
<6> [291.644612] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
<4> [291.646581] bluetooth hci0: Direct firmware load for intel/ibt-19-32-4.sfi failed with error -2
<3> [291.646590] Bluetooth: hci0: Failed to load Intel firmware file (-2)
<6> [291.657719] acpi LNXPOWER:08: Turning OFF
<7> [291.675237] PM: Basic memory bitmaps freed
<6> [291.675240] OOM killer enabled.
<6> [291.675242] Restarting tasks ... done.
<6> [291.769705] PM: hibernation exit
<3> [291.801786] irq 33: nobody cared (try booting with the "irqpoll" option)
<4> [291.801804] CPU: 5 PID: 1194 Comm: kworker/u16:77 Tainted: G     U            5.0.0-rc6-gc853cc6da521-drmtip_218+ #1
<4> [291.801806] Hardware name: Intel Corporation Ice Lake Client Platform/IceLake U DDR4 SODIMM PD RVP TLC, BIOS ICLSFWR1.R00.3071.A00.1902120336 02/12/2019
<4> [291.801854] Workqueue: i915 __i915_gem_free_work [i915]
<4> [291.801856] Call Trace:
<4> [291.801858]  <IRQ>
<4> [291.801862]  dump_stack+0x67/0x9b
<4> [291.801866]  __report_bad_irq+0x2b/0xb0
<4> [291.801869]  note_interrupt+0x22e/0x280
<4> [291.801872]  handle_irq_event_percpu+0x4c/0x70
<4> [291.801875]  handle_irq_event+0x2f/0x50
<4> [291.801878]  handle_fasteoi_irq+0x87/0x140
<4> [291.801881]  handle_irq+0x67/0x160
<4> [291.801884]  do_IRQ+0x5e/0x130
<4> [291.801887]  common_interrupt+0xf/0xf
<4> [291.801889]  </IRQ>
<4> [291.801891] RIP: 0010:_raw_spin_unlock_irqrestore+0x4e/0x60
<4> [291.801893] Code: c7 02 75 1f 53 9d e8 a1 11 7f ff bf 01 00 00 00 e8 57 ea 73 ff 65 8b 05 50 30 67 61 85 c0 74 0c 5b 5d c3 e8 94 0f 7f ff 53 9d <eb> df e8 b5 fb 65 ff 5b 5d c3 0f 1f 84 00 00 00 00 00 53 48 8b 54
<4> [291.801894] RSP: 0018:ffff9c3440babca0 EFLAGS: 00000286 ORIG_RAX: ffffffffffffffdd
<4> [291.801896] RAX: ffff987dd2d18040 RBX: 0000000000000286 RCX: 0000000000000006
<4> [291.801898] RDX: 0000000000000006 RSI: ffffffff9f0ffb7a RDI: ffffffff9f0aad8f
<4> [291.801899] RBP: ffff987dde000640 R08: 00000000276d7f38 R09: 0000000000000000
<4> [291.801900] R10: 0000000000000000 R11: 0000000000000000 R12: ffffe48d522b7680
<4> [291.801901] R13: 0000000000000001 R14: 0000000000000001 R15: ffff987dcadda328
<4> [291.801910]  free_debug_processing+0x270/0x370
<4> [291.801938]  ? __i915_gem_free_objects+0x38a/0x730 [i915]
<4> [291.801942]  __slab_free+0x337/0x4f0
<4> [291.801944]  ? _raw_spin_unlock_irqrestore+0x39/0x60
<4> [291.801948]  ? debug_check_no_obj_freed+0x132/0x210
<4> [291.801976]  ? __i915_gem_free_objects+0x38a/0x730 [i915]
<4> [291.802000]  __i915_gem_free_objects+0x38a/0x730 [i915]
<4> [291.802025]  __i915_gem_free_work+0x5a/0x90 [i915]
<4> [291.802029]  process_one_work+0x245/0x610
<4> [291.802034]  worker_thread+0x37/0x380
<4> [291.802037]  ? process_one_work+0x610/0x610
<4> [291.802039]  kthread+0x119/0x130
<4> [291.802042]  ? kthread_park+0x80/0x80
<4> [291.802045]  ret_from_fork+0x24/0x50
<3> [291.802051] handlers:
<3> [291.802060] [<00000000456b355a>] i2c_dw_isr
<0> [291.802146] Disabling IRQ #33
<5> [292.248613] Setting dangerous option reset - tainting kernel
<6> [292.248855] [IGT] gem_exec_suspend: exiting, ret=0
<6> [292.305356] Console: switching to colour frame buffer device 240x67
Comment 1 CI Bug Log 2019-02-15 09:30:19 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* ICL: igt@gem_exec_suspend@basic-* - dmesg-warn - irq \d+: nobody cared \(try booting with the &quot;irqpoll&quot; option\)
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_218/fi-icl-u2/igt@gem_exec_suspend@basic-s4-devices.html
Comment 2 Don Hiatt 2019-03-05 21:34:12 UTC
This message was repeated for both IRQ#32 and IRQ#33, I'm not sure what those IRQs are tied to so it would be helpful to see /proc/interrupts. That said, the handler is 'i2c_dw_isr' so unless the i915 is using i2c -- is it? -- this may be unrelated.

<3>[  291.460222] irq 32: nobody cared (try booting with the "irqpoll" option)
...
<3>[  291.460288] handlers:
<3>[  291.460305] [<00000000456b355a>] i2c_dw_isr
<0>[  291.460317] Disabling IRQ #32

...
<3>[  291.801786] irq 33: nobody cared (try booting with the "irqpoll" option)
..
<3>[  291.802051] handlers:
<3>[  291.802060] [<00000000456b355a>] i2c_dw_isr
<0>[  291.802146] Disabling IRQ #33
Comment 3 Don Hiatt 2019-03-05 21:38:47 UTC
(In reply to Don Hiatt from comment #2)
> This message was repeated for both IRQ#32 and IRQ#33, I'm not sure what
> those IRQs are tied to so it would be helpful to see /proc/interrupts. That
> said, the handler is 'i2c_dw_isr' so unless the i915 is using i2c -- is it?
> -- this may be unrelated.
Well, there is an 'intel_i2c.c' driver so that answers that. :)
Comment 4 Chris Wilson 2019-03-05 21:43:13 UTC
Not our interrupt; this is designware-i2c.
Comment 5 linawutida@web-experts.net (Spammer; Account disabled) 2019-03-06 07:55:45 UTC
BHai awaz aa rahi hay meri?
Comment 6 linawutida@web-experts.net (Spammer; Account disabled) 2019-03-06 08:00:23 UTC
Jai Hind
Comment 7 Chris Wilson 2019-03-11 17:28:32 UTC
*** Bug 109965 has been marked as a duplicate of this bug. ***
Comment 8 CI Bug Log 2019-03-12 14:38:12 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@gem_exec_suspend@basic-* - dmesg-warn - irq \d+: nobody cared \(try booting with the &quot;irqpoll&quot; option\) -}
{+ ICL: all tests - dmesg-warn - irq \d+: nobody cared \(try booting with the &quot;irqpoll&quot; option\) +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_237/fi-icl-y/igt@gem_create@create-clear.html
Comment 9 Martin Peres 2019-03-12 14:38:48 UTC
(In reply to CI Bug Log from comment #8)
> A CI Bug Log filter associated to this bug has been updated:
> 
> {- ICL: igt@gem_exec_suspend@basic-* - dmesg-warn - irq \d+: nobody cared
> \(try booting with the &quot;irqpoll&quot; option\) -}
> {+ ICL: all tests - dmesg-warn - irq \d+: nobody cared \(try booting with
> the &quot;irqpoll&quot; option\) +}
> 
> New failures caught by the filter:
> 
> *
> https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_237/fi-icl-y/
> igt@gem_create@create-clear.html

+ issues from https://bugs.freedesktop.org/show_bug.cgi?id=109965:
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2534/fi-icl-y/igt@gem_mmap_gtt@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12358/fi-icl-y/igt@gem_mmap_gtt@basic-copy.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5708/fi-icl-y/igt@gem_mmap@basic-small-bo.html
Comment 10 CI Bug Log 2019-03-12 16:04:21 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: all tests - dmesg-warn - irq \d+: nobody cared \(try booting with the &quot;irqpoll&quot; option\) -}
{+ ICL: all tests - dmesg-warn - irq \d+: nobody cared \(try booting with the &quot;irqpoll&quot; option\) +}

 No new failures caught with the new filter
Comment 11 Don Hiatt 2019-03-12 22:09:03 UTC
Hi Lakshmi, according to Chris (Comment #4) this interrupt belongs to designware-i2c so is not related to our driver. Can you please close or advise on how you'd like to handle this?
Comment 12 Martin Peres 2019-04-23 13:15:27 UTC
(In reply to Don Hiatt from comment #11)
> Hi Lakshmi, according to Chris (Comment #4) this interrupt belongs to
> designware-i2c so is not related to our driver. Can you please close or
> advise on how you'd like to handle this?

Assigning Tomi, and moving to CI infra to blacklist the module!
Comment 13 Lakshmi 2019-05-09 10:11:34 UTC
@Tomi, any update here?
Comment 14 Tomi Sarvela 2019-05-13 07:24:13 UTC
If the Intel RVP hardware has anything that can use this particular driver (designware-i2c), I'd rather not blacklist it. Would it be better to make it NOTOURBUG and plunk the bugreports to the maintainer of the driver?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.