Bug 109647 - /usr/include/xf86drm.h:40:10: fatal error: drm.h: No such file or directory
Summary: /usr/include/xf86drm.h:40:10: fatal error: drm.h: No such file or directory
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2019-02-15 21:35 UTC by Vinson Lee
Modified: 2019-02-19 13:42 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2019-02-15 21:35:28 UTC
autotools build error

  CC       tegra_screen.lo
In file included from tegra_screen.c:33:
/usr/include/xf86drm.h:40:10: fatal error: drm.h: No such file or directory
 #include <drm.h>
          ^~~~~~~


commit f1374805a86d0d506557e61efbc09e23caa7a038
Author: Eric Engestrom <eric.engestrom@intel.com>
Date:   Tue Feb 12 18:18:03 2019 +0000

    drm-uapi: use local files, not system libdrm
    
    There was an issue recently caused by the system header being included
    by mistake, so let's just get rid of this include path and always
    explicitly #include "drm-uapi/FOO.h"
    
    Signed-off-by: Eric Engestrom <eric.engestrom@intel.com>
    Reviewed-by: Kristian H. Kristensen <hoegsberg@chromium.org>
Comment 1 Michel Dänzer 2019-02-18 10:48:45 UTC

*** This bug has been marked as a duplicate of bug 109645 ***
Comment 2 Eric Engestrom 2019-02-19 11:24:47 UTC
Actually not really a duplicate; although the issue was shown by the same commit (f1374805a86d0), this bug report is for the bug that was there in the autotools config and the other is for the bug that was in the meson config.

Both should be fixed by this MR:
https://gitlab.freedesktop.org/mesa/mesa/merge_requests/270
Comment 3 Eric Engestrom 2019-02-19 13:42:28 UTC
Fixed by:

commit f84f833981286b2955f40f98e4beeecbcc67a69b
Author: Eric Engestrom <eric.engestrom@intel.com>
Date:   Tue Feb 19 11:18:07 2019 +0000

    tegra/autotools: add missing libdrm cflags
    
    Fixes: f1374805a86d0d506557 "drm-uapi: use local files, not system libdrm"
    Bug: https://bugs.freedesktop.org/show_bug.cgi?id=109647
    Signed-off-by: Eric Engestrom <eric.engestrom@intel.com>
    Reviewed-by: Emil Velikov <emil.velikov@collabora.com>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.