Bug 109711 - [DXVK] Skyrim Special edition hangs
Summary: [DXVK] Skyrim Special edition hangs
Status: RESOLVED DUPLICATE of bug 106713
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-21 08:42 UTC by root
Modified: 2019-02-22 09:51 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description root 2019-02-21 08:42:59 UTC
Skyrim special edition hangs for me on the main menu with a Radeon R9 Fury using RADV. The corresponding DXVK issue can be found here https://github.com/doitsujin/dxvk/issues/927 The issue occurs using Mesa 18.3.3(LLVM 7.0.1), Mesa 19.0.0~rc4(LLVM 8), and Mesa 19.0.0~rc4(LLVM 9-svn). The build of 18.3.3(LLVM 7.0.1) came from the debian sid repositories, the 19.0.0~rc4(LLVM 8) was built by me linking against debian sid's libllvm8 and then 19.0.0~rc4(LLVM 9-svn) was built entirely from scratch.
Comment 1 Bas Nieuwenhuizen 2019-02-21 09:36:26 UTC
So is this an actual hang of the GPU or just a freeze for the game? (i.e. does it need a reboot to do anything again or can you just close the game?) Reading the DXVK bug I'm wondering which of the two it is.
Comment 2 root 2019-02-21 21:40:07 UTC
Yeah, apparently I didn't make that very clear. It is a GAME hang. As in I have to forcibly kill the game from htop but it is not a full system hang.
Comment 3 root 2019-02-22 06:23:27 UTC
It turns out this issue only occurs under XWayland and NOT under X.Org however I'm not sure if it's actually a mesa bug with XWayland or an XWayland bug directly.
Comment 4 Michel Dänzer 2019-02-22 09:51:39 UTC

*** This bug has been marked as a duplicate of bug 106713 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.