Bug 109724 - [CI][BAT gdg] igt@prime_self_import@basic-with_one_bo - fail - Failed assertion: ptr1[i] == counter
Summary: [CI][BAT gdg] igt@prime_self_import@basic-with_one_bo - fail - Failed asserti...
Status: CLOSED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-21 15:37 UTC by Lakshmi
Modified: 2019-05-31 10:43 UTC (History)
1 user (show)

See Also:
i915 platform: I915G
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-02-21 15:37:47 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5648/fi-gdg-551/igt@prime_self_import@basic-with_one_bo.html

Starting subtest: basic-with_one_bo
(prime_self_import:1336) CRITICAL: Test assertion failure function check_bo, file ../tests/prime_self_import.c:67:
(prime_self_import:1336) CRITICAL: Failed assertion: ptr1[i] == counter
Subtest basic-with_one_bo failed.
**** DEBUG ****
(prime_self_import:1336) drmtest-DEBUG: Test requirement passed: !(fd<0)
(prime_self_import:1336) igt_debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(prime_self_import:1336) drmtest-DEBUG: Test requirement passed: !(fd<0)
(prime_self_import:1336) CRITICAL: Test assertion failure function check_bo, file ../tests/prime_self_import.c:67:
(prime_self_import:1336) CRITICAL: Failed assertion: ptr1[i] == counter
(prime_self_import:1336) igt_core-INFO: Stack trace:
(prime_self_import:1336) igt_core-INFO:   #0 ../lib/igt_core.c:1474 __igt_fail_assert()
(prime_self_import:1336) igt_core-INFO:   #1 ../tests/prime_self_import.c:68 check_bo()
(prime_self_import:1336) igt_core-INFO:   #2 ../tests/prime_self_import.c:186 test_with_one_bo()
(prime_self_import:1336) igt_core-INFO:   #3 ../tests/prime_self_import.c:440 __real_main422()
(prime_self_import:1336) igt_core-INFO:   #4 ../tests/prime_self_import.c:422 main()
(prime_self_import:1336) igt_core-INFO:   #5 ../csu/libc-start.c:344 __libc_start_main()
(prime_self_import:1336) igt_core-INFO:   #6 [_start+0x2a]
****  END  ****
Subtest basic-with_one_bo: FAIL (0.147s)
Comment 1 Lakshmi 2019-02-21 15:38:36 UTC
Is this issue due to regression?
Comment 2 CI Bug Log 2019-02-21 15:40:15 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* GDG: igt@prime_self_import@basic-with_one_bo - fail - Failed assertion: ptr1[i] == counter
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5648/fi-gdg-551/igt@prime_self_import@basic-with_one_bo.html
Comment 3 Chris Wilson 2019-02-21 15:42:30 UTC
It's gdg (technically pentium 4), we know there are coherency problems. What is not known is how to stop it misbehaving.
Comment 4 Lakshmi 2019-02-27 08:35:30 UTC
Considering the platform, not as regression, last seen 50 runs and occurred only once. Dropping the priority to high.
Comment 5 Lakshmi 2019-05-31 10:43:07 UTC
This issue occured only once CI_DRM_5648 (3 months, 1 week old).
Closing this bug as WORKSFORME.
Comment 6 CI Bug Log 2019-05-31 10:43:23 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.