Bug 109792 - [hsw] GPU HANG: ecode 7:0:0x85dffffc, in kwin_x11
Summary: [hsw] GPU HANG: ecode 7:0:0x85dffffc, in kwin_x11
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-27 19:03 UTC by amrathil
Modified: 2019-09-25 20:32 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
The gpu crash dump (34.55 KB, text/x-log)
2019-02-27 19:03 UTC, amrathil
Details
glxinfo output (32.17 KB, text/plain)
2019-02-28 17:18 UTC, amrathil
Details
Xorg.o.log (28.64 KB, text/x-log)
2019-02-28 17:41 UTC, amrathil
Details
Latest Xorg.0.log (25.94 KB, text/x-log)
2019-03-07 22:29 UTC, amrathil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description amrathil 2019-02-27 19:03:42 UTC
Created attachment 143492 [details]
The gpu crash dump

From time to time, (once every couple hours approximately), the graphics system hangs for a few seconds, then returns to normal.

The output from dmesg at the time is:
[feb27 19:52] [drm] GPU HANG: ecode 7:0:0x85dffffc, in kwin_x11 [3775], reason: hang on rcs0, action: reset
[  +0,000002] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[  +0,000000] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[  +0,000000] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[  +0,000001] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[  +0,000001] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[  +0,000043] i915 0000:00:02.0: Resetting chip for hang on rcs0




Thanks a lot.
Comment 1 Tapani Pälli 2019-02-28 06:49:52 UTC
Please attach glxinfo output. Also, which version of Xorg and if you are using modesetting or intel driver.
Comment 2 Tapani Pälli 2019-02-28 06:51:11 UTC
And forgot, kernel version as well. In general all details of the system and component versions will greatly help in debugging and getting it fixed.
Comment 3 amrathil 2019-02-28 17:18:55 UTC
Created attachment 143501 [details]
glxinfo output
Comment 4 amrathil 2019-02-28 17:21:30 UTC
Hi, 

kernel version is 4.20.11-200.fc29.x86_64

Xorg version is 1.20.3

The system is a Lenovo W541 laptop, with the intel graphics cards plus an Nvidia Quadro card. 

The distro is a Fedora 29 KDE.

The error seems to be more frequent if I'm watching a video, whether in VLC or in Youtube.

Thanks a lot.
Comment 5 amrathil 2019-02-28 17:41:58 UTC
Created attachment 143502 [details]
Xorg.o.log
Comment 6 Paul 2019-03-05 15:59:25 UTC
Hi guys
I've tried to reproduce the issue from my side on Haswell (with Intel® HD Graphics 4600 ) with Fedora 29 KDE and 4.20.13 Kernel and 1.20.4-1 version of Xorg server but with no luck.
Could you please provide:
1. Link to the video, which hangs GPU.
2. Provide apitrace with the hang if it is possible
https://github.com/apitrace/apitrace
3. Also, try to update your xorg and kernel - that can help you.
Thanks
Comment 7 Sergii Romantsov 2019-03-06 10:17:41 UTC
Hello, amrathil
Could you, please, upgrade f29 up to date. Now it doesn't contain 4.20.11-200.fc29.x86_64 and Xorg 1.20.3 anymore.
Than we can try to investigate further
Comment 8 amrathil 2019-03-07 22:29:11 UTC
Created attachment 143577 [details]
Latest Xorg.0.log
Comment 9 amrathil 2019-03-07 22:32:06 UTC
Hi everyone, 

I've updated F29, now my kernel version is 4.20.13-200.fc29.x86_64, and Xorg version is 1.20.4 (I've attached the Xorg.0.log again), but the problem persist, a couple minutes into a Youtube video causes the crash again. The dmesg output is:
[mar 7 23:25] [drm] GPU HANG: ecode 7:0:0x85dffffd, in Xorg [1144], reason: hang on rcs0, action: reset
[  +0,000001] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[  +0,000001] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[  +0,000000] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[  +0,000000] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[  +0,000001] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[  +0,000053] i915 0000:00:02.0: Resetting chip for hang on rcs0



I'll try to attach that apitrace...
Comment 10 Mark Janes 2019-03-08 00:37:17 UTC
Two things stand out to me in this bug:

  - Prime / nvidia
  - media

Please disable the nvidia graphics in your bios and report if you can reproduce.
Comment 11 amrathil 2019-03-10 10:40:01 UTC
Hi, I'm afraid there's no option to completely disable the discrete graphics card in the BIOS. There's an option to choose the video mode when on a docking station, but that's already set to the integrated graphics.

In any case, I reduced the amount of ram in the "Total graphics memory" BIOS option from 512 to 256MB, to test it that would make a difference. The problem is still there, but I only got one crash in the first hour of usage with a youtube video in the background.

Thanks a lot!
Comment 12 Paul 2019-06-10 09:59:20 UTC
Hello, Amrathil!
I saw a similar issue from another user and he resolved it by disabling of 'turbo performance' setting in BIOS.
If you still have this issue - could you please check this option on your machine?
Thanks.
Comment 13 GitLab Migration User 2019-09-25 20:32:13 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1793.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.