Bug 109809 - [drm] GPU HANG: ecode 9:0:0x84df1ec4, in metro.exe [22296], reason: hang on rcs0, action: reset
Summary: [drm] GPU HANG: ecode 9:0:0x84df1ec4, in metro.exe [22296], reason: hang on r...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-01 23:27 UTC by blaise_g07
Modified: 2019-09-18 19:49 UTC (History)
2 users (show)

See Also:
i915 platform: I965G
i915 features:


Attachments
error log from /sys/class/drm/card0/error (1.00 MB, text/plain)
2019-03-01 23:27 UTC, blaise_g07
Details
dxvk d3d11 (1.91 KB, text/x-log)
2019-03-04 13:11 UTC, blaise_g07
Details
dxvk dxgi (900 bytes, text/x-log)
2019-03-04 13:11 UTC, blaise_g07
Details
dxvk log (2.64 KB, text/plain)
2019-03-05 16:30 UTC, blaise_g07
Details
log from /sys/class/drm/card0/error (1.33 MB, text/plain)
2019-03-05 16:33 UTC, blaise_g07
Details

Note You need to log in before you can comment on or make changes to this bug.
Description blaise_g07 2019-03-01 23:27:58 UTC
Created attachment 143511 [details]
error log from /sys/class/drm/card0/error

Vendor: Intel Open Source Technology Center (0x8086)
Device: Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2)  (0x1916)
Version: 19.1.0 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 19.1.0-devel (git-2793417ec6)
kernel 4.20.13
DXVK version 1.00
Wine 4.2-staging
i3-6100U cpu
Comment 1 Denis 2019-03-04 09:35:33 UTC
Hi, thanks for the report. What metro version did you mean? New one, or old? Link would be helpful.
Also, could you please add more details about hang? It appears after game start, or in some specific moment? Or random/one time?

If somewhere in the game, your game settings (graphic) also would be helpful.
Comment 2 blaise_g07 2019-03-04 13:10:14 UTC
The hang is random and not in any specific area of the game or scene. It happens in Metro 2033 Redux and Metro Last Light Redux. I haven't seen anything on the dxvk github or on steam with a similar issue getting a VK_DEVICE_LOST with the game. The DXVK 1.0 version is built against vulkan 1.1.96 so that may cause an issue maybe.

Currently upgraded to wine-4.3 staging and linux 5.0 kernel. Game version is up to date.

The in-game settings are pretty basic.
1366x768
msaa .5
tessellation on

Vulkan version:1.1.97 Win DLL's and native linux libs installed.

Mesa version: 19.1.0-devel (git-cb4e3e3ef6)

My mesa config:
./autogen.sh --prefix=/usr --libdir=/usr/lib/x86_64-linux-gnu --enable-autotools --with-vulkan-drivers="intel" --with-dri-drivers="i915,i965" --enable-nine --enable-glx="dri" --enable-dri3

It's similar to https://bugs.freedesktop.org/show_bug.cgi?id=107229
but my CONFIG_TRANSPARENT_HUGEPAGE=y.

Thanks.
Comment 3 blaise_g07 2019-03-04 13:11:06 UTC
Created attachment 143519 [details]
dxvk d3d11
Comment 4 blaise_g07 2019-03-04 13:11:42 UTC
Created attachment 143520 [details]
dxvk dxgi
Comment 5 blaise_g07 2019-03-05 16:30:19 UTC
Applicable part of xsession-errors/wine-debug when it hangs ...

0035:err:ntdll:RtlpWaitForCriticalSection section 0x140cfc340 "?" wait timed out in thread 0035, blocked by 0050, retrying (60 sec)
INTEL-MESA: error: vulkan/anv_device.c:2269: GPU hung on one of our command buffers (VK_ERROR_DEVICE_LOST)
0035:err:ntdll:RtlpWaitForCriticalSection section 0x140cfc340 "?" wait timed out in thread 0035, blocked by 0050, retrying (60 sec)
Comment 6 blaise_g07 2019-03-05 16:30:50 UTC
Created attachment 143536 [details]
dxvk log
Comment 7 blaise_g07 2019-03-05 16:33:35 UTC
Created attachment 143537 [details]
log from /sys/class/drm/card0/error
Comment 8 Paul 2019-05-03 09:36:56 UTC
Hello guys
I've tried to reproduce the issue on my Skylake (Intel® HD Graphics 520) with Ubuntu 18.04 and 4.20.13, 5.0.0 and 5.0.10 versions of Kernel, 19.1.0-devel (git-cb4e3e3ef6) and the latest master version of Mesa, 1.1.97 and 1.1.102 versions of Vulkan - can't reproduce the hang on my side.
Blaise, could you please try to reproduce the issue with the latest version of the Vulkan and Kernel.
Thanks.
Comment 9 GitLab Migration User 2019-09-18 19:49:53 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/843.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.