Bug 109817 - GPU HANG: ecode 7:0:0x85dffffc, in Xorg [739], reason: Hang on render ring, action: reset; system freezes and new session is started automatically - GPU issue, i915
Summary: GPU HANG: ecode 7:0:0x85dffffc, in Xorg [739], reason: Hang on render ring, a...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-02 20:48 UTC by marco
Modified: 2019-09-25 20:32 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
gpu crash dump from /sys/class/drm/card0/error (1.09 MB, text/plain)
2019-03-02 20:48 UTC, marco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marco 2019-03-02 20:48:03 UTC
Created attachment 143514 [details]
gpu crash dump from /sys/class/drm/card0/error

System freezes and new session is started automatically. Journal entries point to GPU problem (see below). Crash dump in attachment. I´ m facing similar issues (system freezes) also with the RT kernel. Any help is highly appreciated. 

thanks & cheers, 
marco

Used Kernel: Linux fox 4.9.0-8-amd64 #1 SMP Debian 4.9.144-3.1 (2019-02-19) x86_64 GNU/Linux

Debian Stretch / XFCE

System:
CPU:       Quad core Intel Core i5-4460 (-MCP-) cache: 6144 KB 
           clock speeds: max: 3400 MHz 1: 3398 MHz 2: 3396 MHz 3: 3395 MHz 4: 3399 MHz
           CPU Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 bts clflush cmov
           constant_tsc cx16 cx8 de ds_cpl dtes64 dtherm dts ept erms est f16c flexpriority flush_l1d fma fpu
           fsgsbase fxsr ht ibpb ibrs ida invpcid invpcid_single kaiser lahf_lm lm mca mce mmx monitor movbe msr
           mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts
           rdrand rdtscp rep_good sdbg sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
           tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr

----------------------------
Mär 02 20:56:04 fox kernel: [drm] GPU HANG: ecode 7:0:0x85dffffc, in Xorg [739], reason: Hang on render ring, action: reset
Mär 02 20:56:04 fox kernel: [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Mär 02 20:56:04 fox kernel: [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Mär 02 20:56:04 fox kernel: [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Mär 02 20:56:04 fox kernel: [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Mär 02 20:56:04 fox kernel: [drm] GPU crash dump saved to /sys/class/drm/card0/error
Mär 02 20:56:04 fox kernel: drm/i915: Resetting chip after gpu hang
Mär 02 20:56:15 fox kernel: drm/i915: Resetting chip after gpu hang
Mär 02 20:56:15 fox org.a11y.atspi.Registry[3181]: XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
Mär 02 20:56:15 fox org.a11y.atspi.Registry[3181]:       after 82579 requests (82579 known processed) with 0 events remaining.
Mär 02 20:56:15 fox polkitd(authority=local)[529]: Unregistered Authentication Agent for unix-session:2 (system bus name :1.35, object path /org/gnome/PolicyKit1/AuthenticationAgent, locale de_DE.utf8) (disconne
Mär 02 20:56:15 fox lightdm[3048]: pam_unix(lightdm:session): session closed for user marco
Mär 02 20:56:16 fox lightdm[15916]: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .servic
Mär 02 20:56:16 fox lightdm[15916]: pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
Mär 02 20:56:16 fox systemd[1]: Created slice User Slice of lightdm.
Mär 02 20:56:16 fox systemd[1]: Starting User Manager for UID 112...
Mär 02 20:56:16 fox systemd-logind[456]: New session c2 of user lightdm.
Mär 02 20:56:16 fox systemd[15919]: pam_unix(systemd-user:session): session opened for user lightdm by (uid=0)
Mär 02 20:56:16 fox systemd[1]: Started Session c2 of user lightdm.
Comment 1 marco 2019-03-02 21:02:06 UTC
additional info:

uname -m
x86_64
-------------------
Monitor connector via HDMI
-------------------
Bug not reproducible
Comment 2 marco 2019-03-02 21:03:15 UTC
System:    Host: fox Kernel: 4.9.0-7-amd64 x86_64 (64 bit) Desktop: Xfce 4.12.3
           Distro: Debian GNU/Linux 9 (stretch)
Machine:   Device: desktop Mobo: MSI model: H81M-E34 (MS-7817) v: 3.0 BIOS: American Megatrends v: V17.5 date: 03/30/2015
CPU:       Quad core Intel Core i5-4460 (-MCP-) cache: 6144 KB 
           clock speeds: max: 3400 MHz 1: 3371 MHz 2: 3357 MHz 3: 3357 MHz 4: 3334 MHz
Graphics:  Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           Display Server: X.Org 1.19.2 drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel Haswell Desktop GLX Version: 3.0 Mesa 13.0.6
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller driver: snd_hda_intel
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller driver: snd_hda_intel
           Card-3 AKAI Professional M.I. LPK25 MIDI Keyboard driver: USB Audio
           Card-4 ZOOM driver: USB Audio
           Sound: Advanced Linux Sound Architecture v: k4.9.0-7-amd64
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: d8:cb:8a:e8:e9:99
Drives:    HDD Total Size: 500.1GB (15.9% used)
           ID-1: /dev/sdb model: Samsung_SSD_850 size: 250.1GB
           ID-2: USB /dev/sda model: Portable_SSD_T5 size: 250.1GB
Partition: ID-1: / size: 28G used: 15G (57%) fs: ext4 dev: /dev/sdb1
           ID-2: /home size: 194G used: 39G (21%) fs: ext4 dev: /dev/sdb6
           ID-3: swap-1 size: 7.99GB used: 0.00GB (0%) fs: swap dev: /dev/sdb5
Sensors:   System Temperatures: cpu: 38.0C mobo: 45.0C
           Fan Speeds (in rpm): cpu: 881 fan-1: 759 fan-3: 0 fan-4: 0 fan-5: 0
Info:      Processes: 185 Uptime: 8 min Memory: 1636.2/7424.6MB Client: Shell (bash) inxi: 2.3.5
Comment 3 Mark Janes 2019-03-04 02:33:53 UTC
Please see if you can reproduce on an up to date kernel and mesa.  Many bugs have been fixed since 4.9.
Comment 4 marco 2019-03-04 13:50:12 UTC
Thanks for the comment. I think the error is related to the activated XFCE -compositor. I try with compton instead at the moment.

Do you mean to use the newest kernel and MESA version from the backports? I can try this too, but I fear to run in even more problems.
Comment 5 Mark Janes 2019-03-04 16:37:09 UTC
Is this with a new install, or an update to a previously stable debian testing system?

If it's a new install, I would personally recommend debian's testing distribution for better graphics support.  

If it was previously working, or if you want to run stable and have graphics support, then I would start by updating the kernel to 4.19.  That can be done without pulling in any dependencies, and you can easily back out by selecting the old kernel in grub.  If that doesn't work, then you should try up to date mesa.  I think stable is running mesa 13.0, which is years old and will be missing *many* fixes.

What is your use case for the RT kernel?
Comment 6 marco 2019-03-04 17:19:14 UTC
Thanks for the reply! 

It's a one year old install and from beginning I got sporadic freezes (one every ~ 3 months or so). Since the latest kernel updates they happened more often, especially with the RT kernel, which I use for audio processing (i.e. making music). However, I also can use the standard kernel, it works even better. When freezes happened with the RT kernel I often see kernel logs like:

[drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=149361 end=149362) time 4939 us, min 1073, max 1079, scanline start 863, end 71

This is not the case with the standard kernel. Freeze from above seems to be due to activated compositing. 

If problems persist with standard kernel (Linux fox 4.9.0-8-amd64 #1 SMP Debian 4.9.144-3.1 (2019-02-19) x86_64 GNU/Linux
) + Compton, I try the backport kernel. If it still doesn't help backport kernel + backport mesa. Is it possible that it will work with compton?

Strange thing is that I read every that the i915 driver should work fine with stable. I really want to avoid a new installation at the moment. Next year I plan to upgrade to Buster. 

Thanks for your help and cheers!
Comment 7 marco 2019-03-04 17:26:38 UTC
It was a new Debian / Stable installation. Before that I used Ubuntu KDE 14.04 without any issues.
Comment 8 GitLab Migration User 2019-09-25 20:32:18 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1794.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.