Bug 109829 - No image via KVM switch. USB-C->dual DisplayPort->KVM
Summary: No image via KVM switch. USB-C->dual DisplayPort->KVM
Status: NEEDINFO
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged, ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-04 17:45 UTC by Stuart
Modified: 2019-08-27 10:56 UTC (History)
3 users (show)

See Also:
i915 platform: KBL
i915 features: display/Other


Attachments
dmesg (65.06 KB, text/plain)
2019-03-04 17:45 UTC, Stuart
no flags Details
updated_dmesg (58.08 KB, text/plain)
2019-03-16 18:18 UTC, Stuart
no flags Details
drm-tip install messages (2.15 KB, text/plain)
2019-03-16 18:19 UTC, Stuart
no flags Details
dmesg with boot parameters (871.63 KB, text/plain)
2019-03-19 01:20 UTC, Stuart
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stuart 2019-03-04 17:45:16 UTC
Created attachment 143523 [details]
dmesg

Hi all,

I have a NUC7i7BNH with the latest BIOS (0062) running Ubuntu 18.04 (uname -r = 4.18.0-15-generic). I have the NUC connected via USB-C to a dual DisplayPort adapter, to an Avocent SV340D KVM. Also tried kernel v5.0-rc7.

If I have the KVM on the switch for the NUC, everything works great. If I switch the KVM to another channel, and then switch back to the NUC, I only get black screens. The only solution is to hard reboot the NUC.

This relates to a bug I raised on https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1816269.

Specifically [  135.089830] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun followed by a lot of thunderblot hotplug messages.
Comment 1 Lakshmi 2019-03-07 12:28:47 UTC
Ville, any comments here?
Comment 2 Stuart 2019-03-14 23:12:14 UTC
Any additional info I can provide here to help?
Comment 3 Lakshmi 2019-03-15 07:27:51 UTC
Thanks for asking. Can you please verify the issue with latest drmtip?
(https://cgit.freedesktop.org/drm-tip)

This is to ensure that this issue still persists with drmtip. This will be useful during investigation.
Comment 4 Kai-Heng Feng 2019-03-15 08:07:15 UTC
FWIW you can find prebuilt binary [1] for Ubuntu.

[1] https://kernel.ubuntu.com/~kernel-ppa/mainline/drm-tip/
Comment 5 Stuart 2019-03-16 18:18:28 UTC
Created attachment 143696 [details]
updated_dmesg
Comment 6 Stuart 2019-03-16 18:18:37 UTC
@Lakshmi / @Kai-Heng

Tried cod/tip/drm-tip/2019-03-16 mainline build but still same issue.

When I switch over to another KVM input, and switch back to the NUC, black screen and can't do anything. The only way to recover is hard reboot of the NUC.

new dmesg attached.
Comment 7 Stuart 2019-03-16 18:19:29 UTC
Created attachment 143697 [details]
drm-tip install messages

drm-tip install messages
Comment 8 Lakshmi 2019-03-18 08:48:53 UTC
> new dmesg attached.

Can you please set kernel parameters drm.debug=0x1e log_buf_len=4M and attach the log from boot.
Comment 9 Stuart 2019-03-19 01:20:42 UTC
Created attachment 143731 [details]
dmesg with boot parameters

Thanks for the help. Please see attached file for dmesg with boot params.

Let me know what else I can provide.
Comment 10 Stuart 2019-06-17 13:24:12 UTC
HI @Lakshmi,

This still isn't working for me - I even tried another KVM - is there anything further I can provide to help debug?
Comment 11 Swati Sharma 2019-07-16 13:29:24 UTC
Hi @stuart, can you please provide display_info as well?
cat /sys/kernel/debug/dri/0/i915_display_info
Will try reproducing the issue and get back to you.
Comment 12 Lakshmi 2019-08-27 10:56:07 UTC
(In reply to Stuart from comment #10)
> HI @Lakshmi,
> 
> This still isn't working for me - I even tried another KVM - is there
> anything further I can provide to help debug?

(In reply to Swati Sharma from comment #11)
> Hi @stuart, can you please provide display_info as well?
> cat /sys/kernel/debug/dri/0/i915_display_info
> Will try reproducing the issue and get back to you.

No feedback from more than a month. Dropping the priority of the issue to Medium.
Stuart, can you please provide requested details?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.