Bug 10994 - XvPutImage is supposed to be able to draw to DRAWABLEs, but can only draw to Windows
Summary: XvPutImage is supposed to be able to draw to DRAWABLEs, but can only draw to ...
Status: RESOLVED DUPLICATE of bug 21143
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-18 08:50 UTC by Robert Stoddard
Modified: 2009-09-01 02:34 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Stoddard 2007-05-18 08:50:30 UTC
Not sure if this belongs here, however, I cannot find any other place to submit Xv bug reports.

This report pertains to findings on NVidia cards, other video cards may or may not have similar effects, however, the specification of the Xv library is suspect, regardless of whether this bug avails itself on hardware other than NVidia.

The functions of the Xv library suggest that they can draw to DRAWABLEs, however, when they draw to any DRAWABLE other than a Window, the program crashes with the following error:
X Error of failed request:  XvBadPort
  Major opcode of failed request:  141 (XVideo)
  Minor opcode of failed request:  3 ()
  Serial number of failed request:  46
  Current serial number in output stream:  46

I suppose that what is happening here is that the Window has a direct interface with the video card, where the DRAWABLEs do not.  The Xv library requires that the programmer submit a port number when creating the XvImage, and I think that when the XvPutImage or other "Xv Drawing Function" tries to draw to a DRAWABLE, it expects the DRAWABLE to be a surface on the video card.  DRAWABLEs other than Windows are not, however, causing the Xv library to crash.  Possible fixes:

1) change the Xv specification to only be able to draw to Windows (less favorable)
2) Somehow make DRAWABLEs video card surfaces that Xv can draw to
3) Make an intermediate class of DRAWABLE that has a video card surface which can be drawn to by Xv and other extensions that draw using a port, like Xv does.

If this bug does not belong here, please contact me and tell me where I should report this bug... I can't find it  :(
Comment 1 Alan Coopersmith 2008-11-11 10:04:51 UTC
Bugs against X.Org software should be filed under product "Xorg".
"XStandards" is for standard specification documents only.   Reassigning.
Comment 2 Michel Dänzer 2009-09-01 02:34:33 UTC

*** This bug has been marked as a duplicate of bug 21143 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.