Bug 109950 - Stange Artifacts on UHD 605
Summary: Stange Artifacts on UHD 605
Status: RESOLVED DUPLICATE of bug 108085
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-10 19:20 UTC by HJ
Modified: 2019-03-11 16:18 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.log (202.12 KB, application/gzip)
2019-03-10 19:20 UTC, HJ
no flags Details
glxinfo (37.72 KB, text/plain)
2019-03-11 15:27 UTC, HJ
no flags Details
new xorg.log (48.46 KB, text/plain)
2019-03-11 15:28 UTC, HJ
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description HJ 2019-03-10 19:20:33 UTC
Created attachment 143616 [details]
xorg.log

Hi,

I recently bought an Intel NUC with an J5005 CPU and an UHD 605 graphics. and I have strange artifacts at the top of the screen.

@3 seconds: https://drive.google.com/open?id=1_1KrXVlI-KY_KTqanpj1IUokogGCYOxP

this comes every few seconds.
Comment 1 Chris Wilson 2019-03-10 19:57:32 UTC
[ 15420.752] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[ 15420.752] (EE) modeset(0): present flip failed
Comment 2 Chris Wilson 2019-03-10 19:57:48 UTC
gbm or i965 or -modesetting?
Comment 3 Lionel Landwerlin 2019-03-11 01:47:51 UTC
Could you attach the output of glxinfo?
Thanks!
Comment 4 Lionel Landwerlin 2019-03-11 01:50:56 UTC
Actually found the following :

https://bugzilla.redhat.com/show_bug.cgi?id=1645553

https://gitlab.freedesktop.org/xorg/xserver/merge_requests/131

Seems to be modesetting issue.
Comment 5 HJ 2019-03-11 15:27:01 UTC
Also i disabled the compositor as mentioned here: 

https://bugzilla.redhat.com/show_bug.cgi?id=1645553#c8

and the messages are gone, however I still have those artifacts.
Comment 6 HJ 2019-03-11 15:27:32 UTC
Created attachment 143622 [details]
glxinfo
Comment 7 HJ 2019-03-11 15:28:20 UTC
Created attachment 143623 [details]
new xorg.log
Comment 8 Lionel Landwerlin 2019-03-11 15:52:31 UTC
Looks a lot like https://bugs.freedesktop.org/show_bug.cgi?id=108085
I'm inclined to punt it back to i915.

Can you boot your kernel with the following option : i915.enable_fbc=0 
If this goes away then I'll close with duplicate.
Comment 9 Denis 2019-03-11 15:55:23 UTC
there was also one more suggestion to switch from "modesetting" to "intel" driver.


https://bugzilla.redhat.com/show_bug.cgi?id=1645553#c11

for checking driver in use you can do this:

egrep -i " connected|card detect|primary dev|Setting driver" /var/log/Xorg.0.log
Comment 10 HJ 2019-03-11 16:14:13 UTC
>Can you boot your kernel with the following option : i915.enable_fbc=0 

thx that did it!
Comment 11 Lionel Landwerlin 2019-03-11 16:18:19 UTC

*** This bug has been marked as a duplicate of bug 108085 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.