Bug 109953 - Intel Skylake HD520 Screen flickering
Summary: Intel Skylake HD520 Screen flickering
Status: NEEDINFO
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged, ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-11 00:55 UTC by Dominik Klementowski
Modified: 2019-10-01 12:16 UTC (History)
1 user (show)

See Also:
i915 platform: SKL
i915 features: display/Other


Attachments
dmesg output on booted Arch with 5.0.0-rc7-drm-intel-next-git-b4bf44d2dcbd and enabled debug flag (630.12 KB, text/plain)
2019-03-11 00:55 UTC, Dominik Klementowski
no flags Details
dmesg dump after tearing (3.93 MB, text/plain)
2019-09-27 03:08 UTC, Dominik Klementowski
no flags Details
Dmesg dump on SteamOS (4.39 MB, text/plain)
2019-09-30 15:45 UTC, Dominik Klementowski
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dominik Klementowski 2019-03-11 00:55:51 UTC
Created attachment 143620 [details]
dmesg output on booted Arch with 5.0.0-rc7-drm-intel-next-git-b4bf44d2dcbd and enabled debug flag

== Machine details ==

Host: Aspire E5-574 V1.14
CPU: Intel i5-6200U (4) @ 2.700GHz
GPU: Intel Skylake GT2 [HD Graphics 520]
Memory: 15904MiB (2 * 8GB)
Resolution: 1920x1080

== Issue description ==

This problem was already solved for me once. When I bought this laptop I immediately changed its hardware configuration. As far as I remember, that problem was introduced when I extended RAM memory from 1x4GB to 2x8GB. Any Linux OS with any kernel version (that supported Skylake graphics at all) had that issue. System starts normally and image rendering is totally fine, but sometimes I can see that some part of the screen is black for a small fraction of a second. Sometimes I can see some little scratches and distortions too.
Back then I commented on existing, related bug https://bugs.freedesktop.org/show_bug.cgi?id=94605#c87 I posted some dmesg outputs and then Paulo Zanoni posted kernel patches I tested and first patch was enough for me to not experiencing this issue anymore.

For now I modified my hardware configuration again by replacing harddrive (from 256G SSD to 512GB SSD). Unfortunately now the problem is back. I already checked Windows and it works just fine without any flickering nor any distortions at all. I don't know why it happens, maybe new harddrive consumes more power or something.

Anyway there was also something that Paulo Zanoni suggested - sometimes first row of pixels is broken while playing video. Back when we exchanged comments I wasn't able to reproduce this issue, but on regular basis I started to notice green line on top of the screen showin ocasionally when playing fullscreen video.

== Steps to reproduce ==

Simply run any graphical environment with i915 and sooner or later I can experience some broken frames. It feels like it happens the more often, the more GPU resources are used - e.g. playing YouTube video and running Virtual Machine with other OS makes it happening pretty often.
I doesn't seem like X.org related problem, because I can easily reproduce it on the Wayland session.

== Logs ==

When this happens, this appears in dmesg output:

[ 2609.752028] [drm:intel_hpd_irq_handler [i915]] HPD interrupt storm detected on PIN 6
[ 2609.752539] [drm] HPD interrupt storm detected on connector DP-1: switching from hotplug detection to polling

The `dmesg.txt` attachment has full dmesg output. I added kernel parameters drm.debug=0xe and log_buf_len=4M so maybe those logs would be any useful.

== Environments ==

I tried with few different kernel versions and distros and it's the same everywhere:

Arch Linux: Linux 5.0
Arch Linux: Linux 5.0-rc7 (linux-drm-intel-next)
KDE Neon (Ubuntu?): Linux ~4.16
Debian Stable: Linux 4.8

== Summary ==

Since this is not any blocking sort of bug, it is really annoying and breaks the overall experience.
I would be very grateful for help / fixes. From my side, if I only have some time, I can make any tests, compile kernels, provide logs and so on.
Comment 1 Ville Syrjala 2019-03-11 14:21:28 UTC
There's clearly something fishy going on with your machine on account of those interrupt storms. You have no external displays connected right?

The flickers could be underruns (not seeing those in the logs though), or they could be some kind of eDP signal integrity issues.

First thing I would suggest is a BIOS update. Can you try that?
Comment 2 Dominik Klementowski 2019-03-11 14:29:28 UTC
Actually there's no any external screen connected, but sometimes I use external screens and works like a harm both with VGA and HDMI port.

Here's my xrandr --query output

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1920x1080     60.05 +  60.01*   59.97    59.96    59.93
   1680x1050     59.95    59.88
   1400x1050     59.98
   1600x900      59.99    59.94    59.95    59.82
   1280x1024     60.02
   1400x900      59.96    59.88
   1280x960      60.00
   1440x810      60.00    59.97
   1368x768      59.88    59.85
   1280x800      59.99    59.97    59.81    59.91
   1280x720      60.00    59.99    59.86    59.74
   1024x768      60.04    60.00
   960x720       60.00
   928x696       60.05
   896x672       60.01
   1024x576      59.95    59.96    59.90    59.82
   960x600       59.93    60.00
   960x540       59.96    59.99    59.63    59.82
   800x600       60.00    60.32    56.25
   840x525       60.01    59.88
   864x486       59.92    59.57
   700x525       59.98
   800x450       59.95    59.82
   640x512       60.02
   700x450       59.96    59.88
   640x480       60.00    59.94
   720x405       59.51    58.99
   684x384       59.88    59.85
   640x400       59.88    59.98
   640x360       59.86    59.83    59.84    59.32
   512x384       60.00
   512x288       60.00    59.92
   480x270       59.63    59.82
   400x300       60.32    56.34
   432x243       59.92    59.57
   320x240       60.05
   360x202       59.51    59.13
   320x180       59.84    59.32
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)

I think I made BIOS upgrade once, but it was like 2 years ago. I'll check if theres some update available and let you know.
Comment 3 Dominik Klementowski 2019-03-11 14:57:03 UTC
Ok, thanks to my ext-hdd windows I could quickly upgrade BIOS downloaded from acer.com and I upgraded

Changelog: (not full info available)

* Improve touchpad performance
* Update CPU Microcode for Intel SGX security issue

Unfortunately issue remains unchanged.

Oh, I forgot - this kernel message:

[ 2609.752539] [drm] HPD interrupt storm detected on connector DP-1: switching from hotplug detection to polling

It was always here even when there wasn't any (visible?) flickering. And yes - it was always strange that it complains about DP-1 connector which is not even used.
Comment 4 Dominik Klementowski 2019-03-12 12:08:40 UTC
Ok, so today I've done some simple tests and now I think those DP-1 connector messages are not related to eDP-1 internal laptop screen flickering.

First of all I tried to disable this VGA port by doing

echo off > /sys/class/drm/card0-DP-1/status

No change either with those messages and screen flickering, but when I connected ext display to it, it wasn't working until I wrote 'detect' to the same file.

External screen connected to VGA output is normally detected, I can set it up using Plasma Desktop Settings, it works just fine. When it's connected there are no more logs about it in dmesg output. My internal screen still flickers, so I don't think this is related.
Comment 5 Dominik Klementowski 2019-03-13 11:40:49 UTC
It looks like running older kernel with i915.enable_rc6=0 does the trick. I tried Debian Stable on kernel v4.9 with XFCE and it flickers with rc6 enabled while it stops when I disable it. Unfortunately newer kernels does not respect this parameter anymore. I managed to compile Linux 4.9 on my Arch, but for some reason it cannot load Qt5 libraries, so my Desktop can't start. I was able to run Gnome and I was starring at glxgears (~4500fps) for 15 minutes straight. No flickering...

So highly possible this is RC6 related :/
Comment 6 Lakshmi 2019-06-04 10:57:26 UTC
Have you verified the issue with drmtip? (https://cgit.freedesktop.org/drm-tip)
Can you attach the dmesg from boot with drmtip kernel?
Comment 7 Lakshmi 2019-07-13 18:39:20 UTC
Reporter, do you still have the issue with latest drmtip? Can you please confirm?
Comment 8 Dominik Klementowski 2019-07-13 21:50:09 UTC
I haven't been using this laptop for a while, but I haven't sell it yet. I replaced the harddrive so I need to install some distro and I will check this out.
Comment 9 Lakshmi 2019-08-27 10:47:16 UTC
(In reply to Dominik Klementowski from comment #8)
> I haven't been using this laptop for a while, but I haven't sell it yet. I
> replaced the harddrive so I need to install some distro and I will check
> this out.

Any updates here? 
Dropping the priority to Medium until it's confirmed that issue persists with drmtip.
Comment 10 Dominik Klementowski 2019-09-22 13:59:10 UTC
I can only reproduce this issue if I extend this laptop RAM to 16GB (2x8GB DIMM). I installed some Ubuntu-based distro and I used this: https://kernel.ubuntu.com/~kernel-ppa/mainline/drm-tip/2019-09-22/ fresh build of kernel. I confirm, those ocasional flickers and glitches still happen.
Comment 11 Lakshmi 2019-09-24 07:10:57 UTC
(In reply to Dominik Klementowski from comment #10)
> I can only reproduce this issue if I extend this laptop RAM to 16GB (2x8GB
> DIMM). I installed some Ubuntu-based distro and I used this:
> https://kernel.ubuntu.com/~kernel-ppa/mainline/drm-tip/2019-09-22/ fresh
> build of kernel. I confirm, those ocasional flickers and glitches still
> happen.

Issue is not reproducible when the machine has got 8GB RAM?
Can you please attach the latest dmesg (from drmtip) from boot with kernel parameters drm.debug=0x1e log_buf_len=4M?
Comment 12 Dominik Klementowski 2019-09-27 03:08:06 UTC
Created attachment 145536 [details]
dmesg dump after tearing

So I booted up with additional kernel parameters. I run some WebGL benchmark to stress the GPU a little, then I was just watching a YouTube video. The log file I attached should contain some logs that were spit while those artifacts happened. Last glitches were visible like 10 seconds before I dumped those logs.

I'll try to reproduce the problem with 8GB of RAM to make me completely sure if it's not happening with less amount of memory, but that was my impression.
Comment 13 Dominik Klementowski 2019-09-30 15:45:25 UTC
Created attachment 145597 [details]
Dmesg dump on SteamOS

Ok, now I tried to run various different things on that laptop. I run SteamOS and now it seems like the behavior is dependent on what is being rendered. The Steam full screen menu causes a lot of flickering - even few blinks per second. It's the same with both default kernel (which is 4.19) and manually compiled current drm-tip revision.
Comment 14 Lakshmi 2019-10-01 11:59:23 UTC
(In reply to Dominik Klementowski from comment #13)
> Created attachment 145597 [details]
> Dmesg dump on SteamOS
> 

I couldn't find any issues from the logs, is the dmesg from drmtip kernel?
Comment 15 Dominik Klementowski 2019-10-01 12:16:10 UTC
Yes, I cloned and compiled https://github.com/freedesktop/drm-tip


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.