Bug 109956 - [CI][DRMTIP] igt@kms_plane@plane-panning-bottom-right-suspend-pipe-c-planes - dmesg-warn- WARNING: possible circular locking dependency detected/(&dev->struct_mutex)/(&mm->mmap_sem)
Summary: [CI][DRMTIP] igt@kms_plane@plane-panning-bottom-right-suspend-pipe-c-planes -...
Status: RESOLVED DUPLICATE of bug 109385
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-11 07:50 UTC by Lakshmi
Modified: 2019-03-13 08:36 UTC (History)
1 user (show)

See Also:
i915 platform: BSW/CHT
i915 features: power/runtime PM


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-03-11 07:50:12 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_216/fi-bsw-n3050/igt@kms_plane@plane-panning-bottom-right-suspend-pipe-c-planes.html

<4> [61.382525] ======================================================
<4> [61.382528] WARNING: possible circular locking dependency detected
<4> [61.382532] 5.0.0-rc5-g041ba1d6aa0f-drmtip_216+ #1 Tainted: G     U           
<4> [61.382535] ------------------------------------------------------
<4> [61.382538] kms_plane/1072 is trying to acquire lock:
<4> [61.382542] 00000000e7bea55b (&dev->struct_mutex){+.+.}, at: i915_gem_fault+0x1f8/0x850 [i915]
<4> [61.382656] 
but task is already holding lock:
<4> [61.382658] 00000000c73dd26a (&mm->mmap_sem){++++}, at: __do_page_fault+0x133/0x500
<4> [61.382668] 
which lock already depends on the new lock.
Comment 1 CI Bug Log 2019-03-11 08:03:47 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* BSW : igt@kms_plane@plane-panning-bottom-right-suspend-*-dmesg-warn- WARNING: possible circular locking dependency detected/(&amp;dev-&gt;struct_mutex)/(&amp;mm-&gt;mmap_sem) (No new failures associated)
Comment 2 Chris Wilson 2019-03-11 08:37:28 UTC

*** This bug has been marked as a duplicate of bug 109385 ***
Comment 3 Lakshmi 2019-03-13 08:36:12 UTC
The reason why I have created a separate bug is that, assuming acquire and holding lock in this issue is different from the original Bug 109385.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.