Bug 110037 - [CI][SHARDS] igt@kms_plane_multiple@atomic-pipe-[abc]-* - fail - Failed assertion: !mismatch
Summary: [CI][SHARDS] igt@kms_plane_multiple@atomic-pipe-[abc]-* - fail - Failed asser...
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 110114 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-03-13 15:06 UTC by Martin Peres
Modified: 2019-07-02 11:40 UTC (History)
1 user (show)

See Also:
i915 platform: ALL
i915 features: display/atomic


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-03-13 15:06:03 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4882/shard-glk4/igt@kms_plane_multiple@atomic-pipe-a-tiling-yf.html

Starting subtest: atomic-pipe-A-tiling-yf
(kms_plane_multiple:2399) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:419:
(kms_plane_multiple:2399) igt_debugfs-CRITICAL: Failed assertion: !mismatch
(kms_plane_multiple:2399) igt_debugfs-CRITICAL: Last errno: 25, Inappropriate ioctl for device
Subtest atomic-pipe-A-tiling-yf failed.
Comment 1 Martin Peres 2019-03-13 15:06:42 UTC
This is not seen on the legacy path, so marking as an atomic issue.
Comment 2 CI Bug Log 2019-03-13 15:07:28 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* all machines: igt@kms_plane_multiple@atomic-pipe-[abc]-* - fail - Failed assertion: !mismatch, Last errno: 25, Inappropriate ioctl for device (No new failures associated)
Comment 3 CI Bug Log 2019-03-14 13:28:12 UTC
A CI Bug Log filter associated to this bug has been updated:

{- all machines: igt@kms_plane_multiple@atomic-pipe-[abc]-* - fail - Failed assertion: !mismatch, Last errno: 25, Inappropriate ioctl for device -}
{+ all machines: igt@kms_plane_multiple@atomic-pipe-[abc]-* / igt@kms_universal_plane@universal-plane-pipe-* - fail - Failed assertion: !mismatch, Last errno: 25 +}

 No new failures caught with the new filter
Comment 4 Martin Peres 2019-03-14 13:29:04 UTC
*** Bug 110114 has been marked as a duplicate of this bug. ***
Comment 5 Arek Hiler 2019-04-09 13:22:09 UTC
This tests sets all the non-primary planes to be 256x256 (cursor to 128x128) and randomizes their positions, but with a limitation that they can't overhang the visible area.

Then for that data it prepares primary plane, spanning the whole screen, also filled with the same blue color and black holes for each of the other planes, so that the holes would be covered by the overlay planes.

The final result, if blended correctly, should be a solid color on the whole pipe.

We compare the CRC against a CRC we gathered from solid primary plane with nothing overlayed.

This test failing may mean there are inaccuracies in blending planes.

User impact: small, as not much software is using multiple planes, and we have other tests that seem to be fine with 2 planes / cursor.

Recommended next steps: extra logging for plane positions and maybe manual verification/Chamelium capturing the broken frames for manual inspection.
Comment 6 CI Bug Log 2019-04-10 13:12:03 UTC
A CI Bug Log filter associated to this bug has been updated:

{- all machines: igt@kms_plane_multiple@atomic-pipe-[abc]-* / igt@kms_universal_plane@universal-plane-pipe-* - fail - Failed assertion: !mismatch, Last errno: 25 -}
{+ all machines: igt@kms_plane_multiple@atomic-pipe-[abc]-* / igt@kms_universal_plane@universal-plane-pipe-* - fail - Failed assertion: !mismatch +}

 No new failures caught with the new filter
Comment 7 Arek Hiler 2019-04-23 11:38:12 UTC
Seems like the reproduction rate went down. We have seen it ~10 times each drmtip run (https://intel-gfx-ci.01.org/#idle-runs) but drmtip_260 and _261 are clean. drmtip_262 and _263 have seen it only one.
Comment 8 Mika Kahola 2019-05-31 08:29:19 UTC
In case of ICL we run the test all 7 planes enabled, we may run out of bandwidth. This causes fifo underruns and mismatches.
Comment 9 Mika Kahola 2019-06-05 08:22:21 UTC
The bug hasn't appeared lately in shards. Closing this one now. Let's reopen if the issue comes back.
Comment 10 Martin Peres 2019-07-02 11:40:23 UTC
Yeah, it used to happen once every run, and now nothing for the past 72 runs. Closing!
Comment 11 CI Bug Log 2019-07-02 11:40:36 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.