Bug 110098 - [CI][SHARDS] igt@kms_plane_scaling@pipe-[abc]-scaler-with-* - fail - Failed assertion: ret == 0
Summary: [CI][SHARDS] igt@kms_plane_scaling@pipe-[abc]-scaler-with-* - fail - Failed a...
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: high normal
Assignee: Swati Sharma
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-14 08:19 UTC by Lakshmi
Modified: 2019-09-06 13:05 UTC (History)
3 users (show)

See Also:
i915 platform: GLK
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-03-14 08:19:01 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5738/shard-glk9/igt@kms_plane_scaling@pipe-c-scaler-with-pixel-format.html

	
Starting subtest: pipe-C-scaler-with-pixel-format
(kms_plane_scaling:1893) igt_kms-CRITICAL: Test assertion failure function do_display_commit, file ../lib/igt_kms.c:3392:
(kms_plane_scaling:1893) igt_kms-CRITICAL: Failed assertion: ret == 0
(kms_plane_scaling:1893) igt_kms-CRITICAL: Last errno: 22, Invalid argument
(kms_plane_scaling:1893) igt_kms-CRITICAL: error: -22 != 0
Subtest pipe-C-scaler-with-pixel-format failed.
Comment 1 CI Bug Log 2019-03-14 08:23:26 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* GLK: igt@kms_plane_scaling@pipe-[abc]-scaler-with-* - fail - Failed assertion: ret == 0\n.*Last errno: 22, Invalid argument
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2599/shard-glk9/igt@kms_plane_scaling@pipe-c-scaler-with-rotation.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2600/shard-glk9/igt@kms_plane_scaling@pipe-a-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2601/shard-glk9/igt@kms_plane_scaling@pipe-b-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2602/shard-glk9/igt@kms_plane_scaling@pipe-c-scaler-with-rotation.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2603/shard-glk9/igt@kms_plane_scaling@pipe-b-scaler-with-rotation.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2603/shard-glk9/igt@kms_plane_scaling@pipe-c-scaler-with-rotation.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5738/shard-glk9/igt@kms_plane_scaling@pipe-b-scaler-with-rotation.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5738/shard-glk9/igt@kms_plane_scaling@pipe-c-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5738/shard-glk9/igt@kms_plane_scaling@pipe-a-scaler-with-rotation.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4884/shard-glk9/igt@kms_plane_scaling@pipe-a-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12446/shard-glk9/igt@kms_plane_scaling@pipe-b-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2605/shard-glk9/igt@kms_plane_scaling@pipe-c-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5740/shard-glk9/igt@kms_plane_scaling@pipe-c-scaler-with-rotation.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5740/shard-glk9/igt@kms_plane_scaling@pipe-b-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2609/shard-glk9/igt@kms_plane_scaling@pipe-b-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2610/shard-glk9/igt@kms_plane_scaling@pipe-b-scaler-with-rotation.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2610/shard-glk9/igt@kms_plane_scaling@pipe-c-scaler-with-rotation.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2611/shard-glk9/igt@kms_plane_scaling@pipe-b-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5742/shard-glk9/igt@kms_plane_scaling@pipe-b-scaler-with-rotation.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12449/shard-glk9/igt@kms_plane_scaling@pipe-c-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12449/shard-glk9/igt@kms_plane_scaling@pipe-b-scaler-with-rotation.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2612/shard-glk9/igt@kms_plane_scaling@pipe-b-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2615/shard-glk9/igt@kms_plane_scaling@pipe-a-scaler-with-rotation.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2615/shard-glk9/igt@kms_plane_scaling@pipe-b-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2615/shard-glk9/igt@kms_plane_scaling@pipe-b-scaler-with-rotation.html
Comment 2 CI Bug Log 2019-04-10 13:11:07 UTC
A CI Bug Log filter associated to this bug has been updated:

{- GLK: igt@kms_plane_scaling@pipe-[abc]-scaler-with-* - fail - Failed assertion: ret == 0\n.*Last errno: 22, Invalid argument -}
{+ GLK: igt@kms_plane_scaling@pipe-[abc]-scaler-with-* - fail - Failed assertion: ret == 0 +}

 No new failures caught with the new filter
Comment 3 Swati Sharma 2019-08-07 10:25:14 UTC
The issue was first observed in build CI_DRM_5784, now latest execution is CI_DRM_6642. Its already 904 builds we haven't seen the issue and it was occurring with 1.1% reproduction rate. However, what i observe is kms_plane_scaling test itself not getting executed on CI and is removed from the grid. 
@arek or @petri, can you please comment why kms_plane_scaling got removed?
Comment 4 Arek Hiler 2019-08-07 10:31:55 UTC
It seems to be executed:

https://intel-gfx-ci.01.org/tree/drm-tip/shards-all.html?testfilter=kms_plane_scaling

Can you clarify your question?
Comment 5 Swati Sharma 2019-08-07 11:39:24 UTC
Sorry, it was not getting listed on the default view. It got listed with "shards all" view.Thanks!
It can be seen https://intel-gfx-ci.01.org/tree/drm-tip/shards-all.html?testfilter=kms_plane_scaling, issue is not getting reproduced. It can be closed.
Comment 6 Arek Hiler 2019-08-07 11:47:24 UTC
Yep. The default view shows the results only for tests that are not clean passes across all machines. That's done to make the browsing experience acceptable - smaller .json to download, quicker rendering times, less visual noise in the grids.

Do you have any suggestion on how we should communicate the above the the users?
Comment 7 Swati Sharma 2019-09-06 13:02:31 UTC
(In reply to Arek Hiler from comment #6)
> Yep. The default view shows the results only for tests that are not clean
> passes across all machines. That's done to make the browsing experience
> acceptable - smaller .json to download, quicker rendering times, less visual
> noise in the grids.

Thanks Arek for the info.

> Do you have any suggestion on how we should communicate the above the the
> users?

May be hovering over option can tell some info. But existing thing is pretty cool, even w/o any change its great.
Comment 8 Swati Sharma 2019-09-06 13:04:27 UTC
It can be seen https://intel-gfx-ci.01.org/tree/drm-tip/shards-all.html?testfilter=kms_plane_scaling, issue is not getting reproduced. Issue can be closed 10x rule.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.