Bug 110117 - Waking from Suspend causes screen to appear with grey static (like a TV with no signal)
Summary: Waking from Suspend causes screen to appear with grey static (like a TV with ...
Status: NEW
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-15 02:57 UTC by Craig
Modified: 2019-09-10 11:32 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
journalctl -b -1 -k (115.23 KB, text/plain)
2019-03-15 02:57 UTC, Craig
no flags Details
dmesg after reproducing issue and rebooting (117.68 KB, text/plain)
2019-03-16 14:27 UTC, Craig
no flags Details
dmesg where i ssh'd into machine during the screen static (138.37 KB, text/plain)
2019-03-16 14:39 UTC, Craig
no flags Details
Xorg Log around the recreation of the problem (33.80 KB, text/x-log)
2019-03-16 19:36 UTC, Craig
no flags Details
Xorg.old log when the error was reproduced (34.69 KB, application/x-trash)
2019-03-16 19:37 UTC, Craig
no flags Details
Most Recent dmesg with magic number (76.47 KB, text/plain)
2019-05-14 21:13 UTC, Craig
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Craig 2019-03-15 02:57:36 UTC
Created attachment 143671 [details]
journalctl -b -1 -k

I am running Ubuntu 18.10. This is the PH517-61 Acer Predator Helios 500 with the Ryzen processor. I have temporarily disabled suspend. If I do let the laptop suspend and then hit the keyboard I get what appears to be a TV with no signal. At this point I manually power down and then power up again and am able to view things on screen.

I have reported this downstream here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1813820

in log.txt I have attached the output of 'journalctl -b -1 -k'

uname -a: 5.0.2-050002-generic #201903131832 SMP Wed Mar 13 22:35:19 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Loaded newer kernel from this source: https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0.2/

This is a Vega 56 card but here is what I get with this command:
lspci -k | grep -EA3 'VGA|3D|Display'
08:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Vega 10 XT [Radeon RX Vega 64] (rev c7)
	Subsystem: Acer Incorporated [ALI] Vega 10 XT [Radeon RX Vega 64]
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu

glxinfo | grep "OpenGL version"
OpenGL version string: 4.4 (Compatibility Profile) Mesa 18.2.2



Expected Behaviour:
I expect to continue to be able to use my machine normally and be able to see what is happening on screen.

Actual Behaviour:
Static on screen obscures everything.
Comment 1 Nicholas Kazlauskas 2019-03-15 12:33:25 UTC
I don't see anything immediately wrong in the log at the first glance at least so it'd be helpful if you could post your dmesg log from after the problem occurred with drm.debug=4 in your kernel boot parameters.

Please post your xorg log if applicable as well.
Comment 2 Craig 2019-03-16 14:27:07 UTC
Steps I took:
1. added drm.debug=4 to /etc/default/grub
2. sudo update-grub
3. reboot
4. reproduced the issue
5. rebooted using ctrl-sysrq-reisub
6. dumped this dmesg into log.txt
Comment 3 Craig 2019-03-16 14:27:48 UTC
Created attachment 143692 [details]
dmesg after reproducing issue and rebooting
Comment 4 Craig 2019-03-16 14:39:46 UTC
Created attachment 143693 [details]
dmesg where i ssh'd into machine during the screen static
Comment 5 Craig 2019-03-16 19:36:52 UTC
Created attachment 143698 [details]
Xorg Log around the recreation of the problem
Comment 6 Craig 2019-03-16 19:37:35 UTC
Created attachment 143699 [details]
Xorg.old log when the error was reproduced
Comment 7 Craig 2019-04-13 23:12:20 UTC
tested the kernel from here today with the same result: https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.1-rc4/

generic amd64
Comment 8 Craig 2019-04-24 18:30:00 UTC
I have updated to Ubuntu 19.04 and still getting the same result.  Please let me know what steps to take next to get this issue resolved.
Comment 9 Craig 2019-05-14 21:12:34 UTC
I would like to add to this some additional troubleshooting I have performed, in case it is of use.



just a short history: I am unable to suspend with any Linux distribution and be able to resume again. Currently running Ubuntu 19.04.

I am attempting to follow the steps here to trace the problem: https://wiki.ubuntu.com/DebuggingKernelSuspend

This is what I have done so far:

$ sudo apt install pm-utils
$ sudo sh -c "sync && echo 1 > /sys/power/pm_trace && pm-suspend"

I resumed but got my usual screen garbage (looks like static on the screen). I ssh'd in and did a sudo reboot

Right away I ran this:

$ dmesg > dmesg_post_boot.txt

I looked for Magic number in the dmesg per the ubuntu wiki above and found these lines:

[    0.950964]   Magic number: 0:66:1001
[    0.950965]   hash matches drivers/base/power/main.c:1012

Now the instructions are to exclude this module from the next boot and see if I can replicate the problem. How do I exclude main.c or do I even want to? Is it even possible that the bug is here?
Comment 10 Craig 2019-05-14 21:13:15 UTC
Created attachment 144270 [details]
Most Recent dmesg with magic number
Comment 11 leo60228 2019-05-30 21:25:13 UTC
I can reproduce on the same machine, but I get rainbow static, not grey.
Comment 12 Craig 2019-05-30 21:27:22 UTC
yes i should mention most of my static is grey but there are colours in there as well
Comment 13 Alexey Shindin 2019-06-16 10:50:59 UTC
I can confirm this behavior at Ubuntu 18.04.2 LTS with Acer PH517-61 notebook.

The minor addition is that the issue concerns only the built-in display. In two display configuration after wake up the external display seems to be normal.
Comment 14 edo hikmahtiar 2019-06-21 18:26:20 UTC
happened to me too using Opensuse Tumbleweed with kernel 5.1.7 and MESA 19.0.5, I have been try to disable power management in amdgpu via kernel paramater but still happen.
this happen to me while I play some game(s) such Mutant Zero Year and Uboat on the STEAM, while other games seems doesnt trigger this static greyed display such as The Witcher 3
I cant log/reproduce any error messages since I'm using the laptop display (Acer Predator Helios 500 Ryzen 2700 with vega56)
but maybe I can show my recorded video taken from my phone while this display glitch happened.
Comment 15 leo60228 2019-09-10 11:32:56 UTC
This issue also occurs on Windows. AMD support says that it will be fixed in the next Windows update; could they possibly contribute that same fix to Linux?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.