Bug 110143 - Doom 3: BFG Edition - Steam and GOG.com - white flickering screen
Summary: Doom 3: BFG Edition - Steam and GOG.com - white flickering screen
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: 18.3
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-17 06:52 UTC by hx
Modified: 2019-05-06 07:33 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hx 2019-03-17 06:52:55 UTC
Please see the following WINEHQ error report for system information an log: https://bugs.winehq.org/show_bug.cgi?id=46736
Comment 1 hx 2019-03-17 07:01:08 UTC
Additional link to Steam Community fixes, which does not work: https://steamcommunity.com/app/208200/discussions/0/846958724796395601/?ctp=27
Comment 2 andrew.m.mcmahon 2019-03-18 09:24:12 UTC
Just out of interest RBDoom3-BFG works perfectly.
Consider compiling the latest master rather than running Doom 3 through Wine/Proton. Your RX580 shouldn't have any issue - my R9 285 can handle it.
https://github.com/RobertBeckebans/RBDOOM-3-BFG

There's also dhewm 3 for the non-bfg/vanilla edition of doom 3:
https://github.com/dhewm/dhewm3
Comment 3 hx 2019-03-26 19:25:58 UTC
(In reply to andrew.m.mcmahon from comment #2)
> Just out of interest RBDoom3-BFG works perfectly.
> Consider compiling the latest master rather than running Doom 3 through
> Wine/Proton. Your RX580 shouldn't have any issue - my R9 285 can handle it.
> https://github.com/RobertBeckebans/RBDOOM-3-BFG
> 
> There's also dhewm 3 for the non-bfg/vanilla edition of doom 3:
> https://github.com/dhewm/dhewm3

Hi,

Thanks for already known option.

Still - it does not change the fact that something is wrong with mesa driver, that causes wine breaking and therefore game to be unplayable. That means that until this is fixed, this is an Regression.

Also, if you are saying - between the lines - that Mesa devs do not really care as long as there is Linux alternative, then it must be put like this in clear and straight English so that Community is not hoping empty dreams.
Comment 4 Timothy Arceri 2019-03-27 04:35:23 UTC
You have reported nothing that suggests this is a driver bug. You seem to be suggesting it is because of a steam forum [1] comment from 2013 about the windows  Catalyst drivers.

If this is a regression you need to provide information such as, the Mesa version it was working on vs the Mesa version it stopped working on.

[1] https://steamcommunity.com/app/208200/discussions/0/846958724796395601/?ctp=27
Comment 5 Timothy Arceri 2019-05-03 04:02:49 UTC
I've remove the regression tag from the bug title as I don't think this ever worked on Mesa and have sent a patch [1] that should work around some game bugs in future Mesa releases.

[1] https://patchwork.freedesktop.org/patch/303169/
Comment 6 Timothy Arceri 2019-05-06 07:33:35 UTC
Should be fixed by:

commit 1af72fa4d665b9847dff9b22d7a7dea01c0960c7 (HEAD -> master, origin/master, origin/HEAD)
Author: Timothy Arceri <tarceri@itsqueeze.com>
Date:   Fri May 3 13:59:05 2019 +1000

    util/drirc: add workarounds for bugs in Doom 3: BFG
    
    This makes the game playable on radeonsi.
    
    Cc: "19.0" "19.1" <mesa-stable@lists.freedesktop.org>
    Reviewed-by: Samuel Pitoiset <samuel.pitoiset@gmail.com>
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=110143


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.