Bug 110300 - [KBL-R] USB-C external display doesn't work
Summary: [KBL-R] USB-C external display doesn't work
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-01 15:47 UTC by Jason Ekstrand
Modified: 2019-07-02 06:25 UTC (History)
2 users (show)

See Also:
i915 platform: KBL
i915 features: display/USB-C


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Ekstrand 2019-04-01 15:47:14 UTC
Everything worked fine on 4.18 and 4.19 was ok but fickle.  As of 4.20, GNOME shell won't recognize the external display at all.  I plug it in and the main laptop screen goes black and the monitor continues to be in power-save mode.  If I unplug, everything goes back to normal on my laptop.  Maybe the link just never trains?

I've tried with two different Dell monitors with two different USB-C HDMI adapters (Cabel Matters and a Kensington dock) and with and without my KVM switch.  None of it makes a difference.

Hardware: Dell XPS 13 9360 (KBL-R)
Kernel: 4.19.13 is okish, 4.20.15 and 5.0.4 are broken.  All kernels are Fedora builds
Userspace: Fedora 29 with GNOME Wayland, everything updated
Comment 1 Lakshmi 2019-04-02 07:19:58 UTC
Can you please try to reproduce the issue using drm-tip (https://cgit.freedesktop.org/drm-tip) and kernel parameters drm.debug=0x1e log_buf_len=4M, and if the problem persists attach the full dmesg from boot.
Comment 2 Lakshmi 2019-05-02 11:46:10 UTC
Jason, any updates from drmtip?
Comment 3 Jason Ekstrand 2019-05-02 13:56:59 UTC
It doesn't work with drm-tip but I also haven't sat down and gotten logs.  The one update I do have is that I bought a new dock and it works fine.  I think it has something to do with the fact that my old dock supported both HDMI and displayport and did internal MST.
Comment 4 Lakshmi 2019-05-29 11:27:53 UTC
(In reply to Jason Ekstrand from comment #3)
> It doesn't work with drm-tip but I also haven't sat down and gotten logs. 
> The one update I do have is that I bought a new dock and it works fine.  I
> think it has something to do with the fact that my old dock supported both
> HDMI and displayport and did internal MST.

We need dmesg log from drmtip to investigate the issue. Can you please re-test with latest drmtip and attach the logs? This will speed up the investigation.
Comment 5 Lakshmi 2019-07-02 06:25:49 UTC
Need latest logs from drm-tip to investigate the issue.

No feedback for more than a month, closing as resolved works for me.

Please re-open if issue persists with latest drm-tip https://cgit.freedesktop.org/drm-tip and send dmesg from boot with kernel parameters drm.debug=0x1e log_buf_len=4M?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.