Bug 110308 - [KBL]Screen black with some specific refresh rate due to "out of frequency scope"
Summary: [KBL]Screen black with some specific refresh rate due to "out of frequency sc...
Status: RESOLVED NOTOURBUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: Other All
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged, ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-02 14:13 UTC by Ren Chenglei
Modified: 2019-07-25 08:33 UTC (History)
2 users (show)

See Also:
i915 platform: KBL
i915 features: display/Other


Attachments
EDID info (2.58 KB, text/plain)
2019-04-02 14:18 UTC, Ren Chenglei
no flags Details
dmesg log (1.36 MB, text/plain)
2019-04-02 14:21 UTC, Ren Chenglei
no flags Details
DMESG LOG FROM booting (5.11 MB, text/plain)
2019-04-11 08:05 UTC, Ren Chenglei
no flags Details
attachment-18073-0.html (3.22 KB, text/html)
2019-05-01 18:40 UTC, Ren Chenglei
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ren Chenglei 2019-04-02 14:13:21 UTC
Hardware: KBL NUC7i5BNH and display ViewSonic TD2230 
System: Ubuntu 18.04.2 LTS
Kernel: Linux 5.1.0-rc3+ x86_64
Description: When switch to some specific refresh rate, screen black and show with "out of frequency scope", wait for some time it will return to last working mode.
Steps to reproduce: Setting -> Devices -> Displays -> Refresh Rate -> 30.00Hz -> Apply.
Expect results: UI is normal and refresh rate change to 30Hz
Actual results: Screen black and show with "out of frequency scope", wait for some time, it will return to last working mode.
Comment 1 Ren Chenglei 2019-04-02 14:18:56 UTC
Created attachment 143846 [details]
EDID info
Comment 2 Ren Chenglei 2019-04-02 14:21:22 UTC
Created attachment 143847 [details]
dmesg log
Comment 3 Ren Chenglei 2019-04-02 14:22:29 UTC
We could get config error from the dmesg:

[ 5657.209872] [drm:pipe_config_err [i915]] mismatch in dp_m_n (expected tu 64 gmch 5190451/8388608 link 288358/524288, or tu 0 gmch 0/0 link 0/0, found tu 64, gmch 4325376/8388608 link 120149/262144)
[ 5657.209898] [drm:pipe_config_err [i915]] mismatch in base.adjusted_mode.crtc_clock (expected 148500, found 74250)
[ 5657.209920] [drm:pipe_config_err [i915]] mismatch in port_clock (expected 270000, found 162000)
Comment 4 Jani Saarinen 2019-04-05 05:31:48 UTC
Please send full dmesg from beginning.
Comment 5 Lakshmi 2019-04-05 05:46:24 UTC
Is this a duplicate of Bug 109593?
Comment 6 Ren Chenglei 2019-04-11 08:03:54 UTC
(In reply to Jani Saarinen from comment #4)
> Please send full dmesg from beginning.

Please refer to the attachment dmesg_from_booting.txt
Comment 7 Ren Chenglei 2019-04-11 08:05:29 UTC
Created attachment 143936 [details]
DMESG LOG FROM booting
Comment 8 Ren Chenglei 2019-04-11 08:13:34 UTC
(In reply to Lakshmi from comment #5)
> Is this a duplicate of Bug 109593?

Hi Lakshmi, thanks a lot for the sharing, this issue is reproduced on APL and KBL, we will try https://patchwork.freedesktop.org/series/59184/ and share the results here.
Comment 9 Ren Chenglei 2019-04-11 08:29:54 UTC
(In reply to Ren Chenglei from comment #8)
> (In reply to Lakshmi from comment #5)
> > Is this a duplicate of Bug 109593?
> 
> Hi Lakshmi, thanks a lot for the sharing, this issue is reproduced on APL
> and KBL, we will try https://patchwork.freedesktop.org/series/59184/ and
> share the results here.

Hmmm... 59184 seems for ICL, we can't apply it to 4.9 kernel.
Comment 10 Lakshmi 2019-04-11 14:14:37 UTC
(In reply to Ren Chenglei from comment #0)
> Hardware: KBL NUC7i5BNH and display ViewSonic TD2230 
> System: Ubuntu 18.04.2 LTS
> Kernel: Linux 5.1.0-rc3+ x86_64
> Description: When switch to some specific refresh rate, screen black and
> show with "out of frequency scope", wait for some time it will return to
> last working mode.
> Steps to reproduce: Setting -> Devices -> Displays -> Refresh Rate ->
> 30.00Hz -> Apply.
> Expect results: UI is normal and refresh rate change to 30Hz
> Actual results: Screen black and show with "out of frequency scope", wait
> for some time, it will return to last working mode.

How is the display connected? e.g HDMI?

@Clint, any comments from you?
Comment 11 Ren Chenglei 2019-04-11 14:35:29 UTC
(In reply to Lakshmi from comment #10)
> (In reply to Ren Chenglei from comment #0)
> > Hardware: KBL NUC7i5BNH and display ViewSonic TD2230 
> > System: Ubuntu 18.04.2 LTS
> > Kernel: Linux 5.1.0-rc3+ x86_64
> > Description: When switch to some specific refresh rate, screen black and
> > show with "out of frequency scope", wait for some time it will return to
> > last working mode.
> > Steps to reproduce: Setting -> Devices -> Displays -> Refresh Rate ->
> > 30.00Hz -> Apply.
> > Expect results: UI is normal and refresh rate change to 30Hz
> > Actual results: Screen black and show with "out of frequency scope", wait
> > for some time, it will return to last working mode.
> 
> How is the display connected? e.g HDMI?
> 
> @Clint, any comments from you?

Yes, we connect the display with HDMI port.
Comment 12 Clinton Taylor 2019-04-11 17:26:42 UTC
(In reply to Lakshmi from comment #10)
> (In reply to Ren Chenglei from comment #0)
> > Hardware: KBL NUC7i5BNH and display ViewSonic TD2230 
> > System: Ubuntu 18.04.2 LTS
> > Kernel: Linux 5.1.0-rc3+ x86_64
> > Description: When switch to some specific refresh rate, screen black and
> > show with "out of frequency scope", wait for some time it will return to
> > last working mode.
> > Steps to reproduce: Setting -> Devices -> Displays -> Refresh Rate ->
> > 30.00Hz -> Apply.
> > Expect results: UI is normal and refresh rate change to 30Hz
> > Actual results: Screen black and show with "out of frequency scope", wait
> > for some time, it will return to last working mode.
> 
> How is the display connected? e.g HDMI?
> 
> @Clint, any comments from you?

I don't see anything in the dmesg log that would show a failure. The HDMI output on the NUC is using LS/PCON and everything looks normal during the set mode. Did this work prior to Kernel 5.1?

-Clint
Comment 13 Clinton Taylor 2019-04-11 23:15:48 UTC
I updated my KBL NUC with Kernel 5.1.0-rc4 and have not been able to reproduce this issue.
Comment 14 Ren Chenglei 2019-04-12 01:46:55 UTC
(In reply to Clinton Taylor from comment #13)
> I updated my KBL NUC with Kernel 5.1.0-rc4 and have not been able to
> reproduce this issue.

Hi Clint, we tried with 5.1.0-rc3, and could reproduce this issue. Maybe this is related with specific display(ViewSonic TD2230)?
When the issue is reproduced, we could get the following log:

[ 5657.209872] [drm:pipe_config_err [i915]] mismatch in dp_m_n (expected tu 64 gmch 5190451/8388608 link 288358/524288, or tu 0 gmch 0/0 link 0/0, found tu 64, gmch 4325376/8388608 link 120149/262144)
[ 5657.209898] [drm:pipe_config_err [i915]] mismatch in base.adjusted_mode.crtc_clock (expected 148500, found 74250)
[ 5657.209920] [drm:pipe_config_err [i915]] mismatch in port_clock (expected 270000, found 162000)
Comment 15 Ren Chenglei 2019-05-01 18:40:44 UTC
Created attachment 144121 [details]
attachment-18073-0.html

Thanks for your mail. Chenglei will take AL and International Labor Day from Apr 30 to May 8. Email will not be access.
He Yue will be my backup contact on Apr 30 and May 5 - May 8.
For others, you could get to my manager Huang Yuanjun.
For emergency , pls call my mobile: +86 15021037121.

Thanks
Chenglei
Comment 16 Lakshmi 2019-07-13 18:17:05 UTC
@Swati, any help here?
Comment 17 Swati Sharma 2019-07-23 09:05:00 UTC
I will look into it and get back.
Comment 18 Swati Sharma 2019-07-23 09:06:40 UTC
(In reply to Ren Chenglei from comment #14)
> (In reply to Clinton Taylor from comment #13)
> > I updated my KBL NUC with Kernel 5.1.0-rc4 and have not been able to
> > reproduce this issue.
> 
> Hi Clint, we tried with 5.1.0-rc3, and could reproduce this issue. Maybe
> this is related with specific display(ViewSonic TD2230)?
> When the issue is reproduced, we could get the following log:
> 
> [ 5657.209872] [drm:pipe_config_err [i915]] mismatch in dp_m_n (expected tu
> 64 gmch 5190451/8388608 link 288358/524288, or tu 0 gmch 0/0 link 0/0, found
> tu 64, gmch 4325376/8388608 link 120149/262144)
> [ 5657.209898] [drm:pipe_config_err [i915]] mismatch in
> base.adjusted_mode.crtc_clock (expected 148500, found 74250)
> [ 5657.209920] [drm:pipe_config_err [i915]] mismatch in port_clock (expected
> 270000, found 162000)

Hi Ren, 

Can you please attach display_info aswell?
Comment 19 Ren Chenglei 2019-07-24 05:36:05 UTC
@Lakshmi and @Swati, thanks a lot for the help. We have tried this on Windowns, and this issue is also reproduced. So this may be one hardware defect from display side. If possible, could we close this issue?

So sorry for this noise.
Comment 20 Lakshmi 2019-07-25 08:33:15 UTC
(In reply to Ren Chenglei from comment #19)
> @Lakshmi and @Swati, thanks a lot for the help. We have tried this on
> Windowns, and this issue is also reproduced. So this may be one hardware
> defect from display side. If possible, could we close this issue?
> 
> So sorry for this noise.

Thanks for the feedback. Closing this as not a Kernel bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.