Bug 110322 - [CI][DRMTIP] igt@kms_content_protection@* - fail - Content Protection not enabled, Bksv is invalid
Summary: [CI][DRMTIP] igt@kms_content_protection@* - fail - Content Protection not ena...
Status: RESOLVED NOTOURBUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Ramalingam C
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-04 12:34 UTC by Martin Peres
Modified: 2019-08-09 08:08 UTC (History)
1 user (show)

See Also:
i915 platform: ICL
i915 features: display/HDCP


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-04-04 12:34:44 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_247/fi-icl-u3/igt@kms_content_protection@legacy.html

Starting subtest: legacy
(kms_content_protection:1611) CRITICAL: Test assertion failure function test_cp_enable_with_retry, file ../tests/kms_content_protection.c:215:
(kms_content_protection:1611) CRITICAL: Failed assertion: ret
(kms_content_protection:1611) CRITICAL: Last errno: 25, Inappropriate ioctl for device
(kms_content_protection:1611) CRITICAL: Content Protection not enabled

[drm:intel_hdcp_read_valid_bksv.isra.0 [i915]] Bksv is invalid
Comment 1 CI Bug Log 2019-04-04 12:35:25 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* ICL: igt@kms_content_protection@* - fail - Content Protection not enabled, Bksv is invalid (No new failures associated)
Comment 2 Martin Peres 2019-04-04 13:03:22 UTC
+ Ram.

Can you check if this is platform- or machine-specific? I'll update the filter based on your feedback.
Comment 3 Ramalingam C 2019-04-04 13:26:12 UTC
Martin,

This is error log corresponding to an attached panel with invalid BKSV. We can't fix this from I915.
Comment 4 Ramalingam C 2019-04-11 10:43:39 UTC
HDCP sink connected to teh port provides the invalid BKSV. Hence HDCP authentication is expected to fail. This is not a bug in I915. Thanks.
Comment 5 CI Bug Log 2019-08-09 08:01:34 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@kms_content_protection@* - fail - Content Protection not enabled, Bksv is invalid -}
{+ ICL: igt@kms_content_protection@* - fail - Content Protection not enabled, Bksv is invalid +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_338/fi-icl-u3/igt@kms_content_protection@srm.html
Comment 6 CI Bug Log 2019-08-09 08:08:57 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@kms_content_protection@* - fail - Content Protection not enabled, Bksv is invalid -}
{+ ICL: igt@kms_content_protection@* - fail - Content Protection not enabled, Bksv is invalid +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_338/fi-icl-u3/igt@kms_content_protection@lic.html


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.