Bug 110325 - [CI][DRMTIP] igt@kms_content_protection@* - fail - Content Protection not enabled, Timed out waiting for Ri prime match
Summary: [CI][DRMTIP] igt@kms_content_protection@* - fail - Content Protection not ena...
Status: RESOLVED NOTOURBUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Ramalingam C
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-04 12:42 UTC by Martin Peres
Modified: 2019-04-11 10:46 UTC (History)
1 user (show)

See Also:
i915 platform: ICL, SKL
i915 features: display/HDCP


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-04-04 12:42:08 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_247/fi-skl-gvtdvm/igt@kms_content_protection@atomic.html

<7> [48.671022] [drm:_intel_hdcp_enable [i915]] [HDMI-A-1:85] HDCP is being enabled...
<7> [48.986235] [drm:intel_hdcp_auth [i915]] Timed out waiting for Ri prime match (50000)
<7> [48.986666] [drm:_intel_hdcp_enable [i915]] HDCP Auth failure (-110)
<7> [48.986795] [drm:_intel_hdcp_disable [i915]] [HDMI-A-1:85] HDCP is being disabled...
<7> [48.987460] [drm:_intel_hdcp_disable [i915]] HDCP is disabled
<7> [49.323389] [drm:intel_hdcp_auth [i915]] Timed out waiting for Ri prime match (50000)
<7> [49.323454] [drm:_intel_hdcp_enable [i915]] HDCP Auth failure (-110)
<7> [49.323549] [drm:_intel_hdcp_disable [i915]] [HDMI-A-1:85] HDCP is being disabled...
<7> [49.323674] [drm:_intel_hdcp_disable [i915]] HDCP is disabled
<7> [49.642432] [drm:intel_hdcp_auth [i915]] Timed out waiting for Ri prime match (50000)
<7> [49.642473] [drm:_intel_hdcp_enable [i915]] HDCP Auth failure (-110)
<7> [49.642515] [drm:_intel_hdcp_disable [i915]] [HDMI-A-1:85] HDCP is being disabled...
<7> [49.642642] [drm:_intel_hdcp_disable [i915]] HDCP is disabled
<7> [49.642678] [drm:_intel_hdcp_enable [i915]] HDCP authentication failed (3 tries/-110)
Comment 1 CI Bug Log 2019-04-04 12:42:32 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* SKL ICL: igt@kms_content_protection@* - fail - Content Protection not enabled, Timed out waiting for Ri prime match (No new failures associated)
Comment 2 Martin Peres 2019-04-04 13:03:14 UTC
+ Ram.

Can you check if this is platform- or machine-specific? I'll update the filter based on your feedback.
Comment 3 Ramalingam C 2019-04-04 13:23:49 UTC
Martin,

This is a failure from the panel to provide the valid Ri Prime. Thanks.
Comment 4 Ramalingam C 2019-04-04 13:29:03 UTC
(In reply to Ramalingam C from comment #3)
> Martin,
> 
> This is a failure from the panel to provide the valid Ri Prime. Thanks.

I915 can't fix this too.
Comment 5 Ramalingam C 2019-04-11 10:46:14 UTC
HDCP sink connected to the port is providing the invalid Ri. Hence HDCP authentication is expected fail. So this is not a bug in I915. Thanks


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.