Bug 110361 - [CI][DRMTIP] igt@kms_chamelium@hdmi-cmp-planes-random - fail - Failed assertion: false, Conversion not implemented
Summary: [CI][DRMTIP] igt@kms_chamelium@hdmi-cmp-planes-random - fail - Failed asserti...
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: IGT (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-09 06:34 UTC by Lakshmi
Modified: 2019-08-16 14:16 UTC (History)
1 user (show)

See Also:
i915 platform: ICL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-04-09 06:34:32 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_248/fi-icl-u2/igt@kms_chamelium@hdmi-cmp-planes-random.html

Starting subtest: hdmi-cmp-planes-random
(kms_chamelium:1510) igt_fb-CRITICAL: Test assertion failure function fb_convert, file ../lib/igt_fb.c:2691:
(kms_chamelium:1510) igt_fb-CRITICAL: Failed assertion: false
(kms_chamelium:1510) igt_fb-CRITICAL: Conversion not implemented (from format 0x34325258 to 0x32313259)
Subtest hdmi-cmp-planes-random failed.
**** DEBUG ****
(kms_chamelium:1510) igt_chamelium-DEBUG: Resetting the chamelium
(kms_chamelium:1510) DEBUG: Waiting for HDMI-A-2 to disconnect...
(kms_chamelium:1510) DEBUG: Reprobing HDMI-A-2...
(kms_chamelium:1510) DEBUG: Test requirement passed: res = drmModeGetResources(data->drm_fd)
(kms_chamelium:1510) igt_chamelium-DEBUG: Plugging HDMI-A-2
(kms_chamelium:1510) DEBUG: Waiting for HDMI-A-2 to connect...
(kms_chamelium:1510) DEBUG: Reprobing HDMI-A-2...
(kms_chamelium:1510) igt_kms-DEBUG: display: HDMI-A-2: set_pipe(None)
(kms_chamelium:1510) igt_kms-DEBUG: display: HDMI-A-2: Selecting pipe None
(kms_chamelium:1510) igt_kms-DEBUG: display: HDMI-A-2: set_pipe(A)
(kms_chamelium:1510) igt_kms-DEBUG: display: HDMI-A-2: Selecting pipe A
(kms_chamelium:1510) igt_kms-DEBUG: Test requirement passed: plane_idx >= 0 && plane_idx < pipe->n_planes
(kms_chamelium:1510) igt_fb-DEBUG: igt_create_fb_with_bo_size(width=1920, height=1080, format=XR24(0x34325258), modifier=0x0, size=0)
(kms_chamelium:1510) igt_fb-DEBUG: igt_create_fb_with_bo_size(handle=1, pitch=7680)
(kms_chamelium:1510) ioctl_wrappers-DEBUG: Test requirement passed: igt_has_fb_modifiers(fd)
(kms_chamelium:1510) igt_fb-DEBUG: igt_create_fb_with_bo_size(width=1920, height=1080, format=XR24(0x34325258), modifier=0x0, size=0)
(kms_chamelium:1510) igt_fb-DEBUG: igt_create_fb_with_bo_size(handle=2, pitch=7680)
(kms_chamelium:1510) ioctl_wrappers-DEBUG: Test requirement passed: igt_has_fb_modifiers(fd)
(kms_chamelium:1510) igt_fb-DEBUG: Test requirement passed: cairo_surface_status(fb->cairo_surface) == CAIRO_STATUS_SUCCESS
(kms_chamelium:1510) igt_fb-DEBUG: Test requirement passed: cairo_surface_status(fb->cairo_surface) == CAIRO_STATUS_SUCCESS
(kms_chamelium:1510) igt_kms-DEBUG: display: A.0: plane_set_fb(235)
(kms_chamelium:1510) igt_kms-DEBUG: display: A.0: plane_set_size (1920x1080)
(kms_chamelium:1510) igt_kms-DEBUG: display: A.0: fb_set_position(0,0)
(kms_chamelium:1510) igt_kms-DEBUG: display: A.0: fb_set_size(1920x1080)
(kms_chamelium:1510) DEBUG: Using 4 overlay planes
(kms_chamelium:1510) DEBUG: Plane 0: framebuffer size 1327x770
(kms_chamelium:1510) DEBUG: Plane 0: on-crtc size 376x241
(kms_chamelium:1510) DEBUG: Plane 0: on-crtc position 1076x622
(kms_chamelium:1510) DEBUG: Plane 0: in-framebuffer size 1233x402
(kms_chamelium:1510) DEBUG: Plane 0: in-framebuffer position 94x368
(kms_chamelium:1510) igt_fb-DEBUG: igt_create_fb_with_bo_size(width=1327, height=770, format=XR24(0x34325258), modifier=0x0, size=0)
(kms_chamelium:1510) igt_fb-DEBUG: igt_create_fb_with_bo_size(handle=3, pitch=5312)
(kms_chamelium:1510) ioctl_wrappers-DEBUG: Test requirement passed: igt_has_fb_modifiers(fd)
(kms_chamelium:1510) DEBUG: Plane 0: Y212 format (linear) with stride 8128
(kms_chamelium:1510) igt_fb-DEBUG: igt_create_fb_with_bo_size(width=1327, height=770, format=Y212(0x32313259), modifier=0x0, size=0)
(kms_chamelium:1510) igt_fb-DEBUG: igt_create_fb_with_bo_size(handle=4, pitch=8128)
(kms_chamelium:1510) ioctl_wrappers-DEBUG: Test requirement passed: igt_has_fb_modifiers(fd)
(kms_chamelium:1510) igt_fb-CRITICAL: Test assertion failure function fb_convert, file ../lib/igt_fb.c:2691:
(kms_chamelium:1510) igt_fb-CRITICAL: Failed assertion: false
(kms_chamelium:1510) igt_fb-CRITICAL: Conversion not implemented (from format 0x34325258 to 0x32313259)
(kms_chamelium:1510) igt_core-INFO: Stack trace:
(kms_chamelium:1510) igt_core-INFO:   #0 ../lib/igt_core.c:1474 __igt_fail_assert()
(kms_chamelium:1510) igt_core-INFO:   #1 ../lib/igt_fb.c:2692 fb_convert()
(kms_chamelium:1510) igt_core-INFO:   #2 ../lib/igt_fb.c:3003 igt_fb_convert_with_stride()
(kms_chamelium:1510) igt_core-INFO:   #3 ../tests/kms_chamelium.c:982 prepare_randomized_plane()
(kms_chamelium:1510) igt_core-INFO:   #4 ../tests/kms_chamelium.c:1086 test_display_planes_random()
(kms_chamelium:1510) igt_core-INFO:   #5 ../tests/kms_chamelium.c:1452 __real_main1217()
(kms_chamelium:1510) igt_core-INFO:   #6 ../tests/kms_chamelium.c:1217 main()
(kms_chamelium:1510) igt_core-INFO:   #7 ../csu/libc-start.c:344 __libc_start_main()
(kms_chamelium:1510) igt_core-INFO:   #8 [_start+0x2a]
****  END  ****
Subtest hdmi-cmp-planes-random: FAIL (4.860s)
Comment 1 CI Bug Log 2019-04-09 06:35:31 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* ICL: igt@kms_chamelium@hdmi-cmp-planes-random - fail - Failed assertion: false, Conversion not implemented
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_248/fi-icl-u2/igt@kms_chamelium@hdmi-cmp-planes-random.html
Comment 2 CI Bug Log 2019-05-09 06:19:37 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@kms_chamelium@hdmi-cmp-planes-random - fail - Failed assertion: false, Conversion not implemented -}
{+ ICL: igt@kms_chamelium@hdmi-cmp|crc-planes-random - fail - Failed assertion: false, Conversion not implemented +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_281/fi-icl-u2/igt@kms_chamelium@hdmi-crc-planes-random.html
Comment 3 Lakshmi 2019-05-31 11:58:43 UTC
Reproduction rate of this failure is once in 12.33 drmtip runs.
Comment 4 Lakshmi 2019-05-31 12:08:15 UTC
Moving to IGT as igt_fb.c is missing fb format conversion path. 
Also, its a sporadic failure because the resources are choosing randomly (intentionally).
Comment 5 emersion 2019-08-16 14:16:51 UTC
Not seen in 3 months. Closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.